CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   residual plot (http://www.cfd-online.com/Forums/openfoam/76603-residual-plot.html)

subash May 31, 2010 00:55

residual plot
 
Hi,

Is there a way I can plot the residuals(real time) in OpenFoam as it is done in fluent or starcd /ccm.

Please let me know how, if it can be done.

Thanks

ulli May 31, 2010 03:23

Hi Subash,

please see this thread:

http://www.cfd-online.com/Forums/ope...residuals.html


Ulrich

subash May 31, 2010 07:05

hi wolfgang,

I made the necessary changes to the residual file after downloading the file from the thread link that you had specified. But when I run the gnuplot Residuals
i get the following error
gnuplot: /home/research/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libwx_baseu-2.8.so.0)

I think there is a problem with the gnuplot installation.

Is there way I can download the application and reinstall it.

Thank you.


ulli May 31, 2010 07:14

Hi Subash,

yes you have to install gnuplot. Just serach for "gnuplot" in you software installation tool, e.g. Yast for Suse. It will be found.

Best regards

Ulrich

Chris Lucas May 31, 2010 07:15

pyFoam
 
Hi,

install pyFoam "http://openfoamwiki.net/index.php/Contrib_PyFoam" and use pyFoamPlotWatcher

Regards,
Christian

subash June 2, 2010 05:36

Hi Ullrich
I tried installing gnuplot- 4.4.0, but it still gives the same error as mentioned above. I have installed gnuplot-4.4.0 in the folder containing OpenFoam.

Regards
subash

subash June 2, 2010 05:59

Hi christian,

I tried to install pyfoam0.5.3, I followed the instructions given in the link but it gives me the following error
Neither numpy nor Numeric python-package installed. Plotting won't work

is there any other file missing, let me know.

Regards
subash

gschaider June 2, 2010 08:06

Quote:

Originally Posted by subash (Post 261347)
Hi christian,

I tried to install pyfoam0.5.3, I followed the instructions given in the link but it gives me the following error
Neither numpy nor Numeric python-package installed. Plotting won't work

is there any other file missing, let me know.

Regards
subash

You'll have to install one of the two python libraries numpy (prefered) or Numeric. For most Linux-distros there exist packages in the package manager of those distros

Bernhard


All times are GMT -4. The time now is 00:24.