CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Evenly distributed arrows using glyph in ParaView (http://www.cfd-online.com/Forums/openfoam/77056-evenly-distributed-arrows-using-glyph-paraview.html)

kriz June 11, 2010 06:25

Evenly distributed arrows using glyph in ParaView
 
Hi!

Is there a possibility to generate evenly distributed e.g. velocity-arrows with ParaView? Using glyphs, it seems I only have the possibility of choosing an maximum amount of arrows, but they are always distributed in a random manner, sometimes with less arrows in regions of interest!

Is there a solution?

madad2005 June 11, 2010 06:45

That's because a glyph is placed at a point or cell centre (depending whether you have point or cell data). If you want a glyph everywhere then the easiest option is to turn off random and mask points, the latter of which will reduce the number of points in your data-set to, at most, the maximum number of points defined.

To do what you want is fairly straight-forward, however. Follow thsi process:

1) Create a plane (Sources->Plane) in the region your are interested in. For speed, it is best to define the X and Y resolutions as 1 initially.

2) Using Filters->Alphabetical->Resample With DataSet, select your volume data-set as your input and the plane as your source and apply. This will interpolate the volume data onto your plane.

3) You can then turn on glyphs for this region only and will be present for every point in your new grid that you have specified with the plane source (which is current 1 by 1).

4) Increase the X and Y resolution of your plane source to get the desired density of glyphs in your region of interest.

Hope this helps.

kriz June 11, 2010 12:17

Perfect, that was exactly what I was looking for, thanks a lot!

h0dges June 30, 2014 11:10

Sorry to drag up an old thread, but I am running into an error when following madad2005's process.

After defining a plane I then try to apply the filter "Resample with dataset". However, upon selecting an input I get the following error message:

Quote:

ERROR: In C:\DBD\pvs-x64\paraview\src\paraview\VTK\Common\ExecutionMode l\vtkExecutive.cxx, line 754
vtkPVCompositeDataPipeline (000000001A5388E0): Algorithm vtkPProbeFilter(000000001A8060B0) returned failure for request: vtkInformation (000000001A284F10)
Debug: Off
Modified Time: 16439076
Reference Count: 1
Registered Events: (none)
Request: REQUEST_DATA_OBJECT
ALGORITHM_AFTER_FORWARD: 1
FORWARD_DIRECTION: 0
FROM_OUTPUT_PORT: 0

I've uploaded the vts file here for anyone to try (855 KB): http://s000.tinyupload.com/index.php...93358870219734

Please help me! Or tell me if you get the same error, etc..

Thanks


All times are GMT -4. The time now is 06:22.