CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   OpenFOAM 1.7 - openSUSE 11.3 - gcc 4.5.0 (http://www.cfd-online.com/Forums/openfoam/77554-openfoam-1-7-opensuse-11-3-gcc-4-5-0-a.html)

alberto June 27, 2010 00:54

OpenFOAM 1.7 - openSUSE 11.3 - gcc 4.5.0
 
Hello,

I've been trying to compile OpenFOAM 1.7 on openSUSE 11.3 - 64 bit (RC1, since the stable is not out yet) for testing purposes. This distributions comes with gcc 4.5.0.

The compile process fails always due to the same error:

linux64GccDPOpt/options:6: *** Missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created

OpenFOAM 1.7 compiles without problems on openSUSE 11.2.

Any suggestion or similar experience?

Thanks

MartinB June 27, 2010 02:16

Hi Alberto,

although I only compiled OpenFOAM 1.6.x on OpenSUSE 11.3RC, I think it's the same solution here:

One has to add a parameter "-P" to the g++ compiler. I have done this by editing the "~/OpenFOAM/OpenFOAM-1.6.x/wmake/rules/linux64Gcc/general" file, I think. The GFLAGS settings become:
GFLAGS = -D$(WM_ARCH) -DWM_$(WM_PRECISION_OPTION) -P

Well, I had to remove the OpenSUSE 11.3RC again because of trouble with the graphics driver.

Martin

alberto June 27, 2010 02:28

Thanks, I'll try and let you know.

What driver problem? I just fixed one (which will be corrected in the final release too).

MartinB June 27, 2010 02:41

About the driver problem: I were not able to install the proprietary NVIDIA driver, and the open nouveou driver was too slow and too buggy to display anything useful in Paraview.

More hints about a solution can be found here:
http://forums.opensuse.org/get-help-...ia-driver.html

But I were running out of time to get it done... and OpenSUSE 11.2 works fine...

Martin

alberto June 27, 2010 03:10

Your solution works perfectly. Thank you.

Just a clarification: the -P option has to be added to

~/OpenFOAM/OpenFOAM-1.7.0/wmake/rules/General/general

About the nVidia driver, yes, in my case adding "nomodeset" to grub (permanently in /boot/grub/menu.lst at the end of the kernel line) fixed the problem, and I had the weekend to work on it :-)

I'm testing 11.3 because of some nice hardware support feature it has and for the updated KDE, and with your help, also OpenFOAM works on it :-)

l_r_mcglashan June 28, 2010 03:19

I would say this is a bug and needs to be fixed, this problem has been around for a while.

alberto June 28, 2010 03:30

Quote:

Originally Posted by l_r_mcglashan (Post 264763)
I would say this is a bug and needs to be fixed, this problem has been around for a while.

Technically we are talking about unsupported platforms, but yes, I agree. I'll report it in the bug forum.

mattijs June 28, 2010 11:17

We've added -traditional-cpp to the cpp rules for all linux platforms. If you re-get the packs it should be in there. Please let us know if it doesn't work.

Thanks,

Mattijs

alberto June 28, 2010 12:37

It fixes the problem on openSUSE 11.3 RC1.

Thanks.

l_r_mcglashan June 29, 2010 06:20

Cheers, the installation runs smoothly on Fedora 12 and 13.

jackpap July 28, 2010 06:14

-P option
 
What is this -P option for. Do you think it would disrupt compilation with other versions of gcc ? Is there not a way of putting this option in the linux64gcc folder?

mattijs July 28, 2010 06:41

The -P option should have the same effect as the -traditional-cpp flag.

alberto July 28, 2010 11:59

Quote:

Originally Posted by jackpap (Post 269123)
What is this -P option for. Do you think it would disrupt compilation with other versions of gcc ? Is there not a way of putting this option in the linux64gcc folder?

Hi, you do not -P anymore, since the compile options have been modified in OF 1.7.x and made available via the git repository.

Best,


All times are GMT -4. The time now is 04:12.