CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   paraFoam does not show results of Cavity tutorial (http://www.cfd-online.com/Forums/openfoam/78167-parafoam-does-not-show-results-cavity-tutorial.html)

wischenbartj July 14, 2010 12:07

paraFoam does not show results of Cavity tutorial
 
I have just installed openFoam with ParaView 3.8.0 on Ubuntu

I did this by exactly going throw all steps of http://www.openfoam.com/download/ubuntu.php

As written at this side a started the cavity example. Everything working well. But after starting paraFoam I am not able to visualize anything.

In the Pipline Browser I see - in black letters - "cavity.OpenFOAM". Also after turning beside "eye" on and selecting the green "Apply" button i can not see anything.

I also tried "Upsate GUI", Mesh Parts,... but without success.

Can anyone help me ?

wyldckat July 14, 2010 12:52

Greetings Josef and welcome to the forum!

In what language is your Ubuntu working? If it isn't working in English, then try running this before paraFoam:
Code:

export LC_ALL=C
If things now show up, then run this:
Code:

gksu gedit /opt/openfoam170/bin/paraFoam
And add that export line right after the first block of comments in the file.
Save, close and try to run paraFoam again.

Best regards,
Bruno

wischenbartj July 14, 2010 13:14

Thank you for your welcome.


Your tip solved the problem immediately.

:):):):):):)

Josef

DudaAPD July 31, 2010 09:05

Ola Bruno!

Hope you can help me as well.

I am trying to run paraview in ubuntu 10.04 guest with VirtualBox 3.2.6, but I am having problems. What is happening is that after enabling the 3D accelaration I am having this message in the terminal when I try to run paraview:

"OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
ERROR: In /home/opencfd/OpenFOAM/ThirdParty-1.7.0/ParaView-3.8.0/VTK/Rendering/vtkOpenGLExtensionManager.cxx, line 358
vtkOpenGLExtensionManager (0x91d7e60): Extension GL_VERSION_1_5 could not be loaded"

Then paraview opens but the darkblue screem stays in the same place when I move the program window and it stays in front of everything else. For instance if I click on "Open" to open a file, the new window stays behind the darkblue screem (geometry, mesh, etc display). the cavity tutorial seems to work fine.

I have no idea how to solve this. I have installed the guest additions successfully previously.

Muito Obrigado!!!

wyldckat July 31, 2010 14:52

Olá Luiz and welcome to the forum :)

:eek: that's a bad idea turning on 3D acceleration in VMs... at least by my experience. But I haven't tried VirtualBox, so maybe their 3D acceleration system might work properly.

Anyway, the problem you're having with ParaView is the same as some other users have reported when they install the drivers for their graphics card!
I've answered about this before on this thread: http://www.cfd-online.com/Forums/ope...tml#post267127 post #6

You can also try following my instructions to install the official pre-built ParaView 3.8.0: Using the official pre-built ParaView 3.8.0 version with OpenFOAM...

Or you can try rebuilding ParaView 3.8.0, by following the official instructions in OpenFOAM's website.

Best regards,
Bruno

DudaAPD July 31, 2010 17:51

Bruno muito obrigado pela resposta!

I've disabled the 3D acceleration and rebuilt paraview. It seems to be working well at least for the cavity case. Another error I was having before is not happening now.

Thank you again!

Luiz Eduardo

Francesca Scaramuzzino February 26, 2011 16:42

I cannot plot the 2D field for the cavity example with Paraview
 
Hi there, so I'm fresh with paraview..I've tried to run the cavity example and I taped the instructions icoFoam and paraFoam. When I launched paraFoam, Paraview started so I was able to visualize a block and the mesh but not the 2D field. I read in the manual that I should load the 0.5 time data but I cannot find anything when I go to open the file..So, what should I do to view the 2D field that is reported in the on-line manual? Please give me your help

Francesca

wyldckat February 27, 2011 09:32

Greetings Francesca and welcome to the forum!

It's simple:
  • You ran blockMesh, then icoFoam.
  • No errors in sight and you have the 0.1 to 0.5 time folders.
  • You ran paraFoam. ParaView opens with the case folder. You pressed the big green "Apply" button.
  • The mesh/box appears.
  • Now look at the top right half of ParaView's top toolbar and see the "Time" edit box with a spin box to the right (spin box has two triangles, one pointing up and the other down). Click on the top triangle to change the current time snapshot.
  • Then start reading here: Post-processing ;)
To learn more about ParaView and how to use it with OpenFOAM:
Best regards,
Bruno

Francesca Scaramuzzino February 27, 2011 14:29

Bruno thanks a lot...my problem was the set of the time..I thought I should open a file, while it was the simple setting of 0.5 in the time box...then the problem was the colour scale, because I've the new version (blue to red)...anyway at the moment I fixed the problem...but I think I'll ask to you a lot of things in the future..so "be prepared" ;)!

Thanksthanksthanks

Francesca

wyldckat February 27, 2011 19:09

Hi Francesca,

Quote:

Originally Posted by Francesca Scaramuzzino (Post 297193)
but I think I'll ask to you a lot of things in the future..so "be prepared" ;)!

You're welcome. But don't ask just me, because I have a very limited knowledge about CFD :(

Best regards,
Bruno

Francesca Scaramuzzino March 7, 2011 11:30

Hi Bruno,
so I'd like to ask to u help about the format for paraview. I have output files that I opened with tecplot (these files are "var" files) that contains for many zones of the computational domain the informations about thermodynamics variables like temperature, pressure etc..Now, I'd like to open these files in paraview, to do this I should convert the var files into vtk files, I guess. So, what should I do to achieve that?

Best regards

Francesca

wyldckat March 7, 2011 17:30

Hi Francesca,

I've never used Tecplot. All I know about Tecplot is that there is an executable in OpenFOAM named "foamToTecplot360" that can convert OpenFOAM data to Tecplot's format. So my best guess would be to visualize both results in Tecplot, instead of trying to visualize both in ParaView.

Nonetheless, the easiest thing next to that would be to see what formats Tecplot exports to and which ParaView can read. Failing that, then search this forum for "tecplot" and find out which user is working for Tecplot's company, because I vaguely remember someone responded on their behalf a few months ago.

Best regards,
Bruno

Francesca Scaramuzzino March 30, 2011 10:04

x-y plot in paraview
 
Hi Bruno,
I need of your help. I should draw an x-y graph in paraview, where the x axis is the time.
Now I've tried with filters, alphabetical and plot over line but obviously I see a constant line because on the x axis it doesn't show the time. How can I plot for example the velocity vs the time on a graph in paraview?

wyldckat March 30, 2011 20:32

Hi Francesca,

Uhm, I didn't know either, but after searching in google for:
Code:

site:cfd-online.com plot time
I saw this post: http://www.cfd-online.com/Forums/ope...tml#post287523 post #3

I haven't tried it yet, so I can only assume it should work ;)

Best regards and good luck!
Bruno


PS: :eek: I've hit the 1000 posts barrier!

Francesca Scaramuzzino April 3, 2011 11:06

Hi Bruno,
it doesn't work. Listen, I'm trying to do that with the tutorial in the combustion directory, combustion/ras/counterflowflame2D. So, could you try to use the same instructions you post to me and see if, for example, you can visualize the behaviour of the axial velocity vs the time?
Sorry because I know I'm bothering you!
Best regards

Francesca

wyldckat April 3, 2011 12:09

Hi Franscesca,

I played around a bit with the filters but I don't think I found the right solution.

Basically I:
  1. Used the filter "Plot Over Line".
  2. Then click on the button that splits the view in two and selected spreadsheet on the second window.
  3. Selected the results from the "Plot Over Line" by pressing Ctrl+A.
  4. The used the "Plot Selection Over Time".
The result wasn't very comforting... it only showed one line in the plot.

Like I said, I didn't know and basically I still don't know how to solve your problem. But if you use the search tools to search here in the forum, you should find the solution.

Best regards and good luck!
Bruno


All times are GMT -4. The time now is 18:23.