CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

paraview stoped working

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 27, 2010, 08:22
Default paraview stoped working
  #1
New Member
 
Benjamin Nwobodo
Join Date: Sep 2010
Posts: 11
Rep Power: 6
Benjy is on a distinguished road
Hi there,

After copying and recompiling the IcoFoam to my_icoFoam as directed in the OpenFOAM wiki "how to add Temperature to icoFoam" tutorial, the new solver runned successfully.
But unfortunately, running the paraFoam gives the following error:


benjy@benjy-laptop:~/OpenFOAM/benjy-1.7.1/run/my_icoFoam_cavity$ paraFoam
created temporary 'my_icoFoam_cavity.OpenFOAM'
/opt/openfoam171/bin/paraFoam: 142: paraview: not found
benjy@benjy-laptop:~/OpenFOAM/benjy-1.7.1/run/my_icoFoam_cavity$ ^C
benjy@benjy-laptop:~/OpenFOAM/benjy-1.7.1/run/my_icoFoam_cavity$

The paraview does not also work when i try to run other cases from the tutorials.
I am new user of OpenFOAM and don't know what next to do.

Could anyone be of help to me in solving this problem?
Benjy is offline   Reply With Quote

Old   November 27, 2010, 08:36
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Benjamin,

You are not alone on this a solution already exists: After Update Ubuntu "/opt/openfoam171/bin/paraFoam: 142: paraview: not found"

Best regards and good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   November 27, 2010, 09:36
Default
  #3
New Member
 
Benjamin Nwobodo
Join Date: Sep 2010
Posts: 11
Rep Power: 6
Benjy is on a distinguished road
Hi Bruno,

million thanks for the help, it works now. But i get the following warning:

OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.

Benjamin
Benjy is offline   Reply With Quote

Old   November 28, 2010, 10:23
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Benjamin,

Quote:
Originally Posted by Benjy View Post
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
Mmm... let me guess: you are using Ubuntu in a VirtualBox virtual machine? There should be an option in the virtual machine settings, for turning on 3D acceleration, although my experience with this has never been very good (but I only tried it in VMPlayer).

But if you are using Ubuntu in a real machine (i.e., not in a virtual machine), then you haven't installed the graphic card drivers.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 28, 2010, 20:57
Default
  #5
New Member
 
Benjamin Nwobodo
Join Date: Sep 2010
Posts: 11
Rep Power: 6
Benjy is on a distinguished road
Hi Bruno,

You are right. i am using ubuntu in a vitualbox VM and have turned the 3D acceleration ON and it works now perfectly.

Thanks for the efforts.

Benjamin.
Benjy is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview nice animation PyGloo ParaView 4 June 7, 2012 12:34
working with paraview gandesk OpenFOAM 0 November 19, 2010 12:48
ParaView Stopped Working AlanR OpenFOAM 5 April 17, 2010 04:55
ParaView 3.6.1 3D viewer not working will_avoid_comm_solvers OpenFOAM Paraview & paraFoam 2 March 9, 2010 17:13
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41


All times are GMT -4. The time now is 19:28.