CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   paraFoam dumped px_get: Assertion `extent != 0' failed. (

Farshad_Noravesh December 5, 2010 03:46

paraFoam dumped px_get: Assertion `extent != 0' failed.
I installed paraview in fedora13 and openfoam1.7.1 using sudo yum install paraview
paraview works fine but when i type paraFoam inside any case i get:
[farshad@farshad2 cavity]$ paraFoam
created temporary 'cavity.OpenFOAM'
paraview-real: /builddir/build/BUILD/ParaView-3.8.0/VTK/Utilities/vtknetcdf/posixio.c:433: px_get: Assertion `extent != 0' failed.
/home/farshad/OpenFOAM/OpenFOAM-1.7.1/bin/paraFoam: line 119: 11267 Aborted (core dumped) paraview --data="$caseFile"
[farshad@farshad2 cavity]$
please help me.
I have also done:
[farshad@farshad2 PV3FoamReader]$ ./Allwclean
+ wclean libso vtkPV3Readers
wclean vtkPV3Readers
+ PV3FoamReader/Allwclean
+ rm -f '/home/farshad/OpenFOAM/OpenFOAM-1.7.1/lib/linux64GccDPOpt/libPV3FoamReader*'
+ rm -rf PV3FoamReader/Make
+ wclean libso vtkPV3Foam
wclean vtkPV3Foam
[farshad@farshad2 PV3FoamReader]$ ./Allwmake
+ '[' -d /home/farshad/OpenFOAM/ThirdParty-1.7.1/platforms/linux64Gcc/paraview-3.8.0 -a -r /home/farshad/OpenFOAM/ThirdParty-1.7.1/platforms/linux64Gcc/paraview-3.8.0 ']'

wyldckat December 5, 2010 18:52

Greetings Farshad,

The PV3FoamReader plug-in that comes with OpenFOAM needs the development files for ParaView, which don't come with the ParaView version from the repository.

Try following the point number 7 from this blog post: Using the official pre-built ParaView 3.8.0 version with OpenFOAM...

Best regards,

All times are GMT -4. The time now is 22:30.