CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   Installation error OpenFoam1.7x (http://www.cfd-online.com/Forums/openfoam/83428-installation-error-openfoam1-7x.html)

Eren10 December 28, 2010 10:41

Installation error OpenFoam1.7x
 
Hi,

I have installed the Openfoam1.7x " succesfully " (message on shell).

I want now to begin with the tutorials of OpenFoam.
To generate mesh for the cavity tutorial I have typed " blockMesh" command on the shell. And nothing happened.
*edit: after typing "blockMesh" . I get this on the terminal: bash: blockMesh: command not found


Can someone say what the problem is. I though maybe the problem is caused by the installation directory. It is not in mine " home " directory. Maybe due to this there is no OpenFoam commands on mine bash.

I am also new to the Linux system.

Eren10 December 28, 2010 11:20

I have typed the foamInstallationTest. I get the following:

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: TUD08916
OS: Linux version 2.6.32.24-0.2-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /opt/apps/openfoam yes yes
$WM_PROJECT_USER_DIR ...n/OpenFOAM/DASTUD\**********-1.7.1 no no
$WM_THIRD_PARTY_DIR /opt/apps/openfoam/ThirdParty-1.7.1 yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /opt/apps/openfoam/OpenFOAM-1.7.1 yes yes yes

$FOAM_APPBIN ...7.1/applications/bin/linux64GccDPOpt no yes
$FOAM_SITE_APPBIN ...nfoam/site/1.7.1/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...7.1/applications/bin/linux64GccDPOpt no no
$WM_DIR /opt/apps/openfoam/OpenFOAM-1.7.1/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...m/OpenFOAM-1.7.1/lib/linux64GccDPOpt no yes
$FOAM_SITE_LIBBIN ...nfoam/site/1.7.1/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...*******-1.7.1/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH ...1/platforms/linux64Gcc/openmpi-1.4.1 yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.3.4 /usr/bin/gcc
gzip 1.3.12 /usr/bin/gzip
tar 1.20 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /opt/apps/openfoam/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

*** The foam installation contains 1 critical error(s)
*** Review the output for warning messages and consult
*** the installation guide for trouble shooting.

done.


--

I have used a shell-script ( made by an experienced openfoam user) to install the openFoam. And I have found on other openfoam at different directory. maybe I should delete them and try to install it again

nimasam December 28, 2010 13:07

look in following folder , i guess its empty:
/OpenFOAM/OpenFOAM-1.7.x/applications/bin/linuxGccDPOpt

if its empty! you can make a link file and refer to ur previous openFoam 1.7.1
its not the cure just a pain killer;)

wyldckat December 28, 2010 20:28

Greetings to all!

@Eren10: OK, I can only guess that the Linux distribution you are using is OpenSUSE 11.2. As for the installation script, it would help to know which script, since it would make it easier to check what installation steps have been taken.
As for your second post, it seems that you have more than one OpenFOAM installation. The big question is: is any of those OpenFOAM installations still working?

Anyway, the problem you are having is similar to another question made yesterday, about how to have both OpenFOAM 1.7.x and OpenFOAM 1.5-dev installed and still be able to use both. The solution can be found here: http://www.cfd-online.com/Forums/ope...tml#post288626
Read it very carefully and adapt to your situation. Since you gave very little information about how many OpenFOAM installations you have and where you have them, I can't provide a more dedicated solution for your case.

Best regards and good luck!
Bruno

Eren10 December 29, 2010 08:19

Thank you guys for your replies. The problem is solved and it was a easy one :D.


All times are GMT -4. The time now is 09:21.