CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   interFoam 1.6: Initial Co-Number too large (

LarsPT January 10, 2011 06:07

interFoam 1.6: Initial Co-Number too large

I do simulations of capillary flows with interFoam (OF-1.6). I observed Co-Numbers of 700 in the first time steps. So I decreased the maximum time step. Now the Co-Numbers are fine, way below 0.2, but the simulation takes a lot of time because of the small maximum time step limit. Is there a way to specify more advanced options for the automatic time step control or a different solutions to prevent such high Co-Numbers at the initial steps?

Thanks in advance!


nakul January 10, 2011 06:14


I hope this might help: Specify the keyword maxCo in your controlDict with its value being as per your choice but less than 1. Also with put this in controlDict

adjustableTimeStep yes;

This will automatically modify your time step to maintain the "maxCo" limit.

LarsPT January 10, 2011 12:54

Thanks for your answer! I already know and use the automatic time step control.

My problem is that Co is too large only for the first three or four time steps. So I reduced maximum time step to avoid these high Co-Numbers. But now this small time step limits the time step before the Co limit is guilty. So the computation is too slow.

A workaround is that I stop the computation manually after some time and restart it with a higher time step limit. But this is not practical when you want to start a lot of cases.

So is there a more convenient solution to that problem?



akidess January 11, 2011 04:58

You could try using a very small initial deltaT, and setting your maximum deltaT to a reasonable time step. OpenFOAM will gradually increase your time step, so if you are just worried about the first few iterations this should work.

All times are GMT -4. The time now is 20:25.