CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

engrid: Internal volume mesh becoming coarser during boundayr layer addition

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 21, 2011, 11:35
Default engrid: Internal volume mesh becoming coarser during boundayr layer addition
  #1
Senior Member
 
Arne Stahlmann
Join Date: Nov 2009
Location: Hanover, Germany
Posts: 209
Rep Power: 8
Arnoldinho is on a distinguished road
Hi,

maybe it's a stupid question, but I have a problem using engrid for the boundary layer generation in 3D cases. (Sorry for posting the question here, but the engrid forum seems to be down). The orginally created internal (volume) mesh becomes coarser during the boundary layer or generally the volume mesh creation in engrid.

Let's explain the procedure: I have a block of lets say 1x1x1m that is horizontally divided into several (volume) layers. The layers have different resolutions/edge lengths of tet elements. The mesh is created in Salome using the Netgen algorithm; boundary patches have been created and the mesh is exported into .unv format. After conversion with ideasUnvToFoam, the mesh is imported into engrid by Import -> OpenFOAM case. Then I do "edit boundary conditions", create a new volume and set all boundary patches (six, from the cube sides) to green. Then I do "create prismatic boundary layer", pick the boundary condition to refine and set the conditions. The boundary layer is calculated/created as intended. Then I export the new mesh via Export -> OpenFOAM case (grid only).

No I come to the problem: When I open the mesh in Paraview, the surface mesh of the cube edges (outer 2D mesh) is still fine, but the internal (3D) volume mesh of the cube has become very coarse. No different resolutions of the volume layers can be found any more. So, where can I tell engrid to keep the former internal volume mesh resolutions?

Best regards,
Arne
Arnoldinho is offline   Reply With Quote

Old   January 22, 2011, 05:31
Default
  #2
Senior Member
 
Arne Stahlmann
Join Date: Nov 2009
Location: Hanover, Germany
Posts: 209
Rep Power: 8
Arnoldinho is on a distinguished road
Ok, as the engits forum server is working again, the discussion about the topic can be found here http://engits.eu/vanilla/index.php?p...er-creation/p1 ... just for the case someone has the same problem.
Arnoldinho is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error : Self intersecting surface mesh, computing intersections & Error : Impossible velan Open Source Meshers: Gmsh, Netgen, CGNS, ... 1 July 14, 2015 05:54
[ICEM] surface mesh merging problem everest ANSYS Meshing & Geometry 39 June 5, 2013 19:02
mesh missing after import in fluent morteza08 FLUENT 0 July 23, 2010 02:22
Interpolating volume data onto quad surface mesh N.R. CFX 6 June 7, 2007 08:15
Icemcfd 11: Loss of mesh from surface mesh option? Joe CFX 2 March 26, 2007 18:10


All times are GMT -4. The time now is 04:56.