CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Installing Discretizer

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree19Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   October 27, 2013, 11:01
Default
  #21
New Member
 
Massachusetts
Join Date: May 2013
Posts: 4
Rep Power: 4
Ben Chapman is on a distinguished road
Step 1 of the openFoam installation cleared up the 'mpicc' messages

A fresh install solved GUI problem.

When I try to import .stl surface - discretizersetup shuts down

ben@ben-MS-7760:~/OpenFOAM/discretizer$ ./discretizersetup.sh
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/icoFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/simpleFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/rhoPimpleFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/interFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/solidDisplacementFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/solidEquilibriumDisplacementFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/bin/paraFoam
/home/ben/OpenFOAM/ThirdParty-2.1.1/platforms/linux64Gcc/paraview-3.12.0/bin/paraview
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/foamToVTK
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/transformPoints
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/fluentMeshToFoam
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/foamMeshToFluent
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/renumberMesh
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/setFields
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/snappyHexMesh
/home/ben/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64GccDPOpt/bin/blockMesh
execute from /home/ben/OpenFOAM/discretizer/discretizer200, dialogs from /home/ben/OpenFOAM/discretizer/discretizer200
0.0, 0.0, 0.0, 0.0, 0.0, 0.0
currentsize 2
discretizersetup.rb:977:in `to_i': NaN (FloatDomainError)
from discretizersetup.rb:977:in `write_uniform_blockMesh'
from discretizersetup.rb:959:in `onCmdOpenStl'
from discretizersetup.rb:2662:in `run'
from discretizersetup.rb:2662

Ben

Last edited by Ben Chapman; October 27, 2013 at 13:48.
Ben Chapman is offline   Reply With Quote

Old   October 27, 2013, 14:47
Default
  #22
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Ben,

Is it an ASCII or a binary STL file? Because I think Discretizer is not able to handle binary STL files.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 16, 2013, 13:34
Default
  #23
mk2
New Member
 
Join Date: Nov 2013
Posts: 1
Rep Power: 0
mk2 is on a distinguished road
Hello,

I'm a german mechanical engineering student, and i want to install discretizer but i have several problems with the installation. For the first problem i have a solution. But now i have a new problem.

1. Problem - solved:

~/OpenFOAM/discretizer$ sudo gem install fxruby
Fetching: fxruby-1.6.27.gem (100%)
Building native extensions. This could take a while...
ERROR: Error installing fxruby:
ERROR: Failed to build gem native extension.
...

Solution:
You have to remove this code shred '-Werror=format-security' from this file '/usr/lib/ruby/1.9.1/x86_64-linux/rbconfig.rb'. There are two or three lines with this option.

Now 2. problem -solved:

:~/OpenFoam/discretizer$ ./discretizer.sh
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- tableio (LoadError)
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from discretizer.rb:54:in `<main>'

Solution: You have to edit the file 'discretizer.rb'. The files which are in the same directory than discretizer.rb will be loaded in the skript, but a change in ruby will produce a failure. Because the system wide 'gem' librarys will be loaded, since ruby 1.8.x, with the command require. So you have to change the command 'require' to 'require_relative' for the files which are in the same directory than 'discretizer.rb'. That's a change in the ruby language code!

I've changed this lines:

require 'benchmark'
require 'zlib'
require_relative 'tableio'
require_relative 'objectlist'

#require "glmeshbox"
#require 'infoline'
require_relative 'dialogs'
require 'mathn'
require_relative 'methods'
require_relative 'cross'
require_relative 'mesh'


But now i have a new problem again!

If i tipe in the command line 'ruby discretizer.rb', it gives me this back:

/var/lib/gems/1.9.1/gems/fxruby-1.6.28/lib/fox16/exceptions_for_fxerror.rb:14: [BUG] Segmentation fault
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]



I'm using Ubuntu 13.04 with OpenFoam 2.2.2. I'm still using the SolidWorks CFD, but i need OpenFoam for parallel computing!
Maybe someone can help me?

kind regards,

mk2

wyldckat likes this.

Last edited by mk2; November 17, 2013 at 05:54.
mk2 is offline   Reply With Quote

Old   November 17, 2013, 06:05
Default
  #24
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings mk2 and welcome to the forum!

And many thanks for the solution you gave for step #1, because that helped pass the biggest problem that was occuring on Ubuntu 12.10 and above!

I've finished testing the instructions adapted for Ubuntu 13.04 and made them available here: http://openfoamwiki.net/index.php/In...u#Ubuntu_13.04

Please let me know if they work for you as well!

Best regards,
Bruno

edit: Finished writing and testing for Ubuntu 12.10 as well: http://openfoamwiki.net/index.php/In...u#Ubuntu_12.10
edit2: And Ubuntu 13.10: http://openfoamwiki.net/index.php/In...u#Ubuntu_13.10

Last edited by wyldckat; November 17, 2013 at 07:43. Reason: see "edit:" and "edit 2"
wyldckat is offline   Reply With Quote

Old   June 3, 2015, 20:43
Default Installing on Ubuntu 14.04?
  #25
New Member
 
Nat
Join Date: Jul 2013
Posts: 5
Rep Power: 4
Nat9 is on a distinguished road
Hi,

I really would love to try out Discretizer so I would like to install it on Ubuntu 14.04. Should I go with the installation guide for 13.10 and hope for the best?

I have two versions of OpenFoam installed (of211 and of230). Will that cause problem for me? Should I do something special during installation?

Any help would be appreciated! Thanks
Nat9 is offline   Reply With Quote

Old   June 13, 2015, 13:51
Default
  #26
Member
 
Anil Kunwar
Join Date: Jun 2013
Posts: 52
Rep Power: 3
Annier is an unknown quantity at this point
Quote:
Originally Posted by Nat9 View Post

I have two versions of OpenFoam installed (of211 and of230). Will that cause problem for me? Should I do something special during installation?
Hi Nat,
If you are using two versions of OpenFoam, i guess you are using "Aliases" for these two versions. Typing Alias name of a given version of openfoam or given software in terminal means that the environment of the corresponding software is called. However, these two versions of openfoam are installed separately. In my guess, you need to install discretizer twice - by going to folder of each OpenFOAM versions.

Yours Sincerely
Anil Kunwar
Annier is offline   Reply With Quote

Reply

Tags
discretizer, installation, meshing, openfoam, snow leopard

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Discretizer, a free mesh program for CFD (Computational Fluid Dynamics) mahaputra OpenFOAM Meshing & Mesh Conversion 80 June 28, 2015 15:16
Caelinux discretizer front end to openfoam Thouelfaqar OpenFOAM 34 April 26, 2013 13:23
Discretizer questions be_inspired OpenFOAM 3 June 4, 2011 09:46
Discretizer Rajshekar Open Source Meshers: Gmsh, Netgen, CGNS, ... 2 November 23, 2010 12:13
My experience Installing Elmer (Open Source Multi physics programme) on Linux Ahmed Main CFD Forum 3 August 10, 2010 13:42


All times are GMT -4. The time now is 07:08.