CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

snappyHexMesh Issue

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 15, 2011, 02:40
Default snappyHexMesh Issue
  #1
New Member
 
Thomas Walsh
Join Date: Nov 2010
Posts: 17
Rep Power: 6
thomasnwalshiii is on a distinguished road
I have been running into a strange issue with snappyHexMesh. Everytime I try to mesh a certain region with the 'snap' feature selected part of my geometry disappears. The part that disappears is a long narrow section. Curious if anyone else has come across this? The only way I have found to fix this issue is to increase the level of refinement very high. I have posted two picture below. The first shows the mesh with 'snap' turn off and the second with 'snap' turn on. Every other setting is the exact same.
Attached Images
File Type: jpg SolidPic.jpg (75.8 KB, 40 views)
File Type: jpg HolePic.jpg (84.8 KB, 34 views)
thomasnwalshiii is offline   Reply With Quote

Old   March 15, 2011, 06:17
Default
  #2
Member
 
Dan
Join Date: Oct 2010
Location: UK
Posts: 41
Rep Power: 6
dandalf is on a distinguished road
I think I'm running into a similar problem.

I have three .stl files that I exported from a single geometry in Salome, two of them seem to work properly with snappyHexMesh however the third seems to destroy the background mesh.
so that it becomes the only patch with any faces.

I think that for some reason snappyHexMesh is meshing inside the object instead of outside.

Does anyone know a way of switching between internal and external boundary mode for a given solid?

Dandalf
dandalf is offline   Reply With Quote

Old   March 15, 2011, 10:29
Default
  #3
Member
 
Dan
Join Date: Oct 2010
Location: UK
Posts: 41
Rep Power: 6
dandalf is on a distinguished road
After a frustrating morning I managed to sort out my problem,

I had the location in mesh set to,
locationInMesh (0 0 0);

Which evidently was coincidental with an edge I stuch in some random numbers and the problem was fixed!
dandalf is offline   Reply With Quote

Old   March 15, 2011, 14:49
Default More Pics
  #4
New Member
 
Thomas Walsh
Join Date: Nov 2010
Posts: 17
Rep Power: 6
thomasnwalshiii is on a distinguished road
Just for fun I meshed the exterior of my geometry and it seems to work fine with the 'snap' feature selected. I have posted two more pictures. The first shows this exterior mesh with the narrow channel in question on the left. The second picture shows the interior mesh without this channel. Only the location in mesh point was changed. Can anyone explain why this is happening? Do I need more cells to define this narrow channel? As can be seen the current refinement (2) only produces 1 cell width here. It was my understanding that the snap feature had no impact on the castellatedMesh process, but it seems I am wrong.
Attached Images
File Type: jpg External.jpg (61.5 KB, 19 views)
File Type: jpg Internal.jpg (47.9 KB, 20 views)
thomasnwalshiii is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
snappyHexMesh simple help! atareen64 OpenFOAM Native Meshers: snappyHexMesh and Others 0 March 2, 2011 16:52
Createpatch and SnappyHexMesh hm86 OpenFOAM Native Meshers: snappyHexMesh and Others 1 February 3, 2011 10:50
stitchMesh and snappyHexMesh gdbaldw OpenFOAM 0 December 23, 2009 03:09
Problem with snappyHexMesh samiam1000 OpenFOAM 0 October 3, 2009 05:08
SnappyHexMesh not generate mesh first time mavimo OpenFOAM Mesh Utilities 4 August 26, 2008 07:08


All times are GMT -4. The time now is 06:27.