CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

pythonFlu installation error in Ubuntu 10.10

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree4Likes
  • 2 Post By dhasthagheer
  • 2 Post By alexey2petrov

Reply
 
LinkBack Thread Tools Display Modes
Old   April 13, 2011, 05:48
Default pythonFlu installation error in Ubuntu 10.10
  #1
New Member
 
Dhasthagheer
Join Date: Feb 2011
Posts: 14
Rep Power: 7
dhasthagheer is on a distinguished road
Hi there,

I am getting following error while installing pythonFlu (pythonflu171_8.0-1_maverick_i386.deb)


dhastha@Dhastha:~$ sudo dpkg --install pythonflu171_8.0-1_maverick_i386.deb
(Reading database ... 188750 files and directories currently installed.)
Unpacking pythonflu171 (from pythonflu171_8.0-1_maverick_i386.deb) ...
dpkg-deb (subprocess): short read on buffer copy for failed to write to pipe in copy
dpkg-deb: subprocess paste returned error exit status 2
dpkg: error processing pythonflu171_8.0-1_maverick_i386.deb (--install):
short read on buffer copy for backend dpkg-deb during `./usr/local/lib/python2.6/dist-packages/Foam/transportModels/_transportModels_.so'
Errors were encountered while processing:
pythonflu171_8.0-1_maverick_i386.deb
dhasthagheer is offline   Reply With Quote

Old   May 11, 2011, 15:12
Default
  #2
Member
 
alexey2petrov's Avatar
 
Alexey
Join Date: Feb 2010
Posts: 33
Blog Entries: 1
Rep Power: 9
alexey2petrov is on a distinguished road
Quote:
Originally Posted by dhasthagheer View Post
I am getting following error while installing pythonFlu (pythonflu171_8.0-1_maverick_i386.deb)
Hi Dhasthagheer,

I have just bumped on your post by accident. What for to wait so long for someone's answer if there is an official pythonFlu bug tracker?

About the question, have you checked whether the "pythonflu171_8.0-1_maverick_i386.deb" package you downloaded is whole or broken?
Run md5sum Linux utility to verify that it is equal to "d62a707aec5449826a6a0c37ac21a7fd".

Best regards,
Alexey
alexey2petrov is offline   Reply With Quote

Old   May 11, 2011, 22:14
Default
  #3
New Member
 
Dhasthagheer
Join Date: Feb 2011
Posts: 14
Rep Power: 7
dhasthagheer is on a distinguished road
You are right. The package which I downloaded was broken. I downloaded again fresh pythonflu1.7 and installed successfully
dhasthagheer is offline   Reply With Quote

Old   June 7, 2011, 22:20
Default
  #4
New Member
 
Jindo
Join Date: Mar 2011
Location: Germany
Posts: 25
Rep Power: 7
phuchuynh is on a distinguished road
HI !
I am new to OpenFoam.
I need check the my PC : 32bit or 64bit and so I have a "pythonflu" package conformable .
I checked whether the "pythonflu171_8.1-Elvis-1_maverick_i386.deb" package I downloaded.
However, it appeared error.
Plz, can you help me !
thanks !
phuchuynh is offline   Reply With Quote

Old   June 7, 2011, 22:45
Default
  #5
New Member
 
Dhasthagheer
Join Date: Feb 2011
Posts: 14
Rep Power: 7
dhasthagheer is on a distinguished road
Hi phuchuynh

If you want to check your PC is 32 bit or 64 bit, you just type the following command in terminal

Code:
lscpu
It will display all the information of your CPU.

I have some question for you.

What Ubuntu version your are using?
What are the error your are getting?

Please post the error here
alexey2petrov and phuchuynh like this.
dhasthagheer is offline   Reply With Quote

Old   June 7, 2011, 23:24
Default
  #6
New Member
 
Jindo
Join Date: Mar 2011
Location: Germany
Posts: 25
Rep Power: 7
phuchuynh is on a distinguished road
Quote:
Originally Posted by dhasthagheer View Post
Hi phuchuynh

If you want to check your PC is 32 bit or 64 bit, you just type the following command in terminal

Code:
lscpu
It will display all the information of your CPU.

Please post the error here
I commanded in terminal " lscpu"

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
CPU(s): 2
.

I am using Ubuntu version 10.10. I downloaded packages
"pythonflu171_8.1-Elvis-1_maverick_amd64.deb" and "pythonflu171_8.1-Elvis-1_maverick_i386.deb" .So, I will install package ?
Code:
root@phuc:~# dpkg --install pythonflu171_8.1-Elvis-1_maverick_amd64.deb 
(Reading database ... 326011 files and directories currently installed.)
Preparing to replace pythonflu171 8.1-Elvis-1 (using pythonflu171_8.1-Elvis-1_maverick_amd64.deb) ...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named Foam
dpkg: warning: old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named Foam
dpkg: error processing pythonflu171_8.1-Elvis-1_maverick_amd64.deb (--install):
 subprocess new pre-removal script returned error exit status 1
running install
running bdist_egg
running egg_info
writing Foam.egg-info/PKG-INFO
writing top-level names to Foam.egg-info/top_level.txt
writing dependency_links to Foam.egg-info/dependency_links.txt
warning: manifest_maker: standard file '-c' not found
reading manifest file 'Foam.egg-info/SOURCES.txt'
writing manifest file 'Foam.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
warning: install_lib: 'build/lib.linux-x86_64-2.6' does not exist -- no Python modules to install
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying Foam.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying Foam.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying Foam.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying Foam.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating 'dist/Foam-0.0.0-py2.6.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing Foam-0.0.0-py2.6.egg
removing '/usr/local/lib/python2.6/dist-packages/Foam-0.0.0-py2.6.egg' (and everything under it)
creating /usr/local/lib/python2.6/dist-packages/Foam-0.0.0-py2.6.egg
Extracting Foam-0.0.0-py2.6.egg to /usr/local/lib/python2.6/dist-packages
Foam 0.0.0 is already the active version in easy-install.pth

Installed /usr/local/lib/python2.6/dist-packages/Foam-0.0.0-py2.6.egg
Processing dependencies for Foam==0.0.0
Finished processing dependencies for Foam==0.0.0
Errors were encountered while processing:
 pythonflu171_8.1-Elvis-1_maverick_amd64.deb
.

Sorry, because It is long


Thanks !
phuchuynh is offline   Reply With Quote

Old   June 8, 2011, 09:36
Default
  #7
Member
 
alexey2petrov's Avatar
 
Alexey
Join Date: Feb 2010
Posts: 33
Blog Entries: 1
Rep Power: 9
alexey2petrov is on a distinguished road
Hi Phuchuynh,
Quote:
Originally Posted by phuchuynh View Post
Code:
root@phuc:~# dpkg --install pythonflu171_8.1-Elvis-1_maverick_amd64.deb 
(Reading database ... 326011 files and directories currently installed.)
Preparing to replace pythonflu171 8.1-Elvis-1 (using pythonflu171_8.1-Elvis-1_maverick_amd64.deb) ...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named Foam
dpkg: warning: old pre-removal script returned error exit status 1
I have tried to reproduce your case.
I guess you have run the installation procedure for pythonFlu package more then once.
I confirm, that this is a bug in pythonFlu installation and we are going to fix it in next release (in about one month).
For now, we suggest the following workaround.
  1. Remove the broken pythonFlu installation
    sudo mkdir /usr/local/lib/python2.6/dist-packages/Foam
    sudo touch /usr/local/lib/python2.6/dist-packages/Foam/__init__.py
    sudo dpkg -r pythonflu171
  2. Install pythonFlu once again
    sudo dpkg -i <your path to>/pythonflu171_8.1-Elvis-1_maverick_amd64.deb
  3. Check that pythonFlu was successfully installed
    python -c "from Foam import finiteVolume; print finiteVolume"
  4. Do not forget to install pythonFlu based solvers (http://pythonflu.wikidot.com/solvers) you want, for example
    sudo easy_install icoFlux

Hope this will help,
Alexey
francois and phuchuynh like this.

Last edited by alexey2petrov; June 8, 2011 at 10:06.
alexey2petrov is offline   Reply With Quote

Old   June 9, 2011, 03:42
Default
  #8
New Member
 
Jindo
Join Date: Mar 2011
Location: Germany
Posts: 25
Rep Power: 7
phuchuynh is on a distinguished road
Hi alexey2petrov !
That is great !
thanks for your help !

Best regards
phuchuynh is offline   Reply With Quote

Old   June 9, 2011, 07:03
Default
  #9
Senior Member
 
Francois Beaubert
Join Date: Mar 2009
Location: Lille, France
Posts: 138
Rep Power: 9
francois is on a distinguished road
Same problem with natty and same workaround.
You just have to change python2.6 with python2.7 in the procedure above

Thanks for the tip
francois is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.7.1 installation on LINUX UBUNTU 10.10 electrosin OpenFOAM Installation 39 July 1, 2014 07:55
OpenFOAM vs Ubuntu 10.10 64 bit vkrastev OpenFOAM Installation 12 April 23, 2011 10:14
Error in apt-get update for installation of OpenFoam 1.7.1 on Ubuntu 10.10 StuntedChicken OpenFOAM Installation 1 January 9, 2011 11:43
Installation of OpenFOAM-1.6 on Ubuntu 9.10 marval OpenFOAM Installation 2 March 17, 2010 09:33
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 12:27.