CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Previous version with git (

flowris July 5, 2011 09:06

Previous version with git
Dear forum,

Last week I had a good run with a ggi interface. I updated my version of 1.6-ext and when I run the same case again, I have the warning "Uncovered faces found. On master: 12 on slave: 14". The case gets disturbed on the ggi indeed.

Could somebody explain me how to go back to a previous version. When I read the git manual, I find that I have to use the git-bisect command (, but I do not know what the name of the previous version is. I would like to do something like this:

$ git bisect start
$ git bisect bad           
$ git bisect good ???????

But what is the version name I have to fill in where the ?????? are?

cnsidero July 5, 2011 09:40

I also have encountered the GGI bug you have. It looks as though someone has already reported it in the OF-extend bug tracking system:

You can retrieve the names of the commits from the OF-extend sourceforge site: http://openfoam-extend.git.sourcefor...-ext;a=summary
Browse the code to find the potentially offending commit. Use the object name of commit with bisect.

Alternatively, you could used "git show" to get the names of the most recent commits:

Lastly, a possible fix for the problem may have been checked in a few hours ago - there were some GGI commits. I'm going to pull the new changes and try it again.

cnsidero July 6, 2011 22:43

flowris I'd thought I'd report that the ggi error was fixed in those latest commits. No surprise to see it was Hrv's commits so thanks to him.

flowris July 7, 2011 01:37

OK, thanks to both of you. I've got things running again.

All times are GMT -4. The time now is 13:39.