CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

rhoCentralFoam Solver

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 6, 2011, 01:21
Default rhoCentralFoam Solver
  #1
Member
 
venkat
Join Date: Mar 2011
Location: Bangalore,india
Posts: 47
Rep Power: 6
venkataramana is on a distinguished road
hi all,
here i am using a new scheme with rhoCentralFoam Solver, it is compiling without problems, while running the code there are errors given below,
Create time

Create mesh for time = 0

Reading thermophysical properties

Selecting thermodynamics package ePsiThermo<pureMixture<constTransport<specieThermo <hConstThermo<perfectGas>>>>>
Reading field U

Reading thermophysicalProperties

fluxScheme: newScheme

Starting time loop

#0 Foam::error:rintStack(Foam::Ostream&) in "/opt/openfoam171/lib/linuxGccDPOpt/libOpenFOAM.so"
#1 Foam::sigSegv::sigSegvHandler(int) in "/opt/openfoam171/lib/linuxGccDPOpt/libOpenFOAM.so"
#2 Uninterpreted:
#3
in "/root/OpenFOAM/root-1.7.1/applications/bin/linuxGccDPOpt/newSolver"
#4
in "/root/OpenFOAM/root-1.7.1/applications/bin/linuxGccDPOpt/newSolver"
#5
in "/root/OpenFOAM/root-1.7.1/applications/bin/linuxGccDPOpt/newSolver"
#6 __libc_start_main in "/lib/libc.so.6"
#7
in "/root/OpenFOAM/root-1.7.1/applications/bin/linuxGccDPOpt/newSolver"
Segmentation fault

Regards
Venkat
venkataramana is offline   Reply With Quote

Old   July 6, 2011, 03:25
Default
  #2
Senior Member
 
Rickard
Join Date: May 2010
Location: Lund, Skåne, Sweden
Posts: 143
Rep Power: 7
Rickard.Solsjo is on a distinguished road
Printstack is usually divide by zero.
Did you try changing some of the conditions in your 0-directory?
Otherwise, it might just be some mesh problem, try to run blockMesh again or something like this.
Rickard.Solsjo is offline   Reply With Quote

Old   July 6, 2011, 05:07
Default hi Rickard,
  #3
Member
 
venkat
Join Date: Mar 2011
Location: Bangalore,india
Posts: 47
Rep Power: 6
venkataramana is on a distinguished road
thanks for your reply,
no errors with blockMesh,
venkataramana is offline   Reply With Quote

Old   July 20, 2011, 09:58
Default Problem to generate the mesh
  #4
Member
 
R. P.
Join Date: Jul 2010
Location: Brazil
Posts: 63
Rep Power: 7
Rophys is on a distinguished road
hello everybody,

I'm using the rhoCentral Foam (2.0 version) and I have been problems to generate my mesh. My mesh is composed by two regions, the first one is rectangular and the second one is a parallelepiped. For the region when I run the commands blockMesh and checkMesh everything is ok, but when I introduce the second region the openFoam give the following error: "number of edges not aligned or perpendicular to non-empty directions". I substituted the parallelepiped region for other rectangular region and everything works fine. Maybe the openFoam don't accept angles in the mesh ? Somebody could help me ? Thanks
Rophys is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
thobois class engineTopoChangerMesh error Peter_600 OpenFOAM 4 August 2, 2014 09:52
A New Solver for Supersonic Combustion nakul OpenFOAM 6 March 30, 2014 03:00
A New Solver for Supersonic Combustion nakul OpenFOAM Announcements from Other Sources 18 February 19, 2013 08:48
Development of a Low mach PISO solver nishant_hull OpenFOAM Programming & Development 0 August 25, 2009 12:48
why the solver reject it? Anyone with experience? bearcat CFX 6 April 28, 2008 14:08


All times are GMT -4. The time now is 08:51.