CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

OpenFOAM 2.0.0 in paralell

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 8, 2011, 05:40
Default OpenFOAM 2.0.0 in paralell
  #1
Senior Member
 
Andrea Pasquali
Join Date: Sep 2009
Location: Germany
Posts: 142
Rep Power: 7
andrea.pasquali is on a distinguished road
Hi,
I'm trying the new OpenFOAM 2.0.0.
I found that if I try to run in parallel it crashes:
Quote:
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

[0]
[0]
[0] [cluster-exec1:17247] *** An error occurred in MPI_Recv
[cluster-exec1:17247] *** on communicator MPI_COMM_WORLD
[cluster-exec1:17247] *** MPI_ERR_TRUNCATE: message truncated
[cluster-exec1:17247] *** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)
--> FOAM FATAL IO ERROR:
[0] error in IOstream "IOstream" for operation operator>>(Istream&, List<T>&) : reading first token
[0]
[0] file: IOstream at line 0.
[0]
[0] From function IOstream::fatalCheck(const char*) const
[0] in file db/IOstreams/IOstreams/IOstream.C at line 114.
[0]
FOAM parallel run exiting
[0]
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun has exited due to process rank 6 with PID 17247 on
node cluster-exec1 exiting improperly. There are two reasons this could occur:

1. this process did not call "init" before exiting, but others in
the job did. This can cause a job to hang indefinitely while it waits
for all processes to call "init". By rule, if one process calls "init",
then ALL processes must call "init" prior to termination.

2. this process called "init", but exited without calling "finalize".
By rule, all processes that call "init" MUST call "finalize" prior to
exiting or it will be considered an "abnormal termination"

This may have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).
--------------------------------------------------------------------------
Anyone found this error as me?
I run also "foamInstallationTest" but all seem good (I attached the log file).

Thanks for any help

Andrea
Attached Files
File Type: txt log.foamInstallationTest.txt (2.8 KB, 12 views)
__________________
Andrea Pasquali
andrea.pasquali is offline   Reply With Quote

Old   July 8, 2011, 05:56
Default
  #2
Tag
New Member
 
Noureddine TAGUELMIMT
Join Date: Mar 2011
Location: Rouen, France
Posts: 21
Rep Power: 6
Tag is on a distinguished road
i run dieselFoam in parallel, 6 procs are used with any problems ...
Tag is offline   Reply With Quote

Old   July 9, 2011, 05:55
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

@Andrea: read these posts and the links therein:
Another thing that could be useful is knowing if you are using your cluster's MPI or the OpenMPI that comes with OpenFOAM's ThirdParty. If you are using your cluster's MPI, it's also useful to know which is it!?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 28, 2011, 11:12
Default
  #4
Senior Member
 
Aurelien Thinat
Join Date: Jul 2010
Posts: 154
Rep Power: 7
Aurelien Thinat is on a distinguished road
Hi everyone,

I'm facing the same problem but with snappyHexMesh in //. The other applications are working (simpleFoam / interFoam / LTSInterFoam...) in parallel. Here is my problem :Parallel meshing with OP 2.0.0


Did you find any solution with your problem Andrea ?
Aurelien Thinat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wigley Hull with OpenFoam 2.0.0 problem Stephy OpenFOAM Bugs 13 October 14, 2014 23:11
OpenFoam 2.0.0 installation Jan_Peters OpenFOAM Installation 86 April 27, 2012 05:32
MRFSimpleFoam in OpenFOAM 2.0.0 nickmai123 OpenFOAM Running, Solving & CFD 1 August 5, 2011 04:47
Cross-compiling OpenFOAM 1.7.0 on Linux for Windows 32 and 64bits with Mingw-w64 wyldckat OpenFOAM Announcements from Other Sources 3 September 8, 2010 06:25
Modified OpenFOAM Forum Structure and New Mailing-List pete Site News & Announcements 0 June 29, 2009 05:56


All times are GMT -4. The time now is 07:25.