CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   compile problem of paraview 3.8.0 conjucting with Qt4.7.3 (http://www.cfd-online.com/Forums/openfoam/91650-compile-problem-paraview-3-8-0-conjucting-qt4-7-3-a.html)

abbott.hn August 17, 2011 23:38

compile problem of paraview 3.8.0 conjucting with Qt4.7.3
 
hello everyone .
according to the openfoam 11.4 install guide, when i type ./makeParaview in the konsole, i encounted i problem like this:
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QT_QTASSISTANTCLIENT_INCLUDE_DIR (ADVANCED)
used as include directory in directory /usr/local/OpenFOAM/ThirdParty-1.7.1/paraview-3.8.0/Qt/ApplicationComponents

-- Configuring incomplete, errors occurred!


by the way , i have qt 4.7.3 library in my computer.

could anyone help me out or show me where i can find the reference online ?

thanks a lot..

wyldckat August 18, 2011 06:22

Greetings abbott.hn and welcome to the forum!

Mmm, ParaView 3.8 doesn't like very much Qt 4.7 :( There have been some issues with it in the past, so my suggestion is to follow the instructions from this blog post of mine: Building ParaView 3.8.0 with custom Qt 4.6.3

If you still want to use Qt 4.7.3, then check the packages that should be installed, which are shown here: http://www.openfoam.com/download/source.php#x5-21000

Best regards and good luck!
Bruno

abbott.hn August 23, 2011 05:25

i have solved this problem
 
Quote:

Originally Posted by wyldckat (Post 320599)
Greetings abbott.hn and welcome to the forum!

Mmm, ParaView 3.8 doesn't like very much Qt 4.7 :( There have been some issues with it in the past, so my suggestion is to follow the instructions from this blog post of mine: Building ParaView 3.8.0 with custom Qt 4.6.3

If you still want to use Qt 4.7.3, then check the packages that should be installed, which are shown here: http://www.openfoam.com/download/source.php#x5-21000

Best regards and good luck!
Bruno


hello bruno. you are so kind .;).
I have already solved the problem by downlodading the latest Openfoam .the paraview in this package got an version 3.10,and it can be compiled successfully with qt4.7.3 .

appreciate you so much.


All times are GMT -4. The time now is 14:51.