CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

compile problem of paraview 3.8.0 conjucting with Qt4.7.3

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 18, 2011, 00:38
Default compile problem of paraview 3.8.0 conjucting with Qt4.7.3
  #1
New Member
 
zdong
Join Date: Aug 2011
Posts: 15
Rep Power: 5
abbott.hn is on a distinguished road
hello everyone .
according to the openfoam 11.4 install guide, when i type ./makeParaview in the konsole, i encounted i problem like this:
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QT_QTASSISTANTCLIENT_INCLUDE_DIR (ADVANCED)
used as include directory in directory /usr/local/OpenFOAM/ThirdParty-1.7.1/paraview-3.8.0/Qt/ApplicationComponents

-- Configuring incomplete, errors occurred!


by the way , i have qt 4.7.3 library in my computer.

could anyone help me out or show me where i can find the reference online ?

thanks a lot..
abbott.hn is offline   Reply With Quote

Old   August 18, 2011, 07:22
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,433
Blog Entries: 33
Rep Power: 73
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings abbott.hn and welcome to the forum!

Mmm, ParaView 3.8 doesn't like very much Qt 4.7 There have been some issues with it in the past, so my suggestion is to follow the instructions from this blog post of mine: Building ParaView 3.8.0 with custom Qt 4.6.3

If you still want to use Qt 4.7.3, then check the packages that should be installed, which are shown here: http://www.openfoam.com/download/source.php#x5-21000

Best regards and good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   August 23, 2011, 06:25
Default i have solved this problem
  #3
New Member
 
zdong
Join Date: Aug 2011
Posts: 15
Rep Power: 5
abbott.hn is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Greetings abbott.hn and welcome to the forum!

Mmm, ParaView 3.8 doesn't like very much Qt 4.7 There have been some issues with it in the past, so my suggestion is to follow the instructions from this blog post of mine: Building ParaView 3.8.0 with custom Qt 4.6.3

If you still want to use Qt 4.7.3, then check the packages that should be installed, which are shown here: http://www.openfoam.com/download/source.php#x5-21000

Best regards and good luck!
Bruno

hello bruno. you are so kind ..
I have already solved the problem by downlodading the latest Openfoam .the paraview in this package got an version 3.10,and it can be compiled successfully with qt4.7.3 .

appreciate you so much.
abbott.hn is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATTN ALL: SOLUTON TO UDF COMPILE PROBLEM Rizwan Fluent UDF and Scheme Programming 30 March 21, 2014 07:34
ParaView Problem with dsmcFoam xbook OpenFOAM Paraview & paraFoam 4 February 14, 2014 02:09
paraview split screen problem ziemowitzima OpenFOAM Paraview & paraFoam 1 March 16, 2011 16:07
Qt version of Paraview 3.8.0 in OpenFOAM 1.7 waynezw0618 OpenFOAM Installation 10 March 3, 2011 09:53
Compile Problem Leigh FLUENT 3 July 28, 2006 06:31


All times are GMT -4. The time now is 13:57.