CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   error install Paraview 3.10.1 qt (http://www.cfd-online.com/Forums/openfoam/91806-error-install-paraview-3-10-1-qt.html)

preibie August 23, 2011 07:16

error install Paraview 3.10.1 qt
 
Hi,

I want to install OpenFoam 2.0.1 on a server with suse enterprise. The installation of OpenFoam was ok no errors. Now I want to install paraview 3.10.1. The first problem was the missing cmake but I installed cmake 2.8.5. Now my problem is this output:

Code:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QT_QTWEBKIT_INCLUDE_DIR (ADVANCED)
  used as include directory in directory /home/preibisch/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/GUISupport/Qt

-- Configuring incomplete, errors occurred!
    Starting make
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.

real    0m0.005s
user    0m0.004s
sys    0m0.000s
    Done make
    Installing ParaView to /home/preibisch/OpenFOAM/ThirdParty-2.0.1/platforms/linux64Gcc/paraview-3.10.1
make: *** Keine Regel, um »install« zu erstellen.  Schluss.
    ---
    Installation complete for paraview-3.10.1
    Set environment variables:

        export ParaView_DIR=/home/preibisch/OpenFOAM/ThirdParty-2.0.1/platforms/linux64Gcc/paraview-3.10.1
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.10
    ---

Done

I looked for the version of qt:
Code:

QMake version 2.01a
Using Qt version 4.6.2 in /usr/lib64

foamSystemCheck
Code:

Checking basic system...
-----------------------------------------------------------------------
Shell:          /bin/bash
Host:            ansyscfd
OS:              Linux version 2.6.32.36-0.5-default
User:            preibisch


System check: PASS
==================
Continue OpenFOAM installation.

I think the bouth test are OK! :confused:
What is the problem? Can somebody help me?

thanks Preibie

wyldckat August 23, 2011 16:03

Greetings Preibie,

I've got two solutions for you:
  1. Quote:

    Originally Posted by http://albertopassalacqua.com/?p=653
    The steps of the procedure are the following:

    In bold is the package that the error message is referring to. Well, that's at least the solution for openSUSE, so I don't know if it will work for SuSe.
  2. If all else fails, then try following these instructions: Building ParaView 3.10.1 with custom Qt 4.6.4
Best regards,
Bruno

joel.lehikoinen August 24, 2011 01:56

I got the same error when trying to install Paraview on SuSe Linux Enterprise Server 11 SP1. After installing the libQtWebKit-devel Paraview compiled ok, but when I try to start paraview, I just get an error about a missing GLX extension:

Code:

ERROR: In /home/lehikjoe/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x164f920): Could not find a decent visual

...

ERROR: In /home/lehikjoe/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line
611
vtkXOpenGLRenderWindow (0x164f920): GLX not found.  Aborting.


wyldckat August 24, 2011 04:35

This should work:
ParaFoam error could not find a decent visual - solution in post #4

preibie August 24, 2011 06:41

@wyldckat
 
thanks for the help. Your idea was good. I installed the libQtWebKit-devel package and installed without problems paraview and the reader :)

joel.lehikoinen August 24, 2011 10:36

Quote:

Originally Posted by wyldckat (Post 321324)
This should work:
ParaFoam error could not find a decent visual - solution in post #4

This didn't help, but it's not important; I have a working installation of paraview on another box, so I can perform post-processing there.

wyldckat August 24, 2011 16:11

Hi Joel,
Quote:

Originally Posted by joel.lehikoinen (Post 321409)
This didn't help, but it's not important;

Mmm... I vaguely remember that the packages freeglut, glxgears (Debian only, if I'm not mistaken) and the drivers for the graphics card should have the missing GLX stuff. The "Mesa" drivers should also have it, but Mesa is for CPU based graphics, not GPU.

But neither one of these worked before starting ParaView?
  • Code:

    export LIBGL_ALWAYS_INDIRECT=y
  • Or
    Code:

    export LIBGL_ALWAYS_INDIRECT=1
Best regards,
Bruno


All times are GMT -4. The time now is 13:05.