CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM

error install Paraview 3.10.1 qt

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 23, 2011, 08:16
Default error install Paraview 3.10.1 qt
  #1
Member
 
Stefan
Join Date: Jun 2009
Posts: 67
Rep Power: 7
preibie is on a distinguished road
Hi,

I want to install OpenFoam 2.0.1 on a server with suse enterprise. The installation of OpenFoam was ok no errors. Now I want to install paraview 3.10.1. The first problem was the missing cmake but I installed cmake 2.8.5. Now my problem is this output:

Code:
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QT_QTWEBKIT_INCLUDE_DIR (ADVANCED)
   used as include directory in directory /home/preibisch/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/GUISupport/Qt

-- Configuring incomplete, errors occurred!
    Starting make
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.

real    0m0.005s
user    0m0.004s
sys    0m0.000s
    Done make
    Installing ParaView to /home/preibisch/OpenFOAM/ThirdParty-2.0.1/platforms/linux64Gcc/paraview-3.10.1
make: *** Keine Regel, um »install« zu erstellen.  Schluss.
    ---
    Installation complete for paraview-3.10.1
    Set environment variables:

        export ParaView_DIR=/home/preibisch/OpenFOAM/ThirdParty-2.0.1/platforms/linux64Gcc/paraview-3.10.1
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.10
    ---

Done
I looked for the version of qt:
Code:
QMake version 2.01a
Using Qt version 4.6.2 in /usr/lib64
foamSystemCheck
Code:
Checking basic system...
-----------------------------------------------------------------------
Shell:           /bin/bash
Host:            ansyscfd
OS:              Linux version 2.6.32.36-0.5-default
User:            preibisch


System check: PASS
==================
Continue OpenFOAM installation.
I think the bouth test are OK!
What is the problem? Can somebody help me?

thanks Preibie
preibie is offline   Reply With Quote

Old   August 23, 2011, 17:03
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,511
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings Preibie,

I've got two solutions for you:
  1. Quote:
    Originally Posted by http://albertopassalacqua.com/?p=653
    The steps of the procedure are the following:
    In bold is the package that the error message is referring to. Well, that's at least the solution for openSUSE, so I don't know if it will work for SuSe.
  2. If all else fails, then try following these instructions: Building ParaView 3.10.1 with custom Qt 4.6.4
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   August 24, 2011, 02:56
Default
  #3
New Member
 
Joel Lehikoinen
Join Date: Jun 2011
Posts: 26
Rep Power: 5
joel.lehikoinen is on a distinguished road
I got the same error when trying to install Paraview on SuSe Linux Enterprise Server 11 SP1. After installing the libQtWebKit-devel Paraview compiled ok, but when I try to start paraview, I just get an error about a missing GLX extension:

Code:
ERROR: In /home/lehikjoe/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 404
vtkXOpenGLRenderWindow (0x164f920): Could not find a decent visual

...

ERROR: In /home/lehikjoe/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 
611
vtkXOpenGLRenderWindow (0x164f920): GLX not found.  Aborting.
joel.lehikoinen is offline   Reply With Quote

Old   August 24, 2011, 05:35
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,511
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
This should work:
ParaFoam error could not find a decent visual - solution in post #4
wyldckat is offline   Reply With Quote

Old   August 24, 2011, 07:41
Lightbulb @wyldckat
  #5
Member
 
Stefan
Join Date: Jun 2009
Posts: 67
Rep Power: 7
preibie is on a distinguished road
thanks for the help. Your idea was good. I installed the libQtWebKit-devel package and installed without problems paraview and the reader
preibie is offline   Reply With Quote

Old   August 24, 2011, 11:36
Default
  #6
New Member
 
Joel Lehikoinen
Join Date: Jun 2011
Posts: 26
Rep Power: 5
joel.lehikoinen is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
This should work:
ParaFoam error could not find a decent visual - solution in post #4
This didn't help, but it's not important; I have a working installation of paraview on another box, so I can perform post-processing there.
joel.lehikoinen is offline   Reply With Quote

Old   August 24, 2011, 17:11
Default
  #7
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,511
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Joel,
Quote:
Originally Posted by joel.lehikoinen View Post
This didn't help, but it's not important;
Mmm... I vaguely remember that the packages freeglut, glxgears (Debian only, if I'm not mistaken) and the drivers for the graphics card should have the missing GLX stuff. The "Mesa" drivers should also have it, but Mesa is for CPU based graphics, not GPU.

But neither one of these worked before starting ParaView?
  • Code:
    export LIBGL_ALWAYS_INDIRECT=y
  • Or
    Code:
    export LIBGL_ALWAYS_INDIRECT=1
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview nice animation PyGloo ParaView 4 June 7, 2012 13:34
Segmentation fault with paraview 3.10.1 aot OpenFOAM Paraview & paraFoam 2 July 25, 2011 14:43
Newbie: Install ParaView 3.81 on OF-1.6-ext/OpenSuse 11.2? lentschi OpenFOAM Installation 1 March 9, 2011 03:32
Paraview not found fusij OpenFOAM Installation 2 January 1, 2011 21:44
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41


All times are GMT -4. The time now is 14:22.