CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

OpenFOAM installation

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 14, 2011, 12:49
Default OpenFOAM installation
  #1
New Member
 
Hoarau Yannick
Join Date: Mar 2009
Posts: 21
Rep Power: 8
yhoarau is on a distinguished road
Hi,

I would like to install OpenFoam on our University cluster. I'm not superuser so I need to use the provided openmpi and I already have scotch in a directory.
Could someone tell me how to specify the openmpi patch and the scotch path in the installation?

Many thanks,

Yannick
yhoarau is offline   Reply With Quote

Old   October 14, 2011, 14:57
Default
  #2
Senior Member
 
Adhiraj
Join Date: Sep 2010
Location: Pennsylvania, United States
Posts: 101
Rep Power: 6
adhiraj is on a distinguished road
I suppose you can look into the etc directory that is part of OpenFOAM, particularly the files settings.sh, bashrc.
adhiraj is offline   Reply With Quote

Old   October 14, 2011, 17:20
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

Yannick, if mpirun is ready to be used from the command line and you are going to build OpenFOAM 2.0.1/x, then all you have to do is source OpenFOAM's bashrc file like this:
Code:
source $HOME/OpenFOAM/OpenFOAM-2.0.1/etc/bashrc WM_MPLIB=SYSTEMOPENMPI
Start a new terminal window/tab so you can make sure that the environment is set properly and you ready to go!

Or you can do as Adhiraj said and edit OpenFOAM's "etc/bashrc" file and change the WM_MPLIB entry directly to SYSTEMOPENMPI.
If Open-MPI isn't automatically activated in your terminal environment with this option, then edit the "etc/config/settings.sh" file and scroll down until near the end where you can find the SYSTEMOPENMPI entry and tweak it to use your Open-MPI version.

Good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   October 14, 2011, 18:25
Default
  #4
New Member
 
Hoarau Yannick
Join Date: Mar 2009
Posts: 21
Rep Power: 8
yhoarau is on a distinguished road
I did modify the files bashrc and settings.sh. My mpi is openmpi, I check the $MPI_HOME, $MPI_ARCH_PATH and $OPAL_PREFIX and they are correct.

I still have a compilation error :

could not open file ompi/mpi/cxx/pmpicxx.h for source file PstreamGlobals.C

I don't understand why?

Any ideas?

Many many thanks
yhoarau is offline   Reply With Quote

Old   October 16, 2011, 04:12
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Yannick,

OK, if you look that the file "$HOME/OpenFOAM/OpenFOAM-2.0.x/wmake/rules/General/mplibSYSTEMOPENMPI", you'll see that it tries to define the folders that have Open-MPI's header files and library interfaces by running:
Code:
mpicc --showme:compile
mpicc --showme:link
Do these commands give you anything? If not, then see the file "$HOME/OpenFOAM/OpenFOAM-2.0.x/wmake/rules/General/mplibOPENMPI" for ideas.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   October 17, 2011, 04:28
Default Problem with parafoam
  #6
New Member
 
Begoņa
Join Date: Oct 2009
Posts: 28
Rep Power: 7
bego is on a distinguished road
Hello, I have a problem with paraView, I had installed OpenFOAM 2.0.1 and check the system, I had run blockMesh and icoFoam with cavity exemple, but with paraFoam I had the follow error:
ERROR: In /home/begp/OpenFOAM/ThirdParty-2.0.1/ParaView-3.10.1/VTK/Rendering/vtkXOpenGLRenderWindow.cxx, line 611
vtkXOpenGLRenderWindow (0x1d35800): GLX not found. Aborting.


Anybody can help me?
bego is offline   Reply With Quote

Old   October 17, 2011, 10:47
Default
  #7
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Bego,

Either you haven't installed the drivers for your graphics card or you're missing OpenGL libraries... either way, check the link in my signature, I believe I've got some references written down somewhere about this...

Good luck,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFoam 2.0.0 installation Jan_Peters OpenFOAM Installation 86 April 27, 2012 05:32
Critical errors during OpenFoam installation in OpenSuse 11.0 amscosta OpenFOAM 5 May 1, 2009 14:06
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 02:09.