CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   OpenFOAM2.1.0 (http://www.cfd-online.com/Forums/openfoam/95503-openfoam2-1-0-a.html)

ata December 20, 2011 12:25

OpenFOAM2.1.0
 
Hi dear FOAMers
I have a problem. When I want to install openFOAM2.1.0 on my UBUNTU10.04 I got this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package openfoam210

Is any one has the same problem?

p.s. I added OpenFOAM repository to my repositories.

Best regards

Cyp December 20, 2011 15:36

Are you running with Ubuntu 11.10 ?

Toorop December 20, 2011 16:53

Hi,

If you are not a "bughunter", it's generally a good idea to delay the installation of a new OpenFOAM version a couple of days after the release. It usually has some early hiccups and it takes some time to iron it out.

My note about the git install:
The link provided with the git installation guide ambiguously offers the ThirdParty-2.0.0.gtgz as the latest version. The link for the latest and greatest is ThirdParty-2.1.0.tgz.

aat December 20, 2011 17:15

Hello ata,

Tibor has a good point. However, if you would still like to install OpenFOAM 2.1.0, here's how I resolved that problem:

In my case, this was because I had installed Ubuntu 10.04 build called Maverick, while the OpenFOAM repository looks for build name Lucid (10.04 LTS). I got around this by setting VERS to lucid, and then adding the repository as indicated in step 2 (on download page at openfoam.com). After running sudo apt-get update, I was able to run sudo apt-get install successfully.

Perhaps this helps?

-Amish

Cyp December 20, 2011 17:30

Quote:

Originally Posted by aat (Post 336522)
Hello ata,

Tibor has a good point. However, if you would still like to install OpenFOAM 2.1.0, here's how I resolved that problem:

In my case, this was because I had installed Ubuntu 10.04 build called Maverick, while the OpenFOAM repository looks for build name Lucid (10.04 LTS). I got around this by setting VERS to lucid, and then adding the repository as indicated in step 2 (on download page at openfoam.com). After running sudo apt-get update, I was able to run sudo apt-get install successfully.

Perhaps this helps?

-Amish

It was the point I though. It works for me.

philippose December 21, 2011 01:16

Hi,

Just wanted to report that the OpenFOAM-2.1.0 RPM installation for Fedora worked perfectly fine on my Fedora 16 64-bit system.

The only hiccup was, that OpenMPI is installed in a "non-standard" location when a standard install of OpenMPI from the Fedora repositories is done. This requires a manual addition of the following nature before sourcing the OpenFOAM "bashrc" file....:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/openmpi/lib
export PATH=$PATH:/usr/lib64/openmpi/bin
source <OpenFOAM bashrc file>


Philippose

l_r_mcglashan December 21, 2011 04:43

Quote:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/openmpi/lib
export PATH=$PATH:/usr/lib64/openmpi/bin
source <OpenFOAM bashrc file>
'module load openmpi-$arch' is better, as stated in the instructions, but I'll make it clearer.


All times are GMT -4. The time now is 02:33.