CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

OpenFOAM2.1.0

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 20, 2011, 12:25
Default OpenFOAM2.1.0
  #1
ata
Senior Member
 
ata's Avatar
 
ata kamyabi
Join Date: Aug 2009
Location: Kerman
Posts: 322
Rep Power: 9
ata is on a distinguished road
Hi dear FOAMers
I have a problem. When I want to install openFOAM2.1.0 on my UBUNTU10.04 I got this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package openfoam210

Is any one has the same problem?

p.s. I added OpenFOAM repository to my repositories.

Best regards
ata is offline   Reply With Quote

Old   December 20, 2011, 15:36
Default
  #2
Cyp
Senior Member
 
Cyprien
Join Date: Feb 2010
Location: Stanford University
Posts: 230
Rep Power: 9
Cyp is on a distinguished road
Are you running with Ubuntu 11.10 ?
Cyp is offline   Reply With Quote

Old   December 20, 2011, 16:53
Default
  #3
Member
 
Tibor Nyers
Join Date: Jul 2010
Location: Hungary
Posts: 91
Rep Power: 8
Toorop is on a distinguished road
Hi,

If you are not a "bughunter", it's generally a good idea to delay the installation of a new OpenFOAM version a couple of days after the release. It usually has some early hiccups and it takes some time to iron it out.

My note about the git install:
The link provided with the git installation guide ambiguously offers the ThirdParty-2.0.0.gtgz as the latest version. The link for the latest and greatest is ThirdParty-2.1.0.tgz.
Toorop is offline   Reply With Quote

Old   December 20, 2011, 17:15
Default
  #4
aat
New Member
 
Join Date: Oct 2009
Posts: 14
Rep Power: 7
aat is on a distinguished road
Hello ata,

Tibor has a good point. However, if you would still like to install OpenFOAM 2.1.0, here's how I resolved that problem:

In my case, this was because I had installed Ubuntu 10.04 build called Maverick, while the OpenFOAM repository looks for build name Lucid (10.04 LTS). I got around this by setting VERS to lucid, and then adding the repository as indicated in step 2 (on download page at openfoam.com). After running sudo apt-get update, I was able to run sudo apt-get install successfully.

Perhaps this helps?

-Amish
aat is offline   Reply With Quote

Old   December 20, 2011, 17:30
Default
  #5
Cyp
Senior Member
 
Cyprien
Join Date: Feb 2010
Location: Stanford University
Posts: 230
Rep Power: 9
Cyp is on a distinguished road
Quote:
Originally Posted by aat View Post
Hello ata,

Tibor has a good point. However, if you would still like to install OpenFOAM 2.1.0, here's how I resolved that problem:

In my case, this was because I had installed Ubuntu 10.04 build called Maverick, while the OpenFOAM repository looks for build name Lucid (10.04 LTS). I got around this by setting VERS to lucid, and then adding the repository as indicated in step 2 (on download page at openfoam.com). After running sudo apt-get update, I was able to run sudo apt-get install successfully.

Perhaps this helps?

-Amish
It was the point I though. It works for me.
Cyp is offline   Reply With Quote

Old   December 21, 2011, 01:16
Default
  #6
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hi,

Just wanted to report that the OpenFOAM-2.1.0 RPM installation for Fedora worked perfectly fine on my Fedora 16 64-bit system.

The only hiccup was, that OpenMPI is installed in a "non-standard" location when a standard install of OpenMPI from the Fedora repositories is done. This requires a manual addition of the following nature before sourcing the OpenFOAM "bashrc" file....:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/openmpi/lib
export PATH=$PATH:/usr/lib64/openmpi/bin
source <OpenFOAM bashrc file>


Philippose
philippose is offline   Reply With Quote

Old   December 21, 2011, 04:43
Default
  #7
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Quote:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/openmpi/lib
export PATH=$PATH:/usr/lib64/openmpi/bin
source <OpenFOAM bashrc file>
'module load openmpi-$arch' is better, as stated in the instructions, but I'll make it clearer.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:37.