CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   nCellsInCoarsestLevel (http://www.cfd-online.com/Forums/openfoam/96115-ncellsincoarsestlevel.html)

ChrisPro January 12, 2012 14:08

nCellsInCoarsestLevel
 
Hey All!

While running a calculation on 48processors on 8 machines i get the following error when exectuting potentialFoam:

Code:

Calculating potential flow
[0]
[0]
[0] --> FOAM FATAL ERROR:
[0] No coarse levels created, either matrix too small for GAMG or nCellsInCoarsestLevel too large.
    Either choose another solver of reduce nCellsInCoarsestLevel.
[0]
[0]    From function GAMGSolver::GAMGSolver(const word& fieldName,const lduMatrix& matrix,const FieldField<Field, scalar>& interfaceBouCoeffs,const FieldField<Field, scalar>& interfaceIntCoeffs,const lduInterfaceFieldPtrsList& interfaces,const dictionary& solverControls)
[0]    in file matrices/lduMatrix/solvers/GAMG/GAMGSolver.C at line 116.
[0]
FOAM parallel run exiting
[0]

what is nCellsInCoarsestLevel?

i set it to 1 instead of 10 and now at least potentialFoam works. ...but simpleFoam does not konvergate. It even aborts after 3 timesteps. The case runs perfectly when calculated with only 4 processors.

but what did i change with that?

greets
Christian

akidess January 13, 2012 03:14

Read about multigrid methods. During the solution the grid is coarsened, and this parameter tells the algorithm when to stop. 10 is already a very low value, so I have the feeling you are wasting resources running this problem on 48 CPUs. Does your domain have less than 100 000 cells?

ChrisPro January 21, 2012 05:52

Oh Ok!

Thanks!! that was the problem!

Nucleophobe October 9, 2012 13:45

Quote:

Originally Posted by ChrisPro (Post 340407)
Oh Ok!

Thanks!! that was the problem!

Sorry to bring up an old thread, but what did you do to resolve this? I am getting the same error. My case has some processor directories which contain no mesh due to the complexity of its shape. Is this an issue?

Edit: I realized that having empty processor directories was the issue, and remedied this by changing my how my mesh was decomposed (in decomposeParDict).

ChrisPro October 10, 2012 05:21

So have you solved your problem? :)

Either take less processors or use a finer mesh


greets
Christian


All times are GMT -4. The time now is 08:04.