CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   swak4Foam-groovyBC build problem (http://www.cfd-online.com/Forums/openfoam/97401-swak4foam-groovybc-build-problem.html)

zxj160 February 16, 2012 07:31

swak4Foam-groovyBC build problem
 
I got swak4Foam installed. But I want to know whether it has been installed successfully.

inlet
{
type groovyBC;
//type fixedValue
// log-law expression
variables "u_f=0.02;z0=0.0003;z_f=pos().y;K=0.4;vel=(u_f/K)*log((z_f+z0)/z0);";
valueExpression "vector (vel,0,0)";
}

When I set an velocity inlet using groovyBC, there is an error below:

--> FOAM Warning :
From function groovyBCFvPatchField<Type>::groovyBCFvPatchField(c onst fvPatch& p,const DimensionedField<Type, volMesh>& iF,const dictionary& dict)
in file groovyBCFvPatchField.C at line 119
No value defined for U on inlet therefore using 50{(0 0 0)}

zxj160 February 16, 2012 07:38

The install information (some of the long messages),

In the swak4Foam, wmake all


Bison is version 2.3
No 'swakConfiguration'. Python etc won't work
OpenFOAM-version: Major 2 Minor 0 Patch 1
No Libraries/swak4FoamParsers/foamVersion4swak.H. Generated
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file SurfacesRepository.C
Making dependency list for source file SetsRepository.C
Making dependency list for source file GlobalVariablesRepository.C
Making dependency list for source file ExpressionDriverWriter.C
Making dependency list for source file ExpressionResult.C
Making dependency list for source file StoredExpressionResult.C
Making dependency list for source file swakRegistryProxySurface.C
Making dependency list for source file swakRegistryProxySet.C
Making dependency list for source file FieldValueExpressionParser.yy
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionParser.yy
Making dependency list for source file PatchValueExpressionParser.yy
could not open file PatchValueExpressionParser.tab.hh for source file PatchValueExpressionParser.yy
Making dependency list for source file SubsetValueExpressionParser.yy
could not open file SubsetValueExpressionParser.tab.hh for source file SubsetValueExpressionParser.yy
Making dependency list for source file CommonValueExpressionDriver.C
Making dependency list for source file makeSwakDataEntry.C
Making dependency list for source file FieldValueExpressionLexer.ll
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionLexer.ll
Making dependency list for source file FieldValueExpressionDriver.C
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionDriver.C
Making dependency list for source file PatchValueExpressionLexer.ll
could not open file PatchValueExpressionParser.tab.hh for source file PatchValueExpressionLexer.ll
Making dependency list for source file PatchValueExpressionDriver.C
could not open file PatchValueExpressionParser.tab.hh for source file PatchValueExpressionDriver.C
could not open file FieldValueExpressionParser.tab.hh for source file PatchValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file PatchValueExpressionDriver.C
Making dependency list for source file SubsetValueExpressionLexer.ll
could not open file SubsetValueExpressionParser.tab.hh for source file SubsetValueExpressionLexer.ll
Making dependency list for source file SubsetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SubsetValueExpressionDriver.C
Making dependency list for source file SetSubsetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SetSubsetValueExpressionDriver.C
Making dependency list for source file CellSetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file CellSetValueExpressionDriver.C
Making dependency list for source file FaceSetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file FaceSetValueExpressionDriver.C
Making dependency list for source file CellZoneValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file CellZoneValueExpressionDriver.C
Making dependency list for source file FaceZoneValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file FaceZoneValueExpressionDriver.C
Making dependency list for source file SampledSurfaceValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SampledSurfaceValueExpressionDriver.C
Making dependency list for source file SampledSetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SampledSetValueExpressionDriver.C
Making dependency list for source file initSwakFunctionObject.C
SOURCE=SurfacesRepository.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/SurfacesRepository.o
SOURCE=SetsRepository.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/SetsRepository.o
SOURCE=GlobalVariablesRepository.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/GlobalVariablesRepository.o
SOURCE=ExpressionDriverWriter.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/ExpressionDriverWriter.o
SOURCE=ExpressionResult.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/ExpressionResult.o
ExpressionResult.C: In member function ‘void Foam::ExpressionResult::uglyDelete()’:
ExpressionResult.C:159:20: warning: deleting ‘void*’ is undefined
SOURCE=StoredExpressionResult.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/StoredExpressionResult.o
SOURCE=swakRegistryProxySurface.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/swakRegistryProxySurface.o
SOURCE=swakRegistryProxySet.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/swakRegistryProxySet.o
SOURCE=FieldValueExpressionParser.yy ; rm -f Make/linux64GccDPOpt/FieldValueExpressionParser.C Make/linux64GccDPOpt/FieldValueExpressionParser.tab.hh; bison -ra -v -d $SOURCE ; mv *.tab.cc Make/linux64GccDPOpt/FieldValueExpressionParser.C ; sed -i.bak "s/position.hh/FieldValueExpressionParser_position.hh/" location.hh ; mv location.hh lnInclude/FieldValueExpressionParser_location.hh ; mv stack.hh lnInclude/FieldValueExpressionParser_stack.hh ; mv position.hh lnInclude/FieldValueExpressionParser_position.hh ; sed -i.bak "s/stack.hh/FieldValueExpressionParser_stack.hh/;s/location.hh/FieldValueExpressionParser_location.hh/" FieldValueExpressionParser.tab.hh ;mv *.hh lnInclude ; touch -r $SOURCE lnInclude/FieldValueExpressionParser*.hh ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c Make/linux64GccDPOpt/FieldValueExpressionParser.C -o Make/linux64GccDPOpt/FieldValueExpressionParser.o
FieldValueExpressionParser.tab.cc: In member function ‘parserField::FieldValueExpressionParser::token_nu mber_type parserField::FieldValueExpressionParser::yytransla te_(int)’:
FieldValueExpressionParser.tab.cc:5385:24: warning: use of old-style cast
SOURCE=PatchValueExpressionParser.yy ; rm -f Make/linux64GccDPOpt/PatchValueExpressionParser.C Make/linux64GccDPOpt/PatchValueExpressionParser.tab.hh; bison -ra -v -d $SOURCE ; mv *.tab.cc Make/linux64GccDPOpt/PatchValueExpressionParser.C ; sed -i.bak "s/position.hh/PatchValueExpressionParser_position.hh/" location.hh ; mv location.hh lnInclude/PatchValueExpressionParser_location.hh ; mv stack.hh lnInclude/PatchValueExpressionParser_stack.hh ; mv position.hh lnInclude/PatchValueExpressionParser_position.hh ; sed -i.bak "s/stack.hh/PatchValueExpressionParser_stack.hh/;s/location.hh/PatchValueExpressionParser_location.hh/" PatchValueExpressionParser.tab.hh ;mv *.hh lnInclude ; touch -r $SOURCE lnInclude/PatchValueExpressionParser*.hh ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c Make/linux64GccDPOpt/PatchValueExpressionParser.C -o Make/linux64GccDPOpt/PatchValueExpressionParser.o
PatchValueExpressionParser.tab.cc: In member function ‘parserPatch::PatchValueExpressionParser::token_nu mber_type parserPatch::PatchValueExpressionParser::yytransla te_(int)’:
PatchValueExpressionParser.tab.cc:4521:24: warning: use of old-style cast
SOURCE=SubsetValueExpressionParser.yy ; rm -f Make/linux64GccDPOpt/SubsetValueExpressionParser.C Make/linux64GccDPOpt/SubsetValueExpressionParser.tab.hh; bison -ra -v -d $SOURCE ; mv *.tab.cc Make/linux64GccDPOpt/SubsetValueExpressionParser.C ; sed -i.bak "s/position.hh/SubsetValueExpressionParser_position.hh/" location.hh ; mv location.hh lnInclude/SubsetValueExpressionParser_location.hh ; mv stack.hh lnInclude/SubsetValueExpressionParser_stack.hh ; mv position.hh lnInclude/SubsetValueExpressionParser_position.hh ; sed -i.bak "s/stack.hh/SubsetValueExpressionParser_stack.hh/;s/location.hh/SubsetValueExpressionParser_location.hh/" SubsetValueExpressionParser.tab.hh ;mv *.hh lnInclude ; touch -r $SOURCE lnInclude/SubsetValueExpressionParser*.hh ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c Make/linux64GccDPOpt/SubsetValueExpressionParser.C -o Make/linux64GccDPOpt/SubsetValueExpressionParser.o
SubsetValueExpressionParser.tab.cc: In member function ‘parserSubset::SubsetValueExpressionParser::token_ number_type parserSubset::SubsetValueExpressionParser::yytrans late_(int)’:
SubsetValueExpressionParser.tab.cc:4254:24: warning: use of old-style cast
SOURCE=CommonValueExpressionDriver.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/CommonValueExpressionDriver.o
SOURCE=makeSwakDataEntry.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/makeSwakDataEntry.o
SOURCE=FieldValueExpressionLexer.ll ; rm -f Make/linux64GccDPOpt/FieldValueExpressionLexer.C ; flex -f $SOURCE ; mv *.c Make/linux64GccDPOpt/FieldValueExpressionLexer.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/finiteVolume/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/sampling/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/triSurface/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/lagrangian/basic/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/meshTools/lnInclude -IlnInclude -I. -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude -I/apps/OpenFOAM/OpenFOAM-2.0.1/src/OSspecific/POSIX/lnInclude -fPIC -c Make/linux64GccDPOpt/FieldValueExpressionLexer.C -o Make/linux64GccDPOpt/FieldValueExpressionLexer.o
Make/linux64GccDPOpt/FieldValueExpressionLexer.C:245:36: warning: use of old-style cast
Make/linux64GccDPOpt/FieldValueExpressionLexer.C:296:23: warning: use of old-style cast
Make/linux64GccDPOpt/FieldValueExpressionLexer.C:296:44: warning: use of old-style cast
lex.fvexpr.c: In function ‘int parserFieldlex(parserField::FieldValueExpressionPa rser::semantic_type*, parserField::location*, Foam::FieldValueExpressionDriver&)’:
lex.fvexpr.c:27985:56: warning: use of old-style cast
lex.fvexpr.c:27985:56: warning: use of old-style cast
lex.fvexpr.c:28001:3: warning: use of old-style cast
lex.fvexpr.c:28717:60: warning: use of old-style cast
lex.fvexpr.c: In function ‘int yy_get_next_buffer()’:
lex.fvexpr.c:28885:49: warning: use of old-style cast
lex.fvexpr.c:28912:37: warning: use of old-style cast
lex.fvexpr.c:28925:35: warning: use of old-style cast
lex.fvexpr.c:28926:28: warning: use of old-style cast
lex.fvexpr.c:28947:3: warning: use of old-style cast
lex.fvexpr.c: In function ‘yy_state_type yy_get_previous_state()’:
lex.fvexpr.c:28995:48: warning: use of old-style cast
lex.fvexpr.c:28995:48: warning: use of old-style cast
lex.fvexpr.c: In function ‘int yyinput()’:
lex.fvexpr.c:29152:25: warning: use of old-style cast
lex.fvexpr.c: In function ‘yy_buffer_state* fvexpr_create_buffer(FILE*, int)’:
lex.fvexpr.c:29229:72: warning: use of old-style cast
lex.fvexpr.c:29238:60: warning: use of old-style cast
lex.fvexpr.c: In function ‘void fvexpr_delete_buffer(yy_buffer_state*)’:
lex.fvexpr.c:29261:41: warning: use of old-style cast
lex.fvexpr.c:29264:29: warning: use of old-style cast
lex.fvexpr.c:29266:25: warning: use of old-style cast
lex.fvexpr.c: In function ‘yy_buffer_state* fvexpr_scan_buffer(char*, yy_size_t)’:
lex.fvexpr.c:29345:72: warning: use of old-style cast
lex.fvexpr.c: In function ‘yy_buffer_state* fvexpr_scan_bytes(const char*, int)’:
lex.fvexpr.c:29399:34: warning: use of old-style cast
lex.fvexpr.c: In function ‘void yy_push_state(int)’:
lex.fvexpr.c:29438:53: warning: use of old-style cast
lex.fvexpr.c:29442:15: warning: use of old-style cast
lex.fvexpr.c:29442:40: warning: use of old-style cast
lex.fvexpr.c: In function ‘void* yy_flex_alloc(yy_size_t)’:
lex.fvexpr.c:29549:31: warning: use of old-style cast
lex.fvexpr.c: In function ‘void* yy_flex_realloc(void*, yy_size_t)’:
lex.fvexpr.c:29567:36: warning: use of old-style cast
lex.fvexpr.c:29567:46: warning: use of old-style cast
lex.fvexpr.c: At global scope:

gschaider February 16, 2012 19:36

Quote:

Originally Posted by zxj160 (Post 344747)
I got swak4Foam installed. But I want to know whether it has been installed successfully.

inlet
{
type groovyBC;
//type fixedValue
// log-law expression
variables "u_f=0.02;z0=0.0003;z_f=pos().y;K=0.4;vel=(u_f/K)*log((z_f+z0)/z0);";
valueExpression "vector (vel,0,0)";
}

When I set an velocity inlet using groovyBC, there is an error below:

--> FOAM Warning :
From function groovyBCFvPatchField<Type>::groovyBCFvPatchField(c onst fvPatch& p,const DimensionedField<Type, volMesh>& iF,const dictionary& dict)
in file groovyBCFvPatchField.C at line 119
No value defined for U on inlet therefore using 50{(0 0 0)}

A warning is NOT an error. A warning means "not everything is perfect but I think I solved the problem. If unexpected things happen this is the first place to investigate. If things go fine ingnore it"

The warning you have happens during startup. Before evaluating the expression for the first time the boundary condition needs (for technical reasons) SOME value. If you specify such a value (it will have no effect) like

value uniform (0 0 0);

the warning should go away.

The warnings in the other posting (I think they are what you're concerned about) can't be avoided. bison produces C-code that the compiler has some complaints about but nothing bad happens

zxj160 February 17, 2012 07:40

OK, thanks.

cuteapathy February 20, 2012 06:59

Dear gschaider,

I need to use groovyBC for setting my boundary condition so I got swak4Foam installed. When I run the case, I got error message:

--> FOAM FATAL IO ERROR:
Unknown patchField type groovyBC for patch type genericPatch

I guess that I got the problem about building swak4Foam. When I use wmake all to build swak4Foam, the error message shows:

Bison is version 2.4.1
No 'swakConfiguration'. Python etc won't work
OpenFOAM-version: Major 2 Minor 1 Patch 0
No change to Libraries/swak4FoamParsers/foamVersion4swak.H
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libswak4FoamParsers.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libgroovyBC.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libswakFunctionObjects.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libsimpleFunctionObjects.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libsimpleSwakFunctionObjects.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libswakTopoSources.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libswakSourceFields.so' is up to date.
'/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/lib/libgroovyStandardBCs.so' is up to date.
SWAK_PYTHON_INCLUDE not defined .... no Python-Integration
make: `/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/bin/funkySetFields' is up to date.
make: `/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/bin/funkySetBoundaryField' is up to date.
make: `/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/bin/replayTransientBC' is up to date.
make: `/home/yi-ching/OpenFOAM/yi-ching-2.1.0/platforms/linuxGccDPOpt/bin/funkyDoCalc' is up to date.

I have no idea what to make the error message. Could you please help me? Thank you.

Michelle

gschaider February 20, 2012 11:03

Quote:

Originally Posted by cuteapathy (Post 345293)
Dear gschaider,

I need to use groovyBC for setting my boundary condition so I got swak4Foam installed. When I run the case, I got error message:

--> FOAM FATAL IO ERROR:
Unknown patchField type groovyBC for patch type genericPatch

I guess that I got the problem about building swak4Foam. When I use wmake all to build swak4Foam, the error message shows:

That is a problemless build what your messages show.

My guess: you haven't added "libgroovyBC.so" to the the libs-list in controlDict and therefor the solver doesn't know about it

cuteapathy February 20, 2012 15:25

I added the line
libs ( "libgroovyBC.so");

to my controlDict.
I got another error message:

--> FOAM FATAL IO ERROR:
wrong token type - expected Scalar, found on line 658 the punctuation token ','

file: /home/yi-ching/OpenFOAM/yi-ching-2.1.0/run/tutorials/incompressible/icoFoam/TGVdbc2D/25/water/0/U::boundaryField::sides::value at line 658.

From function operator>>(Istream&, Scalar&)
in file lnInclude/Scalar.C at line 91.

FOAM exiting

Did I do something wrong here? Thank you for responding me.

gschaider February 20, 2012 19:35

Quote:

Originally Posted by cuteapathy (Post 345390)
I added the line
libs ( "libgroovyBC.so");

to my controlDict.
I got another error message:

--> FOAM FATAL IO ERROR:
wrong token type - expected Scalar, found on line 658 the punctuation token ','

file: /home/yi-ching/OpenFOAM/yi-ching-2.1.0/run/tutorials/incompressible/icoFoam/TGVdbc2D/25/water/0/U::boundaryField::sides::value at line 658.

From function operator>>(Istream&, Scalar&)
in file lnInclude/Scalar.C at line 91.

FOAM exiting

Did I do something wrong here?

Don't know if YOU did something wrong. That's hard to tell without knowing the history of line 658 of your file.

What exactly is the problem is hard to tell without knowing line 658. but it seems that there is one comma too many in that line

cuteapathy February 21, 2012 08:52

Dear Bernhard,

I added libs ("libOpenFOAM.so" "libgroovyBC.so"); to my controDict and tried to run icoFoam. It ran well at first and fail at the last few seconds. The error message shows:Time = 0.978

Courant Number mean: 7.60285e+98 max: 7.90092e+100
#0 Foam::error::printStack(Foam::Ostream&) in "/opt/openfoam210/platforms/linuxGccDPOpt/lib/libOpenFOAM.so"
#1 Foam::sigFpe::sigHandler(int) in "/opt/openfoam210/platforms/linuxGccDPOpt/lib/libOpenFOAM.so"
#2 Uninterpreted:
#3 Foam::PBiCG::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const in "/opt/openfoam210/platforms/linuxGccDPOpt/lib/libOpenFOAM.so"
#4
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
#5
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
#6
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
#7 __libc_start_main in "/lib/tls/i686/cmov/libc.so.6"
#8
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
Floating point exception

Does this happen because my groovyBC did not set up right?
My boundary condition for 0/p is

boundaryField
{
sides
{
type groovyBC;
value "exp(-4*nu*time())*0.25*(cos(2*x1)+cos(2*y1)-2)";
variables "nu=0.000001002;x1=pos().x;y1=pos().y;";
value uniform 0;
}
frontAndBack
{
type empty;
}
}


My boundary condition in 0/U is

boundaryField
{
sides
{
type groovyBC;
valueExpression "exp(-2*nu*time())*(sin(x1)*cos(y1)*vector(1,0,0)-cos(x1)*sin(y1)*vector(0,1,0))";
variables "nu=0.000001002;x1=pos().x;y1=pos().y;";
value uniform (0 0 0);
}
frontAndBack
{
type empty;
}
}

Could you take a look at this? I have no idea what make this wrong. Thank you very much.

gschaider February 21, 2012 19:14

Quote:

Originally Posted by cuteapathy (Post 345519)
Dear Bernhard,

I added libs ("libOpenFOAM.so" "libgroovyBC.so"); to my controDict and tried to run icoFoam. It ran well at first and fail at the last few seconds. The error message shows:Time = 0.978

Courant Number mean: 7.60285e+98 max: 7.90092e+100
#0 Foam::error::printStack(Foam::Ostream&) in "/opt/openfoam210/platforms/linuxGccDPOpt/lib/libOpenFOAM.so"
#1 Foam::sigFpe::sigHandler(int) in "/opt/openfoam210/platforms/linuxGccDPOpt/lib/libOpenFOAM.so"
#2 Uninterpreted:
#3 Foam::PBiCG::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const in "/opt/openfoam210/platforms/linuxGccDPOpt/lib/libOpenFOAM.so"
#4
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
#5
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
#6
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
#7 __libc_start_main in "/lib/tls/i686/cmov/libc.so.6"
#8
in "/opt/openfoam210/platforms/linuxGccDPOpt/bin/icoFoam"
Floating point exception

Does this happen because my groovyBC did not set up right?
My boundary condition for 0/p is

The courant-number above shows that your simulation has "exploded" (you get unphysical velocities). This is not uncommon when using interFoam and not setting it up correctly. Have a look when the Courant-numbr crosses the threshold that is reasonable (something between 0.25 and 0.5, depends on whom you're asking), decrease the timestep and see if it goes away. Consider adaptive timestepping

groovyBC itself is not the problem here. It is possible that the boundary conditions you've set caused the problem but I can't help you with that

cuteapathy February 22, 2012 05:54

Dear Bernhard,

I got my problem solved and ran the case pretty well. Thank you for everything. I appreciate your help. You are the best. :)

Michelle

ziad January 13, 2013 17:33

CommonValueExpressionDriver.C compile problem
 
Hi,

I am getting the following error compiling swak4Foam with the latest git pull of 2.1.x:

Code:

CommonValueExpressionDriver.C:1091: error: template argument required for ‘class lessOp’
CommonValueExpressionDriver.C: In member function ‘Foam::vector Foam::CommonValueExpressionDriver::getPositionOfMinimum(const Foam::scalarField&, const Foam::vectorField&) const’:
CommonValueExpressionDriver.C:1156: error: missing template arguments before ‘(’ token
make: *** [Make/linux64GccDPOpt/CommonValueExpressionDriver.o] Error 1

libswak4FoamParsers.so won't build. I looked in the code for CommonValueExpressionDriver.C and class lessOp does indeed require two arguments which are not passed at line 1156. I expect the same problem would occur at line 1164 with biggerOp.

Code:

class lessOp {
public:
    bool operator()(scalar a,scalar b) {
        return a<b;
    }
};

Code:

vector CommonValueExpressionDriver::getPositionOfMinimum(
    const scalarField &vals,
    const vectorField &locs
) const
{
    return getExtremePosition(lessOp(),vals,locs); // line 1156
}

Did this code change from previous versions? I never had this error before.

Z.

gschaider January 13, 2013 17:51

Quote:

Originally Posted by ziad (Post 401636)
Hi,

I am getting the following error compiling swak4Foam with the latest git pull of 2.1.x:

Code:

CommonValueExpressionDriver.C:1091: error: template argument required for ‘class lessOp’
CommonValueExpressionDriver.C: In member function ‘Foam::vector Foam::CommonValueExpressionDriver::getPositionOfMinimum(const Foam::scalarField&, const Foam::vectorField&) const’:
CommonValueExpressionDriver.C:1156: error: missing template arguments before ‘(’ token
make: *** [Make/linux64GccDPOpt/CommonValueExpressionDriver.o] Error 1

libswak4FoamParsers.so won't build. I looked in the code for CommonValueExpressionDriver.C and class lessOp does indeed require two arguments which are not passed at line 1156. I expect the same problem would occur at line 1164 with biggerOp.

Code:

class lessOp {
public:
    bool operator()(scalar a,scalar b) {
        return a<b;
    }
};

Code:

vector CommonValueExpressionDriver::getPositionOfMinimum(
    const scalarField &vals,
    const vectorField &locs
) const
{
    return getExtremePosition(lessOp(),vals,locs); // line 1156
}

Did this code change from previous versions? I never had this error before.

Z.

I just stumbled upon this problem last week. No idea why it didn't happen before. Basically what is happening is that the lessOp defined here clashes with the lessOp from OpenFOAM. Why it didn't happen before ... maybe in the last pull from 2.1.x (BTW: which version are you using) a header changed. I fixed it by renaming my lessOp to smallerOp so that it doesn't clash with the upstream. biggerOp doesn't seem to have this problem (probably a more elegant solution is to remove "my" definition of lessOp altogether and write lessOp<scalar>() in line 1156)

wyldckat January 13, 2013 18:07

Greetings to all!

Quote:

Originally Posted by gschaider (Post 401638)
I just stumbled upon this problem last week. No idea why it didn't happen before. Basically what is happening is that the lessOp defined here clashes with the lessOp from OpenFOAM. Why it didn't happen before ... maybe in the last pull from 2.1.x (BTW: which version are you using) a header changed. I fixed it by renaming my lessOp to smallerOp so that it doesn't clash with the upstream. biggerOp doesn't seem to have this problem (probably a more elegant solution is to remove "my" definition of lessOp altogether and write lessOp<scalar>() in line 1156)

:confused: it's been about 2 weeks since I reported this, along with patch: http://sourceforge.net/apps/mantisbt...iew.php?id=163
Although the proposition was to use "littlerOp", just to avoid some other similar incident :rolleyes:

Best regards,
Bruno

ziad January 13, 2013 21:04

Both solutions are equivalent, renaming in swak4Foam or OpenFOAM. Since the latter is really up to OpenCFD I'll go for the former.

Thanks Bernhard and Bruno.

@Bernhard

I'm using OF2.1.x with yesterday's pull. Not sure which swak4Foam I have but it is a 2.0 version downloaded several months ago.

gschaider January 14, 2013 05:26

Quote:

Originally Posted by wyldckat (Post 401639)
Greetings to all!


:confused: it's been about 2 weeks since I reported this, along with patch: http://sourceforge.net/apps/mantisbt...iew.php?id=163
Although the proposition was to use "littlerOp", just to avoid some other similar incident :rolleyes:

Best regards,
Bruno

Ups. Sorry. Overlooked that

ziad January 15, 2013 11:59

Hi Bernhard,

Is the svn repository accessible? Got the following error from two different systems:

Code:

ziad@linux-ec5v> svn checkout https://openfoam-extend.svn.sourceforge.net/svnroot/openfoam-extend/trunk/Breeder_2.0/libraries/swak4Foam/
svn: Could not open the requested SVN filesystem


gschaider January 15, 2013 12:14

Quote:

Originally Posted by ziad (Post 401993)
Hi Bernhard,

Is the svn repository accessible? Got the following error from two different systems:

Code:

ziad@linux-ec5v> svn checkout https://openfoam-extend.svn.sourceforge.net/svnroot/openfoam-extend/trunk/Breeder_2.0/libraries/swak4Foam/
svn: Could not open the requested SVN filesystem


The problem is that the GIT and the SVN of openfoam-extend have been temporarily disabled by Sourceforge because ANSYS sent them a letter that 6 files in the 1.6-ext violate their copyright. Collateral damage is that other projects hosted there are also unavailable. There are actions under way to clear the situation and bring back the repositories but I can't tell you details because I'm not involved in this (the annoying part is that the files in question are not even essential for 1.6-ext). The story has been told on the front-page of the Wiki and been mentioned several times on the MessageBoard. I understand that not everyone scans these sources all the time so it would be helpful if you let us know whether there is any additional place where you think this information should be put to make it known to all concerned.

Anyway. In
http://www.cfd-online.com/Forums/ope...tml#post401436
I published two links to download tarballs of the latest swak4Foam-release (the development version in mercurial works anyway as promised on the Wiki)

bhushanvelis July 30, 2013 13:14

Thanks for your help .. :)
 
Thanks it helped
Quote:

Originally Posted by gschaider (Post 345339)
That is a problemless build what your messages show.

My guess: you haven't added "libgroovyBC.so" to the the libs-list in controlDict and therefor the solver doesn't know about it



All times are GMT -4. The time now is 02:00.