CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM (http://www.cfd-online.com/Forums/openfoam/)
-   -   wmake error (http://www.cfd-online.com/Forums/openfoam/99113-wmake-error.html)

zxj160 March 26, 2012 10:52

wmake error
 
I copied the channelFoam application files and change the name of the .C file to newchannelFoam (aslo in the make file) and the path to user directory. I wmake it and it seems OK.
Then I run the channelFoam tutorial case: blockMesh and newchannelFoam. The error message is as follows:

bash-3.2$ newchannelFoam
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by newchannelFoam)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by newchannelFoam)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libincompressibleLESModels.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libincompressibleLESModels.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libincompressibleTransportModels.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libincompressibleTransportModels.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libfiniteVolume.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libfiniteVolume.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libmeshTools.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libmeshTools.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libOpenFOAM.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libOpenFOAM.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libincompressibleTurbulenceModel.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libincompressibleTurbulenceModel.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/openmpi-1.5.3/libPstream.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/openmpi-1.5.3/libPstream.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libLESdeltas.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libLESdeltas.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libLESfilters.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libLESfilters.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libtriSurface.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libtriSurface.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libfileFormats.so)
newchannelFoam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /apps/OpenFOAM/OpenFOAM-2.0.1/platforms/linux64GccDPOpt/lib/libfileFormats.so)


All times are GMT -4. The time now is 18:02.