CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

groovyBC in openFOAM-2.0 for parabolic velocity bc

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   August 26, 2013, 04:27
Default
  #21
Senior Member
 
Illya Shevchuk
Join Date: Aug 2009
Location: Darmstadt, Germany
Posts: 174
Rep Power: 7
linch is on a distinguished road
The version was 0.2.3 (next to last according to Swak4Foam-Wiki) and suitable to OF up to 2.2 (2.1 is the one I use).

Now I've got v0.2.4 (release, available via svn, must be the latest one), but the errors are still there.

There are also a couple of other error related to openmpi (see attachment for the full log)
Code:
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Waitall'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Abort'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `ompi_mpi_double'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Get_count'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Init'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Probe'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Send'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Allreduce'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `ompi_mpi_packed'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Buffer_detach'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Bsend'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `ompi_mpi_byte'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Irecv'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Recv'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `ompi_mpi_comm_world'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Get_processor_name'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Test'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Isend'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Finalize'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `ompi_mpi_op_sum'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Buffer_attach'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Comm_size'
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Comm_rank'
. Somehow, swak is looking for the "OF-internal" openmpi, while an external is used. I think I'm missing something.

Best regards,
Ilya
Attached Files
File Type: gz log.Allwmake.gz (14.6 KB, 5 views)
linch is offline   Reply With Quote

Old   August 26, 2013, 07:02
Default
  #22
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by linch View Post
The version was 0.2.3 (next to last according to Swak4Foam-Wiki) and suitable to OF up to 2.2 (2.1 is the one I use).

Now I've got v0.2.4 (release, available via svn, must be the latest one), but the errors are still there.

There are also a couple of other error related to openmpi (see attachment for the full log)
Code:
/home/shevchuk/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so: undefined reference to `MPI_Waitall'
. Somehow, swak is looking for the "OF-internal" openmpi, while an external is used. I think I'm missing something.

Best regards,
Ilya
Have you ever tried compiling other software than swak with that installation? Because it seems that this is a problem with the installation, not swak. swak doesn't specify which MPI to use but uses the options that wmake automatically generates (have a look for instance at Utilities/replayTransientBC/Make/options - that is one of the links that is failing and it uses only standard-options).

What version of Linux are you using?
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   August 26, 2013, 11:06
Default
  #23
Senior Member
 
Illya Shevchuk
Join Date: Aug 2009
Location: Darmstadt, Germany
Posts: 174
Rep Power: 7
linch is on a distinguished road
Thanks Bernhard,

the problem was indeed somewhere else. I was looking for it for a while with our admin, who takes care of the cluster. Finally, his conclusion was that the openmpi installed on the cluster was compiled with intel compiler while OF uses gcc. However, compiling ThirdPartys and src's caused no errors, these errors occurred only while compiling some application and swak4foam. After recompiling the openmpi with gcc, everything was ok.

Nevertheless, the warnings
Quote:
could not open file [...] for source file [...]
are still there. But since there are no errors, I think it's ok.

Thank you for the hints and best regards,
Ilya
linch is offline   Reply With Quote

Old   July 10, 2015, 09:44
Default groovyBC problems
  #24
New Member
 
Join Date: Jul 2015
Posts: 2
Rep Power: 0
bufs is on a distinguished road
Hi guys,


it's my first time using groovyBC and I'm trying to set up a parabolic profile of inlet velocity. What I'm doing is editing the U file to have the following code for inlet

Code:
inlet
    {
        type               groovyBC;
    variables          "yp = pts().y; minY = min(yp); maxY = max(yp); rad = 0.5*(maxY - minY); vavg = 0.23;";
    valueExpression    "2.0*vavg*(1.0-pow(pos().y/rad, 2))*normal()";
    value              uniform (10 0 0);
    }
and also I edited the controlDict file in system to include

Code:
libs ("libOpenFOAM.so"
      "libsimpleSwakFunctionObjects.so"
      "libswakFunctionObjects.so"
      "libgroovyBC.so"
);
But, when I run the case I get the following message

Code:
Create time

Create mesh for time = 0

Selecting dynamicFvMesh dynamicMotionSolverFvMesh
Selecting motion solver: displacementSBRStress
Selecting motion diffusion: inverseDistance
Reading field p

Reading field U

Reading/calculating face flux field phi

Selecting incompressible transport model Newtonian
Selecting turbulence model type laminar
Reading field rAU if present

No field sources present


PIMPLE: no residual control data found. Calculations will employ 2 corrector loops


Starting time loop

Courant Number mean: 0.00054139691 max: 0.023902054
deltaT = 0.00011990408
Time = 0.00011990408

DICPCG:  Solving for cellDisplacementx, Initial residual = 0, Final residual = 0, No Iterations 0
DICPCG:  Solving for cellDisplacementy, Initial residual = 0, Final residual = 0, No Iterations 0
word::stripInvalid() called for word yp
    For debug level (= 2) > 1 this is considered fatal
Aborted (core dumped)
Anyone knows what I'm doing wrong?
bufs is offline   Reply With Quote

Reply

Tags
boundary conditions, groovybc, velocity inlet

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.6 and 1.7 with interFoam, groovyBC give different strange results Arnoldinho OpenFOAM 7 December 9, 2010 17:29
wmake groovyBC in OpenFOAM 1.7 ? randomid OpenFOAM Running, Solving & CFD 1 August 27, 2010 05:15
acoustic pressure , velocity, etc. study using openfoam suniljain OpenFOAM 0 January 19, 2010 06:52
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Terrible Mistake In Fluid Dynamics History Abhi Main CFD Forum 12 July 8, 2002 09:11


All times are GMT -4. The time now is 18:01.