CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ParaView (http://www.cfd-online.com/Forums/paraview/)
-   -   Limiting streamlines using surfaceLIC plugin (http://www.cfd-online.com/Forums/paraview/116477-limiting-streamlines-using-surfacelic-plugin.html)

Tarak April 19, 2013 20:39

Limiting streamlines using surfaceLIC plugin
 
Hii,

Can someone tell me how to get limiting streamlines on a surface using the surfaceLIC plugin?

wyldckat April 21, 2013 06:14

1 Attachment(s)
Greetings Tarak,

I had never tried the "surfaceLIC" plug-in before... Had to search a bit on how to use it and found the following presentation (the last 3 slides describe a bit about it): http://www.tfd.chalmers.se/~hani/kur...jjadHaider.pdf

From what I can figure out, the only controls available are in the "Display" tab of the "Object Inspector"; near the end of the page there is the group box "Line Integral Convolution", as shown in the attached image on the lower left corner.
It looks like it's not possible to control the length of the lines, since this is a representation method, not a filter.
Even if you only have 4 cells with data, it still shows several surface lines. But, by using the filter "Extract Cells By Region" with the "Intersect With" set to "box", you can restrain to the geometry you want to represent with "Surface LIC".

Best regards,
Bruno

Tarak April 21, 2013 13:19

Thanks Bruno, I was trying the same steps as you mentioned, but somehow the streamtraces don't show up. Did you have to do anything extra apart from choosing "SurfaceLIC" instead of "Surface" as the visualization mode to just to get the lines (i.e. did you have to play with the parameters in the display tab in the object inspector box?)? This is another thread which talks about this http://www.cfd-online.com/Forums/ope...-paraview.html

Thanks,
Tarak

wyldckat April 21, 2013 15:01

Hi Tarak,

Quote:

Originally Posted by wyldckat (Post 422080)
I had never tried the "surfaceLIC" plug-in before... Had to search a bit on how to use it and found the following presentation (the last 3 slides describe a bit about it): http://www.tfd.chalmers.se/~hani/kur...jjadHaider.pdf

I followed the instructions on the last 3... wait, in the last 4 slides from the link above. It's also discussed in the thread you indicated.

Now that I re-read your first post... do you mean you haven't been able to load the "surface LIC" plug-in? Does the plug-in show up in the "Plugin Manager"?

If not, I'm going to have to guess... probably you are using Linux, possibly Ubuntu... and possibly Ubuntu's own ParaView. If this is the case, start a terminal window and run the following commands:
Code:

export PV_PLUGIN_PATH=/usr/lib/paraview
paraview

The first line will define that the path where the default plug-ins are in the specified folder and the second will run ParaView.

Best regards,
Bruno

Tarak April 21, 2013 15:15

Hii Bruno,

I have loaded the plugin, and it appears in the scroll-down menu where you have usual options for visualization as "outline","surface","surface with edges" etc. And the parameters for the plugin also appear in the "display" tab of the "object inspector". From your words, as well as from what is mentioned in the link I gave, it seems that as soon as one chooses "surfaceLIC" in the scroll down menu, the streamtraces appear. But it is not so in my case. So, I'm wondering if I have to do something more to make the streamlines appear.

Thanks,
Tarak

wyldckat April 21, 2013 15:25

2 Attachment(s)
Hi Tarak,

Unpack the ".gz" file attached and open the VTK file inside ParaView. Then select "Surface LIC" and choose "p" as the representation field.

In the attached image is the configuration I used.

Best regards,
Bruno

Tarak April 21, 2013 15:40

1 Attachment(s)
Hii Bruno,

Attached is the screenshot of what I'm getting. Maybe something is wrong with the plugin I'm using. BTW I'm using Paraview 3.12.0.

Thanks,
Tarak

wyldckat April 21, 2013 15:59

I've tested just now with ParaView 3.12.0 that I built for OpenFOAM 2.1.x... it seemed to only work properly if I turn on the plug-in and then open the file once again.

Are you using the auto-load feature for loading the plug-in? And close ParaView and open it again?

And are you using Unity in 3D? In case you don't know, "Unity" is the name of the default desktop manager that Ubuntu provides in the latests versions (will all of the buttons on the left) and 3D acceleration is usually turned on by default. Unity's 3D acceleration usually messes up ParaView.

Tarak April 21, 2013 16:30

Hii Bruno,

It worked! But only after I moved from Ubuntu to Windows. I was using Unity in Ubuntu, and maybe that was causing the problem as you mentioned. Thanks a lot!!

berk April 21, 2013 21:01

LIC does require certain OpenGL extensions that may not exist on certain older cards and/or drivers.

kiddmax January 13, 2014 09:47

1 Attachment(s)
Quote:

Originally Posted by wyldckat (Post 422160)
I've tested just now with ParaView 3.12.0 that I built for OpenFOAM 2.1.x... it seemed to only work properly if I turn on the plug-in and then open the file once again.

Are you using the auto-load feature for loading the plug-in? And close ParaView and open it again?

And are you using Unity in 3D? In case you don't know, "Unity" is the name of the default desktop manager that Ubuntu provides in the latests versions (will all of the buttons on the left) and 3D acceleration is usually turned on by default. Unity's 3D acceleration usually messes up ParaView.

Hi Bruno,

I also want to plot this line. But I failed, could you please to see what I did wrong?
Thanks a lot!

Ye

wyldckat January 18, 2014 10:59

Hi Ye,

I need more information in order to be able to help. More specifically:
  1. Which ParaView version are you using?
  2. What were the exact steps you've taken?
Don't forget that the image you have provided only gives the last thing you saw. It does not give any hints at which were the exact steps you've taken.

Best regards,
Bruno

hiuluom February 28, 2014 04:22

1 Attachment(s)
Hi Bruno,

I downloaded cavity.vtk and ran with the same your guide. But the oilflow is not appear. Could you please show me why has this problem?

Thank you.
Attachment 28978

wyldckat March 1, 2014 06:17

Hi Huynh,

A few questions:
  • Did you restart ParaView after turning on the Surface LIC plug-in?
  • Did you install the correct graphics-card drivers in your Windows installation?
Best regards,
Bruno

hiuluom March 3, 2014 05:39

Sorry Bruno, I did not reply you early, because I am sick 2 days so far.

I surely restart Paraview and I ran the same your guide step by step. I tried with Ubuntu, but the result the same. In windows OS, I updated latest driver for my PC Intel GMA 4500MHD. I haven't seen any change when I chose surfaceLIC.

Best regards,
Thanh.

P/s: Huynh is my family name, Thanh is my name :p

wyldckat March 3, 2014 07:57

Hi Thanh,

Quote:

Originally Posted by hiuluom (Post 477673)
Sorry Bruno, I did not reply you early, because I am sick 2 days so far.

Get well soon!


Quote:

Originally Posted by hiuluom (Post 477673)
I surely restart Paraview and I ran the same your guide step by step. I tried with Ubuntu, but the result the same. In windows OS, I updated latest driver for my PC Intel GMA 4500MHD. I haven't seen any change when I chose surfaceLIC.

Mmm... then the problem might be as Berk said on the other post:
Quote:

Originally Posted by berk (Post 422192)
LIC does require certain OpenGL extensions that may not exist on certain older cards and/or drivers.

I used Google for:
Code:

GMA 4500MHD OpenGL limitations
And among the results was an indication that this GPU does not fully support all OpenGL 2.1 extensions, which would explain the reason why it's not working for you :(


Quote:

Originally Posted by hiuluom (Post 477673)
P/s: Huynh is my family name, Thanh is my name :p

Sorry, I'm never sure if people use the "First to Last" or "Last then First" convention for their names. Since the forum is in English, I assumed that it was "First to Last".

Best regards,
Bruno

hiuluom March 3, 2014 12:00

Hi Bruno,

I thank you so much you showed me reason.

Best regards,
Thanh


All times are GMT -4. The time now is 15:59.