CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ParaView

How so suppress update of steady objects for new time steps

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   January 22, 2014, 12:36
Default How so suppress update of steady objects for new time steps
  #1
Senior Member
 
flotus1's Avatar
 
Alex
Join Date: Jun 2012
Location: Germany
Posts: 1,097
Rep Power: 19
flotus1 will become famous soon enoughflotus1 will become famous soon enough
I have an issue with PV that bothers me every time I want to view or save an animation of particles together with some representation of the underlying flow field.

As long as I only have the particles visible, the animation runs quite fast, lets say in the range of 10ms per timestep.
fast.jpg

The problem is that if I want to show some representation of the flow field in the background like e.g. streamlines, it takes orders of magnitude longer.
awfully_slow.jpg
It seems like the streamlines were recomputed every time step, which is not necessary.
I have a steady-state flow field and only the particle positions change.
I thought that the option "Ignore time" would be what I am searching for, but it has no effect. I ticked "Ignore time" for every object except the particles, but this changes nothing.

My workaround until now was to save an image of the flow representation I need and use it instead of the actual results, but that is not very comfortable.

I have version 4.01 installed right now, but this issue has been bothering me since 3.10.
Any ideas?
flotus1 is offline   Reply With Quote

Old   January 24, 2014, 20:22
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Alex,

So, if I understand you correctly, the "LB_results" data remains the same for all time snapshots, is that correct? But whenever you change the file, it seems to reload and recalculate the streamlines.

There are 2 possibilities here:
  1. You might have got the "Lock Interactive Render" feature turned on. It's shown here: http://www.paraview.org/Wiki/ParaVie...r_View_General - switch the value to 0, so that it won't hold still for 2 seconds between renders.
  2. The data inside "LB_results" might actually change with time, hence the streamlines are always calculated. In this scenario, there are 2 possible fixes:
    1. Select the "Transform" entry after the streamlines and use the menu to choose "File -> Save Data" and save as VTK file the stream lines. Delete the "LB_results" branch and load back the VTK file you had saved.
    2. If it's very slow to calculate the streamlines, then apply the "extract edges" or "extract geometry" or "extract surface" filter (I can't remember which one it's best) save as VTK file.
      Delete the streamlines calculation and load the VTK file. Then apply the filter... er... I think it's the "Resample with Dataset" filter. If you select both the loaded VTK file entry and the "LB_results" entry, you can interpolate the results onto the VTK lines and therefore have the interpolated data on them.
      It's faster in the sense that interpolation alone is quicker, than having to calculate first the streamlines.
Best regards,
Bruno
flotus1 likes this.
wyldckat is offline   Reply With Quote

Old   January 27, 2014, 05:13
Default
  #3
Senior Member
 
flotus1's Avatar
 
Alex
Join Date: Jun 2012
Location: Germany
Posts: 1,097
Rep Power: 19
flotus1 will become famous soon enoughflotus1 will become famous soon enough
Thanks Bruno, your advice helped a lot.

The "Lock Interactive Render" feature was already turned off, so this did not cause the problem.
Both options you supposed in 2. worked for me, although only the "extract surface" filter retained the information of the streamlines.

In order to help me fully understand what I am doing wrong, could you try comment on these issues:
The data inside "LB_results" that contains the flow field actually changes with time. But only because we use a transient solver to obtain a steady-state result. There is only a small amount of time steps and I only want to use the last one.
The particle trajectories were actually calculated based on the last "time step" of the "LB_results" dataset.
So here is the thing: "LB_results" only contains 4 time steps, of which only the last one is needed.
The "Particles.vtk" contains thousands of real time steps showing the actual trajectories of the particles.
So although the time counter in ParaView is constantly higher than the last time step available in "LB_results" during the animation, PV still tries to update the representations based on this dataset?
Then what is the "ignore time" option good for?
flotus1 is offline   Reply With Quote

Old   February 2, 2014, 13:11
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Alex,

The "ignore time" option only affects the selected source entry in pipeline; it will be certainly frozen in time, although most likely it will be stuck in the first iteration.
But the streamlines are always calculated when a new time snapshot occurs.
Here's how I know this... I've done a few tests with OpenFOAM data in ParaView 3.12.0 and I noticed the following:
  1. One entry of a file ".OpenFOAM" is loaded.
  2. I apply the "Streamlines" filter to it.
  3. It calculates the streamlines on a need basis, namely when the time snapshot is changed.
  4. I chose to freeze the time for the ".OpenFOAM" entry.
  5. The time controls were restricted and sort-of frozen in time = 0s. But I could still changed from 0 to 1 in steps of 0.1(1), but it did not affect the streamlines filter.
  6. I loaded a second entry of the same ".OpenFOAM" file.
  7. The time controls were back on and the streamlines were calculated along with the original data. In other words, the second entry broke the time lock on the first entry.
This is probably because ParaView's time controls still have some considerable limitations.

Note: I have not tested with ParaView 4.1.0, to see if the same problem still occurs or not.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 3, 2014, 03:03
Thumbs up
  #5
Senior Member
 
flotus1's Avatar
 
Alex
Join Date: Jun 2012
Location: Germany
Posts: 1,097
Rep Power: 19
flotus1 will become famous soon enoughflotus1 will become famous soon enough
Thanks for your effort.
flotus1 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Superlinear speedup in OpenFOAM 13 msrinath80 OpenFOAM Running, Solving & CFD 18 March 3, 2015 06:36
How to determine time step size and Max. iterations per time step. pratik c FLUENT 38 February 11, 2015 07:44
AMI speed performance danny123 OpenFOAM 19 October 24, 2012 07:44
Multiple floating objects CKH OpenFOAM 10 September 21, 2011 23:13
unsteady calcs in FLUENT Sanjay Padhiar Main CFD Forum 1 March 31, 1999 12:32


All times are GMT -4. The time now is 09:35.