CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ParaView

Block Indices vanish???

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 21, 2014, 11:38
Default Block Indices vanish???
  #1
Senior Member
 
François Grégoire
Join Date: Jan 2010
Location: Laval University, Canada
Posts: 293
Rep Power: 7
macfly is on a distinguished road
Hi,

I load multiple .encas data files from Fluent then I Filter\Extract Block for each case in order to be able to choose which zone of the geometry I want to plot.

I don't know why at some point the list of Block Indices disappear in the Properties tab of Extract Block. See Fig.1, the Block Indices are all there, everything is ok. Then see Fig.2, they vanished!

I typically load 2 or 3 .encas. Sometimes this strange behavior happens for 1 or 2 Extract Block, sometimes everything stays flawless, sometimes it happens for every dataset. It's pretty random and very annoying. I get nervous never knowing when I'm going to loose the Block Indices. Reset button and Zoom To Data don't help.

Thanks,
François
Attached Images
File Type: png 1.png (13.9 KB, 5 views)
File Type: png 2.png (15.4 KB, 4 views)
macfly is offline   Reply With Quote

Old   April 24, 2014, 16:35
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,172
Blog Entries: 32
Rep Power: 70
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings François,

After a really quick search, I couldn't find any examples of this specific file format.
Can you share a really small example file and/or folder, so that I or anyone else can try this out?

Because without being able to test this myself, my guesses are:
  1. It's a bug and should be reported... after we can figure out how to reproduce the bug.
  2. It's possible that the desired blocks have to be manually selected in the reader options, which might not be done automatically every time.
  3. There could be a memory leak somewhere or interference from some other application. I've had such situations when using VLC or Flash, both on Linux.
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   April 26, 2014, 12:33
Default
  #3
Senior Member
 
François Grégoire
Join Date: Jan 2010
Location: Laval University, Canada
Posts: 293
Rep Power: 7
macfly is on a distinguished road
Hi,

.encas is the file format outputed by Fluent when you choose to export data to Ensight Case Gold. It's the most convenient file format for transient results from Fluent to Paraview.

In Paraview, I use the Ensight Files reader. There is no option for choosing which blocks are imported, you only get to click which variables you want to import. All the blocks (the zones in Fluent) are 'hidden' in the data. Then with the Extract Block filter you get to choose which block (zones) are extracted.

The weird behavior happens when I do a lot of manipulations such as legend modifications, calculators, programmable filters, multiple views, etc. It's like Paraview loses track a little bit at some point...
macfly is offline   Reply With Quote

Old   April 26, 2014, 13:53
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,172
Blog Entries: 32
Rep Power: 70
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi François,

I don't have access to Fluent nor EnSight, so there isn't much I can do there

Mmm... from your description, it does seem more like a bug, possibly due to one or more memory leaks. ParaView is a bit known having those kinds of problems (edit: but they do gradually fix each problem with each new release). To top it off, this looks like a Heisenbug: http://en.wikipedia.org/wiki/Heisenbug

A couple of test files and two or three lists of steps on how to possibly trigger this issue would be helpful for placing a bug report at ParaView's bug tracker: http://paraview.org/Bug/

There is another hypothesis: the meshes+data being stored in the ".encas" format might be relying on ghost cells or some other feature that ParaView does not fully support. This would easily lead to there being unexpected memory leaks, causing this issue.
To solve this scenario, you would need to be able to assess what specific feature might be being used in the datasets. Using EnSight to load the files and checking the features being used, would help estimate which feature is making ParaView have problems.

Best regards,
Bruno

Last edited by wyldckat; April 26, 2014 at 13:54. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible Bug in pimpleFoam (or createPatch) (or fluent3DMeshToFoam) cfdonline2mohsen OpenFOAM 3 October 21, 2013 09:28
Mixer mesh - negative volume problem jadtwo OpenFOAM Native Meshers: blockMesh 1 July 20, 2013 05:00
foamLog not solving for Ux, Uy, Uz aerospain OpenFOAM Post-Processing 5 April 18, 2012 10:01
Icem Mesh to Foam jphandrigan OpenFOAM Mesh Utilities 4 March 9, 2010 02:58
blockMesh: block with 6 vertexes dani OpenFOAM 3 June 25, 2009 13:13


All times are GMT -4. The time now is 11:33.