CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Pointwise & Gridgen (http://www.cfd-online.com/Forums/pointwise/)
-   -   extrude-normal problems when creat structured mesh for a ship (http://www.cfd-online.com/Forums/pointwise/123395-extrude-normal-problems-when-creat-structured-mesh-ship.html)

nigel332 September 11, 2013 22:25

extrude-normal problems when creat structured mesh for a ship
 
Dear all,

Thanks for your attention first!

I met the problems of "positive skew jacobian" when I try to extrude the domain grids of half of a ship into blocks.

My used one domain grid to describe the ship model with deck, as shown in pic1.
pic1:http://ntu.me/di/P5YV/pic1.jpg
http://ntu.me/di/T5FA/pic.jpg

As you can see in the following pic, the grid for stern is very sharp, so when i use extrude--normal method to create the block for the ship, i met the problems such as "positive skew jacobian" .
http://ntu.me/di/PJ6J/pic.jpg

So, my good friends, can your give me some suggest and help me with the problems?

Thank you !

taxalian September 12, 2013 14:25

Hi Nigel332,

Try to split surface mesh in the vicinity of the sharp stern region i.e subgrids. Afterwards smoothen the surface mesh using Gridgen's elliptic solver using appropriate boundary condtion. Then go on with the extrusion.

good luck.

Quote:

Originally Posted by nigel332 (Post 451243)
Dear all,

Thanks for your attention first!

I met the problems of "positive skew jacobian" when I try to extrude the domain grids of half of a ship into blocks.

My used one domain grid to describe the ship model with deck, as shown in pic1.
pic1:http://ntu.me/di/P5YV/pic1.jpg
http://ntu.me/di/T5FA/pic.jpg

As you can see in the following pic, the grid for stern is very sharp, so when i use extrude--normal method to create the block for the ship, i met the problems such as "positive skew jacobian" .
http://ntu.me/di/PJ6J/pic.jpg

So, my good friends, can your give me some suggest and help me with the problems?

Thank you !


nigel332 September 12, 2013 22:41

Quote:

Originally Posted by taxalian (Post 451394)
Hi Nigel332,

Try to split surface mesh in the vicinity of the sharp stern region i.e subgrids. Afterwards smoothen the surface mesh using Gridgen's elliptic solver using appropriate boundary condtion. Then go on with the extrusion.

good luck.

Hi, taxalian,

Thanks for your reply! and i will try as you said.

And yesterday I found another problem:
When I use extrusion to create the 3-D block mesh, something happened as shown in the following pic:
http://ntu.me/di/BOOW/扭曲效果.jpg
You see the extrude line was screwy. And i imagine the extrude line should be like this:
http://ntu.me/di/QOLI/正常效果.jpg

What is your opinion?

And the teu.iges flie of my ship model can be done loaded here:
http://www.yourfilelink.com/get.php?fid=848272
if you like, try it please.Thank you.

taxalian September 13, 2013 12:33

Hi Nigel332,

I can import the iges file, but the geometry is not clean. Can you provide a better version of this file.

Thanks.

Quote:

Originally Posted by nigel332 (Post 451439)
Hi, taxalian,

Thanks for your reply! and i will try as you said.

And yesterday I found another problem:
When I use extrusion to create the 3-D block mesh, something happened as shown in the following pic:
http://ntu.me/di/BOOW/扭曲效果.jpg
You see the extrude line was screwy. And i imagine the extrude line should be like this:
http://ntu.me/di/QOLI/正常效果.jpg

What is your opinion?

And the teu.iges flie of my ship model can be done loaded here:
http://www.yourfilelink.com/get.php?fid=848272
if you like, try it please.Thank you.


nigel332 September 13, 2013 20:26

Quote:

Originally Posted by taxalian (Post 451584)
Hi Nigel332,

I can import the iges file, but the geometry is not clean. Can you provide a better version of this file.

Thanks.

hI, taxalian

Thanks for your reply! The iges file I uploaded yesterday is the file I created by pointwiseV17 by export domin grids in iges file. So maybe you can not open it.
And the original iges file of the ship in iges file can be download from here:
https://app.box.com/s/m7fl8b0chf3guxcl4gps

Try to extrude with constant Y boundary condition please.

taxalian September 15, 2013 10:42

thanks for the iges file, i can import the geometry and let you know about the extruded mesh.
Quote:

Originally Posted by nigel332 (Post 451617)
hI, taxalian

Thanks for your reply! The iges file I uploaded yesterday is the file I created by pointwiseV17 by export domin grids in iges file. So maybe you can not open it.
And the original iges file of the ship in iges file can be download from here:
https://app.box.com/s/m7fl8b0chf3guxcl4gps

Try to extrude with constant Y boundary condition please.


nigel332 September 20, 2013 02:38

Quote:

Originally Posted by taxalian (Post 451814)
thanks for the iges file, i can import the geometry and let you know about the extruded mesh.

Hi, taxalian

Thanks for your reply! And I succeed with the extrude mesh. But you know it is half of the ship, and I want to create grids for whole mesh by using Mirror tool. But I am failed.

So, do you have any idea about why I cannot create grids with mirror tool to create the other part of the ship?

Thanks!

taxalian September 20, 2013 13:51

Quote:

Originally Posted by nigel332 (Post 452647)
Hi, taxalian

Thanks for your reply! And I succeed with the extrude mesh. But you know it is half of the ship, and I want to create grids for whole mesh by using Mirror tool. But I am failed.

So, do you have any idea about why I cannot create grids with mirror tool to create the other part of the ship?

Thanks!

Hi nigel332,
I think the problem by looking at your geometry, y-coordinate of your half model does not lie on y=0. Actually they lie on positive and negative y values at the symmetry plane. You need to shift your geometry on y=0 plane. Then try again with the mirror tool.

nigel332 September 20, 2013 19:55

Quote:

Originally Posted by taxalian (Post 452803)
Hi nigel332,
I think the problem by looking at your geometry, y-coordinate of your half model does not lie on y=0. Actually they lie on positive and negative y values at the symmetry plane. You need to shift your geometry on y=0 plane. Then try again with the mirror tool.

Hi,

I create the other block with y=-0.1 for example, then it works well. But when I move the new block to Y=0, the new block just missing!

So i am confused~~~

YanNW October 11, 2013 05:04

Can you solve it now?
 
Hi Dear,

Could you solve this problem ?
I also got the same problem now.. and stopped at this stage...
so high skew near the stern and cannot extrude well...

nigel332 October 11, 2013 09:35

Quote:

Originally Posted by YanNW (Post 456301)
Hi Dear,

Could you solve this problem ?
I also got the same problem now.. and stopped at this stage...
so high skew near the stern and cannot extrude well...

Hi YanNW,

I think it would be batter for you to solve your grids first. If needed you can try use triangle grids instead of totally quadrilateral grids.

Then try again.


All times are GMT -4. The time now is 01:29.