CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Pointwise & Gridgen (http://www.cfd-online.com/Forums/pointwise/)
-   -   Sphere in pointwise (http://www.cfd-online.com/Forums/pointwise/130349-sphere-pointwise.html)

agv10 February 24, 2014 16:26

Sphere in pointwise
 
Hi,

I am new to pointwise. I am trying to create a spherical geometry for the problem of flow over a sphere. I have been trying the 'rotate' tool along with 2D sketches to extrude it into a sphere but I keep getting an error that is something like - 'some mesh elements have negative Jacobian'.

Can anyone suggest a simple way to do this?

Thanks.

cnsidero February 24, 2014 23:29

4 Attachment(s)
Quote:

Originally Posted by agv10 (Post 476556)
Hi,

I am new to pointwise. I am trying to create a spherical geometry for the problem of flow over a sphere. I have been trying the 'rotate' tool along with 2D sketches to extrude it into a sphere but I keep getting an error that is something like - 'some mesh elements have negative Jacobian'.

Can anyone suggest a simple way to do this?

Thanks.

best

I'm a little bit confused how you're going about this but in general revolving a 2D mesh where there is mesh all the way to the axis will not result in a good 3D mesh.

The easiest way to do this and get a high quality structured mesh is with 6 blocks. It sounds complicated but it's not. Here's how ... start with a spherical geometry. If you don't have one, create a semi-circle db curve and revolve once 180 deg in one direction and revolve again 180 deg again in the other direction. It's generally not a good idea to do it in one step and revolve it 360 deg. Without the verbosity - trust me, do it in two halves. See first picture.

To mesh it create 12 connectors that form the sides of cude that enclose the sphere. My sphere has dia = 1 centered at (0,0,0) so I created a cube with sides L = 1 centered at (0,0,0). See second picture.

Project the 12 connectors onto the sphere by selecting all the connectors, Edit>Project (be sure to uncheck Interior Only). With all the connectors still selected set the dimension the connectors to your liking. I choose a dimension of 21 which results in a grid point spacing ~ 0.03. With all the connectors still selected create the domains with the Assemble Domains button on the toolbar. Select the 6 new domains and project them to the sphere (re-check Interior Only). With the 6 domains still selected smooth them 10-20 iterations with Grid>Solve. See third picture.

With the 6 domains still selected, create the volume mesh with Create>Extrude>Normal. In the attributes panel set the initial step size, growth rate and ensure the orientation normals point outward. I used a initial step size = 0.001, growth rate = 1.2. Go back to run tab and enter the number of steps, click Run. I choose 55 steps. The tricky part here is knowing how far to extrude to ensure the resulting farfield is far enough away. 55 steps resulted in farfield dia ~= 100. If you find it's too large or too small use Grid>Re-Extrude to add or remove steps. See the fourth image.

That should be it. Let me know if you have any questions.

agv10 February 28, 2014 19:22

Hi cnsidero,

Thanks for your detailed response. I managed to create the sphere by revolving the db semi-circle curve 180 degrees in two directions (Figure 1) but I my projection is incorrect. The full geometry that I am trying to create is a sphere contained in a cube.

Once I made the 12 connectors for the cube and projected them onto the sphere, only 4 domains were created and not 6 as you said. Two patches were left empty (Figure 2). I set projection control to the default parameter -'closest point' and set dimension to '20'.

Have I missed something in the settings for the projection?

agv10 February 28, 2014 21:01

3 Attachment(s)
I have attached images of what I've done so far.

cnsidero March 1, 2014 15:54

Quote:

Originally Posted by agv10 (Post 477361)
Hi cnsidero,
Once I made the 12 connectors for the cube and projected them onto the sphere, only 4 domains were created and not 6 as you said. Two patches were left empty (Figure 2). I set projection control to the default parameter -'closest point' and set dimension to '20'.

Have I missed something in the settings for the projection?

I see you're using an unstructured mesh. If that's the mesh type you want there's no need to use the approach I described. Instead simply select the two halves of the sphere and click the Create Domains on Database button in the tool bar.

My description was if you wanted a structured mesh.

agv10 March 4, 2014 21:05

Hi,

I tried doing that but once I select the two halves of the sphere (surface 1 + surface 2 under the tree on the left), the 'domains on database' option is disabled and I cannot select it. All my masks are checked at this point.

I created a semi circle db curve and revolved it 180 degrees in two directions to create a sphere, so I now have 3 entities in the tree - curve-1, surface-1 and surface-2.

cnsidero March 5, 2014 09:04

Quote:

Originally Posted by agv10 (Post 478138)
Hi,

I tried doing that but once I select the two halves of the sphere (surface 1 + surface 2 under the tree on the left), the 'domains on database' option is disabled and I cannot select it. All my masks are checked at this point.

Do you have a default dimension or average spacing set in the Defaults tab?

agv10 March 5, 2014 14:27

No, they are disabled too.

cnsidero March 5, 2014 14:28

Quote:

Originally Posted by agv10 (Post 478368)
No, they are disabled too.

That's it. To automatically assemble an unstructured domains on a database entity you must have a non-zero dimension or average spacing set.

agv10 March 5, 2014 14:45

But the dimension only gets enabled when I have connectors. I am starting from scratch by revolving the db semi-circle so I only have the sphere. At this point, can I enable the dimension or spacing without having connectors?

If I click 'connectors on database entities', I see the dimension get enabled but after I set a dimension, the 'domains on database' is still not enabled.

cnsidero March 5, 2014 15:34

Quote:

Originally Posted by agv10 (Post 478372)
But the dimension only gets enabled when I have connectors. I am starting from scratch by revolving the db semi-circle so I only have the sphere. At this point, can I enable the dimension or spacing without having connectors?

If I click 'connectors on database entities', I see the dimension get enabled but after I set a dimension, the 'domains on database' is still not enabled.

You're looking at the wrong dimension entry dialogue - not on the toolbar but in the Defaults panel. On the left side of Pointwise, is a panel with three tabs: List, Layers, Defaults. Click the Defaults tab. Within the Defaults panel, under Connectors are two entry entry dialogues: dimension and average ds. These are used to apply a non-zero dimension to newly created connectors including those created automatically by the Domains on Database command.


All times are GMT -4. The time now is 08:19.