CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   Connect to server (

LaGurk May 3, 2012 05:29

Connect to server
Hello Star-CCM+ Users,

I am trying to connect to a ccm+ server that is running on a linux machine from a Win7 computer. On the Win7 machine ssh is working without entering a password (public-private key pair), but it is still not possible to connect to the server. When I try to scan the host for running servers I get the error that no servers could be found. Connecting via ssh-tunnel is also not possible due to time out.
Had anyone the same problems and has a solution for me?


ryancoe May 3, 2012 09:36

I haven't been successful with the connect to server function across ssh (i think my network won't allow ssh without a password), but you might need to specify the port number on the remote server (see page below).

Let me know how it goes.

LaGurk May 3, 2012 10:49

Specifying a port number different from the default doesn't work. Maybe the feature "connect to server" is not really a feature but a bug...:mad:

Pauli May 3, 2012 13:31

On my system, the connect to server tunneling option quit working after version 6.02. I've had a problem with 6.04 & now 7.02.

Connect to server works fine when you do not need the tunneling option.

abdul099 May 3, 2012 13:46

You need to log in to the machine without the need for a password. Otherwise you can't connect to the server.
The issue is, when you need the ssh tunnel option, you will not be able to connect to the Linux machine without a password. Therefore this combination will not work.
An option to get around this would be to set up a vnc server on the Linux machine and forward your display to the vnc server and start a vnc client on the windows machine.

LaGurk, the port number needs to meet the server port number. Any other can never work since the server will not listen to an attempt to connect on any port other than the one used when starting the server (see the output, there should be something like "server start machineName:47827" where 47827 is the port number. This number will change when more than one server is running on the same machine.

Pauli May 3, 2012 13:55

I can login without a password. Tunneling works from the shell command line. And the same system worked fine in v6.02 but not since.

Pauli May 3, 2012 15:10

Sorry. Tunneling in v7.02.008 does work. You need the correct ssh options:
"-n -o StrictHostKeyChecking=yes -o PasswordAuthentication=no -N"

LaGurk May 4, 2012 06:23

I don't really need the ssh tunnel option, because my server is running on the machine I can directly login from outside the company network. But scanning the host does not give any running server.

Pauli, I already tryed your options, but without any effort.

I open a ssh connection from my Win7 machine using pageant, so I do not have to enter any password, to the linux machine where the ccm+ server is running. Then I start ccm+ on my local Win7 computer and try to connect to the server on the linux machine, which does not work. I even can't open a remote server on the linux machine from my local Win7 computer.
Has anyone an idea, what I am doing wrong?

abdul099 May 6, 2012 08:39

Do you use the same user name (login name) on the machine running the server and the machine dedicated to be your client? If not, you will not be able to connect as long as you haven't activated "collaboration" (or used the -collab switch) on the server.

Do you use the same ccm+ version? It should work within the same main version, so you should be able to connect to a 6.04.008 server with a 6.04.011 client or vice versa, but not to a 6.04.x server from a 6.0x.xx client except 6.04.x.

Scanning hosts often does not work. Sometimes it helps to scan twice or even more often. But usually I need to remember the server port name and enter it in the "connect to server" dialog manually. Did you already try this?

All times are GMT -4. The time now is 05:17.