CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

Connect to server

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 3, 2012, 05:29
Question Connect to server
  #1
New Member
 
Join Date: Apr 2012
Posts: 6
Rep Power: 5
LaGurk is on a distinguished road
Hello Star-CCM+ Users,

I am trying to connect to a ccm+ server that is running on a linux machine from a Win7 computer. On the Win7 machine ssh is working without entering a password (public-private key pair), but it is still not possible to connect to the server. When I try to scan the host for running servers I get the error that no servers could be found. Connecting via ssh-tunnel is also not possible due to time out.
Had anyone the same problems and has a solution for me?

Thanks!
LaGurk is offline   Reply With Quote

Old   May 3, 2012, 09:36
Default
  #2
Member
 
Ryan Coe
Join Date: Jun 2010
Location: Albuquerque, NM
Posts: 98
Rep Power: 7
ryancoe is on a distinguished road
I haven't been successful with the connect to server function across ssh (i think my network won't allow ssh without a password), but you might need to specify the port number on the remote server (see page below).

https://wiki.anl.gov/tracc/Speeding_..._Remote_Server

Let me know how it goes.
__________________
Ryan

Last edited by ryancoe; May 3, 2012 at 09:37. Reason: needed to add something
ryancoe is offline   Reply With Quote

Old   May 3, 2012, 10:49
Default
  #3
New Member
 
Join Date: Apr 2012
Posts: 6
Rep Power: 5
LaGurk is on a distinguished road
Specifying a port number different from the default doesn't work. Maybe the feature "connect to server" is not really a feature but a bug...
LaGurk is offline   Reply With Quote

Old   May 3, 2012, 13:31
Default
  #4
Senior Member
 
Pauli
Join Date: Mar 2009
Posts: 181
Rep Power: 8
Pauli is on a distinguished road
On my system, the connect to server tunneling option quit working after version 6.02. I've had a problem with 6.04 & now 7.02.

Connect to server works fine when you do not need the tunneling option.
Pauli is offline   Reply With Quote

Old   May 3, 2012, 13:46
Default
  #5
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
You need to log in to the machine without the need for a password. Otherwise you can't connect to the server.
The issue is, when you need the ssh tunnel option, you will not be able to connect to the Linux machine without a password. Therefore this combination will not work.
An option to get around this would be to set up a vnc server on the Linux machine and forward your display to the vnc server and start a vnc client on the windows machine.

LaGurk, the port number needs to meet the server port number. Any other can never work since the server will not listen to an attempt to connect on any port other than the one used when starting the server (see the output, there should be something like "server start machineName:47827" where 47827 is the port number. This number will change when more than one server is running on the same machine.
__________________
We do three types of jobs here:
GOOD, FAST AND CHEAP
You may choose any two!
abdul099 is offline   Reply With Quote

Old   May 3, 2012, 13:55
Default
  #6
Senior Member
 
Pauli
Join Date: Mar 2009
Posts: 181
Rep Power: 8
Pauli is on a distinguished road
I can login without a password. Tunneling works from the shell command line. And the same system worked fine in v6.02 but not since.
Pauli is offline   Reply With Quote

Old   May 3, 2012, 15:10
Default
  #7
Senior Member
 
Pauli
Join Date: Mar 2009
Posts: 181
Rep Power: 8
Pauli is on a distinguished road
Sorry. Tunneling in v7.02.008 does work. You need the correct ssh options:
"-n -o StrictHostKeyChecking=yes -o PasswordAuthentication=no -N"
Pauli is offline   Reply With Quote

Old   May 4, 2012, 06:23
Default
  #8
New Member
 
Join Date: Apr 2012
Posts: 6
Rep Power: 5
LaGurk is on a distinguished road
I don't really need the ssh tunnel option, because my server is running on the machine I can directly login from outside the company network. But scanning the host does not give any running server.

Pauli, I already tryed your options, but without any effort.

I open a ssh connection from my Win7 machine using pageant, so I do not have to enter any password, to the linux machine where the ccm+ server is running. Then I start ccm+ on my local Win7 computer and try to connect to the server on the linux machine, which does not work. I even can't open a remote server on the linux machine from my local Win7 computer.
Has anyone an idea, what I am doing wrong?
LaGurk is offline   Reply With Quote

Old   May 6, 2012, 08:39
Default
  #9
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
Do you use the same user name (login name) on the machine running the server and the machine dedicated to be your client? If not, you will not be able to connect as long as you haven't activated "collaboration" (or used the -collab switch) on the server.

Do you use the same ccm+ version? It should work within the same main version, so you should be able to connect to a 6.04.008 server with a 6.04.011 client or vice versa, but not to a 6.04.x server from a 6.0x.xx client except 6.04.x.

Scanning hosts often does not work. Sometimes it helps to scan twice or even more often. But usually I need to remember the server port name and enter it in the "connect to server" dialog manually. Did you already try this?
__________________
We do three types of jobs here:
GOOD, FAST AND CHEAP
You may choose any two!
abdul099 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFD Online Back on Main Server pete Site News & Announcements 0 March 31, 2011 18:14
CFD Online Running on Backup Server pete Site News & Announcements 0 March 25, 2011 15:51
connect failed with errno%3d113 wedsall OpenFOAM Running, Solving & CFD 2 November 3, 2008 05:17
CFD Online Running on a New Server CFD Online Team Main CFD Forum 2 November 30, 2007 17:58
CFD Online Server Load Jonas Larsson Main CFD Forum 0 March 13, 2001 15:29


All times are GMT -4. The time now is 01:51.