CFD Online Discussion Forums

CFD Online Discussion Forums (
-   STAR-CCM+ (
-   -   Star-CCM+ co-simulation with Abaqus (

bandits August 15, 2012 14:36

Star-CCM+ co-simulation with Abaqus
So I was just going through the mechanical co-simulation tutorial in Star, followed it down to a tee but when I click run this error message appears...

"Error in spawning Abaqus Pre job. Please check executable name."

I've gone over this a number of times and it's just frustrating me at this stage. The three executable names I've tried are

or "C:\SIMULIA\Abaqus\Commands\<abaqus or abq610ef1>"

The last one, including the directory, was suggested for Windows within the Star manual.

Also I launched star-ccm+ through cmd as well as providing access to the dynamic link libraries using cmd before launching. Just wondering if anyone has a clue as to what the problem could be?! :confused::confused::confused:

EDIT: Just figured out the co-simulation licences were not installed :o. I was told they were but they're not that's why abaqus is failing to launch. I'd delete this post if I could because it' a bit of a waste but I can't find out how to do that either.

Jose1994 July 5, 2016 09:18

Dear all,

I am having a similar issue to the one described above. I have done the FSI tutorial from CD-Adapco´s tutorial guide. I am having issues with the co-simulation libraries. The error message that I get is the following:

"Loading the SIMULIA Co-Simulation Engine shared libraries failed. In order for STAR-CCM+ to automatically locate the libraries, check the following:

I am specifying the full path to the Abaqus executable in "C:\SIMULIA\Commands", it locates the executable ok because it starts checking things but fails to load the co-simulation libraries.

Any Ideas what can be going on here?

Thanks for the help,


All times are GMT -4. The time now is 05:46.