CFD Online URL
[Sponsors]
Home > Forums > STAR-CCM+

Windows Cluster

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By abdul099

Reply
 
LinkBack Thread Tools Display Modes
Old   August 16, 2012, 12:21
Default Windows Cluster
  #1
Member
 
David
Join Date: Aug 2012
Posts: 47
Rep Power: 4
GM_XIII is on a distinguished road
Hi friends

I'm trying to run a cluster in Windows, well it's not really a cluster is a multi remote pcs station. So i have severall laptops connected to a network. I installed in all of them star ccm+ and MPICH and i register in mregister.exe the proper user and password.

When i try to run a simulation with 2 pcs i have no problems with for example:
starccm+ -server -on 192.168.1.12
but when i add one more computer like:
starccm+ -server -on 192.168.1.12,192.168.1.13
i get a LaunchProcess Error

Thanks, and please ask for more information if it is needed, i will try to give more details soon

New Update


I have solved almost all problem above and i can run easily a remote multi-PC system with 32 bits system but now i'm trying to add that server severall 64 bits PCs, which i dont know if it's possible at all, please i will be very if someone can help me i'm starting with CFD.

The error that i keep getting when i try to run a 64 bit machine from a 32 bit one is the following:

Starting local server: starccm+ -server -on 192.168.1.10:2 -collab -master david
getmpifinalized returned: FAIL
Sending kill commands to launched processes
getmpifinalized returned: FAIL
process 0 on david exited without calling MPIFinalize

Before this error i get another one that i solved by moving the starccm folder on the 64 bits PC. Thanks you in advance.

Last edited by GM_XIII; August 17, 2012 at 12:42. Reason: Updates
GM_XIII is offline   Reply With Quote

Old   August 28, 2012, 20:12
Default
  #2
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
I think it's not possible to run a simulation on a 32bit and a 64bit machine at the same time.
Connecting a 32bit client to a 64bit server works fine, but the server can't run on 32 and 64bit at a time.
siara817 likes this.
__________________
We do three types of jobs here:
GOOD, FAST AND CHEAP
You may choose any two!
abdul099 is offline   Reply With Quote

Old   August 30, 2012, 04:26
Default
  #3
Member
 
David
Join Date: Aug 2012
Posts: 47
Rep Power: 4
GM_XIII is on a distinguished road
Thanks you for your answer .
I've realised of that too, now I'm trying to make work a 64 bits cluster but i can't since the program tells me that there is a mpi problem even when the pcs individually can run in parallel. Have someone had this problem? It also says something about a Logon error.
GM_XIII is offline   Reply With Quote

Old   August 30, 2012, 19:49
Default
  #4
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
To run in parallel, you need to be able to login from a machine to every other machine without the need to specify a password.
I had similar issues during my thesis due to (global) network restrictions from the IT department. It was weird since I had a valid account and could locally login on every machine without any issues. It looked like the user rights didn't allow the communication to take place. The solution was to give me access to a (local) superuser account (all machines run on Windows XP). I would try that, when it works, it's the somewhere buried in the OS setup.

Otherwise it might get too complicated. The issue is, I don't have multiple machines at home and most of the time I'm using Linux. Therefore I'm running out of ideas very quickly. Maybe you can call the CD-adapco support desk, the guys there will have more experience.
__________________
We do three types of jobs here:
GOOD, FAST AND CHEAP
You may choose any two!
abdul099 is offline   Reply With Quote

Old   August 31, 2012, 07:11
Default
  #5
Member
 
David
Join Date: Aug 2012
Posts: 47
Rep Power: 4
GM_XIII is on a distinguished road
Thanks for your answer. When I ran it in 32 bits system i set the same username and password to all pcs and there was no problem but now with the 64 bits i can't, i will try to look for more information about what you've said, thanks again for the hint.
GM_XIII is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFX11 + Fortran compiler ? Mohan CFX 20 March 30, 2011 19:56
Dual Boot Windows and Linux and Go Open Source andyj Main CFD Forum 2 October 21, 2010 17:49
Cross-compiling OpenFOAM 1.7.0 on Linux for Windows 32 and 64bits with Mingw-w64 wyldckat OpenFOAM Announcements from Other Sources 3 September 8, 2010 07:25
setup windows cluster radiatn STAR-CD 2 March 30, 2009 14:52
Fluent on a Windows cluster Erwin FLUENT 4 October 22, 2002 12:39


All times are GMT -4. The time now is 01:31.