CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   STAR-CCM+ (http://www.cfd-online.com/Forums/star-ccm/)
-   -   Overset mesh error. (http://www.cfd-online.com/Forums/star-ccm/113901-overset-mesh-error.html)

arun7328 February 28, 2013 15:00

Overset mesh error.
 
2 Attachment(s)
Hi all

I am trying to create an overset mesh for a problem of cylinder falling into water. I did the mesh and when i initialize i get the error "found inactive faces in region background.Could be due to too coarse or fine. I have made sure that the region of overlap has the same mesh size and has more than 4-5 cells.

Can anyone please help me out with the error?

The cells in the outer of the overset mesh is of 0.1 m and that in the background symmetry plane is of 0.125 m. I have attached the mesh and status diagram..

Please tell me what i should check. I have tried to change the sizes and check but still i get the same error.

Regards
Arun

arun7328 February 28, 2013 15:15

just to add this is my cell status..the picture is better...

Pls give me a tip if you know how to get this right..

lava12005 February 28, 2013 23:47

Hi,

It seems from your Overset cell status the background value is 1 (red coloured) which means in-active and it shouln't be that way I suppose?
Maybe you should check whether you are assigning the correct overset boundary type to the correct boundary?
Or have you created the Overset Interface between the 2 domain?

arun7328 March 1, 2013 04:28

I have created the overset interphase between the two and when i try to initialize the interface it fails. Now with changing the mesh values of the 2 regions i have got to another error which says "failed to cut a hole..could be a problem with overlap"..but how to check this overlap..I have left enoung cells in the overlap region of both boundaries.

thanks
arun

grad@itu March 1, 2013 14:41

if you want, you can send your file to me.. i would like to see..

arun7328 March 1, 2013 19:34

ya sure ..i got it running now but after some time it displays an error the mesh might be too coarse or fine. Can i put it in the drop box? how can i share it with u?..my id is arun7328@gmail.com..if you gimme ur id i can share it with u...

Thanks a lot
Regards
Arun

arun7328 March 3, 2013 17:24

Quote:

Originally Posted by grad@itu (Post 410922)
if you want, you can send your file to me.. i would like to see..

how should i send the file?..I have got it running but after some time it gives the same error, that the mesh is coarse of fine..I am not able to figure out why because i have made sure that the overset does not cross boundary region and also the mesh sizes even during movement is comparable. The physics is happening correctly now.

Regards
Arun

phanh January 20, 2014 22:19

Quote:

Originally Posted by arun7328 (Post 411218)
how should i send the file?..I have got it running but after some time it gives the same error, that the mesh is coarse of fine..I am not able to figure out why because i have made sure that the overset does not cross boundary region and also the mesh sizes even during movement is comparable. The physics is happening correctly now.

Regards
Arun

Hi Arun,

Did you solve your problem? I have the similar error message. could you give me some advises for this issue?

Best regards

arun7328 January 21, 2014 05:13

Hi.

Yes I solved the problem. Not sure what you are facing though. The problem with my model was that the mesh sizes on the boundary of the overset and the background were not the same. They have to exactly similar. In my case overset boundary was 0.1m and back ground was 0.125. I changed both to 0.1 and it worked.

Hope it works for you, if not explain yours and we shall see what to do.

Regards
Arun

phanh January 22, 2014 09:58

Hi Arun,

Thank you for taking your time. I also solved my problem.

Best regards

EnronZhang May 1, 2014 18:11

Hi Arun,

I have the similar problem as you had before. Just wondering that the mesh sizes of overset and back ground should be exactly the same, does it mean the volume mesh or the surface remesh? Because I have made the volume meshes in the same sizes for both region, but it still did not work.

Many thanks.
Enron

Quote:

Originally Posted by arun7328 (Post 471015)
Hi.

Yes I solved the problem. Not sure what you are facing though. The problem with my model was that the mesh sizes on the boundary of the overset and the background were not the same. They have to exactly similar. In my case overset boundary was 0.1m and back ground was 0.125. I changed both to 0.1 and it worked.

Hope it works for you, if not explain yours and we shall see what to do.

Regards
Arun


arun7328 May 2, 2014 04:32

Dear Zhang,

Its the volume meshes. What is the error message you are getting? Are you able to initialise the interface.

Regards
Arun

dhaval July 9, 2015 17:04

I am running into same issue. In my case, background mesh has prism layers on the boundaries. When overset mesh enters into this prism layers, I get the error message. May be it is because prism mesh is smaller?

Background mesh size: 1.25 mm
Size of first prim layer in background mesh: 0.77 mm
Overset mesh size: 1 mm

I am not sure if the error message (mesh is either too small or too coarse) is due to two surfaces coming too close or because of size difference. I run another simulation with following sizes and it run without any problem (background: 1.45, prism: 0.85, overset: 1)

ggulgulia July 16, 2015 08:33

Hi Everybody

From the images posted above, it was obvious that the cells were not intersecting properly. The best method to avoid this is to use mesh size in the Background Region nearly 1.5 times the mesh size in the Overset Region.

withwolf April 6, 2016 09:42

I'm facing the same problem. It turns out that I forgot to set the overset interface interpolation option to "linear".

rahulpawar July 5, 2016 14:34

Hi all

I am also running in to same problem. I have maintained background mesh size and overset mesh size same at boundaries, still problem exist. any guess what could be the reason?


All times are GMT -4. The time now is 19:44.