CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

Field function for translation

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 6, 2013, 13:29
Default Field function for translation
  #1
Member
 
Arun Krishnan.L.H
Join Date: Jan 2013
Posts: 75
Rep Power: 4
arun7328 is on a distinguished road
Dear all,

I have created a filed function for oscillation of a cylinder on free surface and then was trying to provide reference of the field function in translation. I am getting an error during this operation.

Cannot evaluate expression $$WallVelocity on Simulation>MotionManager>TranslatingMotion("Transl ation")>VectorPhysicalQuantity>InlineFieldFunction ("InlineFieldFunction")
Command: SetProperties

My field function name is WallVelocity

I have defined it as

[(($Time<0.05) ?
(1*$$Position(“wall”) [1]) :
(0.1*sin(360./6.2831853*$Time)*$$Position(“wall”) [1])), 0, 0]

a simple SHM with amplitude of 0.1 and frequency of 1 rad/s.

This does not show any syntax error.

Then i refer the field function using $$WallVelocity in my translation motion and i get the error specified above?

Can anyone guide me where things are going wrong?

Thanks

Regards
Arun
arun7328 is offline   Reply With Quote

Old   March 6, 2013, 13:49
Default
  #2
New Member
 
AndrewLBloxom's Avatar
 
Andrew L. Bloxom
Join Date: Dec 2010
Location: Blacksburg, VA
Posts: 7
Rep Power: 6
AndrewLBloxom is on a distinguished road
Did you set the type and function name in the properties window?

Did you use a Tools>Motions, to define a Translation Motion with you field function at the Translation Velocity?
AndrewLBloxom is offline   Reply With Quote

Old   March 6, 2013, 15:21
Default
  #3
Member
 
Arun Krishnan.L.H
Join Date: Jan 2013
Posts: 75
Rep Power: 4
arun7328 is on a distinguished road
Quote:
Originally Posted by AndrewLBloxom View Post
Did you set the type and function name in the properties window?

Did you use a Tools>Motions, to define a Translation Motion with you field function at the Translation Velocity?
Hello Andrew,
I did assign type as velocity and function name as WallVelocity and Translation velocity was assigned $$WallVelocity.

Thanks
Regards
Arun
arun7328 is offline   Reply With Quote

Old   March 6, 2013, 15:25
Default
  #4
Member
 
Arun Krishnan.L.H
Join Date: Jan 2013
Posts: 75
Rep Power: 4
arun7328 is on a distinguished road
Also this is a problem of free surface with VOF definition. To specify calm water condition with no velocity, i have defined VOF waves and given 0.0 amplitude.
Is it possible to have a wall condition and symmetry planes all around and still define VOF waves?I am getting an error.

Can you please tell me how to specify a calm water condition with the motion of this cylinder on free surface?

If you could just guide.

Regards
Arun
arun7328 is offline   Reply With Quote

Old   March 6, 2013, 15:42
Default
  #5
New Member
 
AndrewLBloxom's Avatar
 
Andrew L. Bloxom
Join Date: Dec 2010
Location: Blacksburg, VA
Posts: 7
Rep Power: 6
AndrewLBloxom is on a distinguished road
You should be able to define a flat wave, use the hydrostatic and volume fraction definitions for your initial condition and then oscillate it. You may want to make the bottom a zero velocity inlet and the top a pressure outlet.

I'm not sure about your wall velocity function. You might want to try and implement the motion through a grid velocity applied to the top and bottom with the morpher.
AndrewLBloxom is offline   Reply With Quote

Old   March 6, 2013, 18:44
Default
  #6
Member
 
Arun Krishnan.L.H
Join Date: Jan 2013
Posts: 75
Rep Power: 4
arun7328 is on a distinguished road
Thanks a lot.
Will try your suggestions.

Regards
Arun
arun7328 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems after decomposing for running alessio.nz OpenFOAM 5 April 20, 2011 08:44
Force Report help~ or maybe Custom Field Function sailor FLUENT 0 April 13, 2011 03:45
OpenFOAM static build on Cray XT5 asaijo OpenFOAM Installation 9 April 6, 2011 12:21
latest OpenFOAM-1.6.x from git failed to compile phsieh2005 OpenFOAM Bugs 25 February 9, 2010 05:37
Compilation errors in ThirdPartymallochoard feng_w OpenFOAM Installation 1 January 25, 2009 07:59


All times are GMT -4. The time now is 16:49.