CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

Star-CCM+ at Cluster [Windows Server 2008 R2 Enterprise x64]

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 28, 2013, 15:10
Angry Star-CCM+ at Cluster [Windows Server 2008 R2 Enterprise x64]
  #1
cwl
Member
 
Chaotic Water
Join Date: Jul 2012
Posts: 58
Rep Power: 6
cwl is on a distinguished road
Send a message via Skype™ to cwl
Hello

I'm totally stuck while trying to make a cluster for Star-CCM+.
I beg for help/instructions.

Hardware:
2 Workstations s5520sc with 2x Xeon x5550 (named Node-0 and Node-1)

OS:
Clean Windows Server 2008 R2 x64 Enterprise

What was done:
1) Domain (using Active Directory Services) was created at Node-0, both computers were included in Domain ("Cluster.cwl").

2) Accounts with the same name and password were created at both computers - but i'm confused: there exist Administrator account (set up at Windows setup) and Administrator@Cluster.cwl account (was created after Domain setup).

3) Feature -> Cluster was added, both computers are present in Nodes list.

4) Windows Firewall and UAC were turned off on both computers.

4) Star-CCM+ 8.04.007 was installed on both computers.

5) Following command was executed at both computers:
"C:\Program Files\CD-Adapco\STAR-CCM+8.04.007\mpi\mpich2_ch3\win64\bin\mpiexec.exe" -register
same (existing) username and password were passed.

6) Using ProcessMonitor i found out that Star was looking for rsh - so i've put a downloaded third-party rsh-client at Node-0 and set up a third-party rsh-service at Node-1. Node-0 is supposed to be a "head" node - Star GUI would be started there.

Using rsh-client on Node-0 i started Notepad.exe on Node-1 - it has appeared in process list, yet window was invisible.

Launching Star (from Node-0) on two nodes from GUI leads to Star-processes started at Node-1, BUT - this results in "Server process ended unexpectedly (return code 0)." at Star GUI.

My ideas: if i get it right - Star (GUI) at "master" computer launches Star server at "slave" computer through rsh and tries to connect to it - and it fails i guess.

What might be done in dummy tries (haven't done yet because of being sick and tired):

A) Install rsh-client on Node-1
Б) Install rsh-server on Node-0

I'll try it - but according to my understanding of architerctre this has no sense.

I would be endlessly thankful for any help .. guys, i'm desperate :<
cwl is offline   Reply With Quote

Old   July 28, 2013, 16:57
Default
  #2
cwl
Member
 
Chaotic Water
Join Date: Jul 2012
Posts: 58
Rep Power: 6
cwl is on a distinguished road
Send a message via Skype™ to cwl
Please if anyone has made cluster for Star-CCM+ - give me instuctions, i've no ideas left.
cwl is offline   Reply With Quote

Old   July 29, 2013, 00:10
Default
  #3
Senior Member
 
Arjun
Join Date: Mar 2009
Location: Nurenberg, Germany
Posts: 437
Rep Power: 13
arjun is on a distinguished road
can you ask this to adapco support. PS: I work for adapco, but support should help you with it.
arjun is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem when imported geometry from 3D CAD to star ccm, TAREK GANAT STAR-CCM+ 1 May 21, 2013 22:15
Using starToFoam clo OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 33 September 26, 2012 04:04
Restart Star CCM server? Apocolapse STAR-CCM+ 1 January 10, 2012 04:56
StarToFoam error Kart OpenFOAM Meshing & Mesh Conversion 1 February 4, 2010 05:38
Trimmed cell and embedded refinement mesh conversion issues michele OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 2 July 15, 2005 04:15


All times are GMT -4. The time now is 05:41.