CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   STAR-CCM+ (http://www.cfd-online.com/Forums/star-ccm/)
-   -   Memory Exception Workaround?! (http://www.cfd-online.com/Forums/star-ccm/68291-memory-exception-workaround.html)

Maddin September 14, 2009 03:34

Memory Exception Workaround?!
 
I have serveral problem whit creating some meshes because this happens in only one process under windows.
Simulations are splitted because I have more cores but only 32Bit...
Is there a trick to create the mesh on 2 processes? Mesh isn't very big, only 300MB but the task manager shows me that CCM needs much more memory for the volume mesh... and then I get a memory error (bad alloc).
Import mesh looks nice, should I look for some faults?

bramv101 September 14, 2009 04:37

i would say, check your mesh settings. Maybe there is a decimal point misplaced so your mesh size goes very fine. this is usually the cause of these type of problems.

A good tip is to do a surface mesh with coarse settings and examine results. from there add more detail

Maddin September 14, 2009 04:54

The cell size is 1mm, base and maximum. Surface cell size the same. Should I make in coarse?
Maybe I should update to 64Bit...

bramv101 September 14, 2009 05:46

The actual cell size doesn't tell me much, you should compare it to the dimensions of your part. if your part is 100 meters in diameter and your cells only 1mm then you are going to get a huge model.

Take for base size 5 percent of your main inlet orifice, and leave everything else at default. then try to do surface mesh NOT volume mesh. Check your mesh and if you notice that not enough detail is included, adjust your surface size max=100% and min=15%

If you could post a rough sketch of your geometry and your base dimensions, this would be good to start from

Maddin September 14, 2009 06:23

Ok I will look what I can do.
Dimension isn't very big, 1mm is a little bit to coarse I think.
When I make a corse volume mesh I get problems with rasing the mass flow etc. :(

Maddin September 14, 2009 16:37

I have checked all my settings. I had a extrusion of my wall. :rolleyes::D Don't know how it came... but it was set...
Thanks for help.;)


All times are GMT -4. The time now is 23:20.