CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

Floating error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 17, 2009, 07:27
Default Floating error
  #1
New Member
 
Join Date: Nov 2009
Posts: 12
Rep Power: 7
Arconis is on a distinguished road
Hi, i'm getting a floating point exception just after running the simulation, before any iteration complete. (It takes several minutes)

It happened in two cases:

- When i use ideal gas model with a specified temperature and a catalyst.

I solved that running as constant density 100 iterations and then switching to ideal gas

- Using constant density model with a filter (porous region).

Solved running with fluid region filter 20 iterations and then changing it to porous region


Can you tell me if i did it well or there's another or easier solution?


Server Error: A floating point exception has occurred: floating point exception [Invalid operation]. The specific cause cannot be identified.

Last edited by Arconis; November 25, 2009 at 04:37.
Arconis is offline   Reply With Quote

Old   November 25, 2009, 01:35
Default
  #2
Senior Member
 
Ping
Join Date: Mar 2009
Posts: 223
Rep Power: 9
ping is on a distinguished road
Ideal gas is much more sensitive and can take a bit of effort to get going occasionally - here are some ideas:
try reducing the under-relaxation factors
use better initial conditions
your boundary conditions might be too radial for the steady solver - reduce their values by an order of magnitude or two and step them up again as the solution develops
change to the implicit transient solver
ping is offline   Reply With Quote

Old   November 25, 2009, 04:23
Default
  #3
New Member
 
Join Date: Nov 2009
Posts: 12
Rep Power: 7
Arconis is on a distinguished road
thx ping, i'll try that
Arconis is offline   Reply With Quote

Old   February 8, 2012, 04:09
Default Floating error
  #4
Member
 
Join Date: Jan 2012
Posts: 58
Rep Power: 5
sheikh nasir is on a distinguished road
Hello
i am getting floating error:invalid number. I am working on train travelling in tunnel. Can any body help me. My email is sheikhnasir39@gmail.com

thanks
sheikh nasir is offline   Reply With Quote

Old   February 18, 2012, 07:52
Default
  #5
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
What about a little bit more information on the problem, setup etc.? I lost my crystal ball last week, so I'm no visionary anymore...

Quote:
Originally Posted by sheikh nasir View Post
Hello
i am getting floating error:invalid number. I am working on train travelling in tunnel. Can any body help me. My email is sheikhnasir39@gmail.com

thanks
abdul099 is offline   Reply With Quote

Old   February 18, 2012, 10:12
Default floating errror
  #6
Member
 
Join Date: Jan 2012
Posts: 58
Rep Power: 5
sheikh nasir is on a distinguished road
hello,
i am using gambit and fluent for my analysis i.e train moving in tunnel. i am trying for 2D analysis. but i am getting floating error; invalid number. plz help me
sheikh nasir is offline   Reply With Quote

Old   February 18, 2012, 11:08
Default
  #7
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
Quote:
Originally Posted by sheikh nasir View Post
hello,
i am using gambit and fluent for my analysis i.e train moving in tunnel. i am trying for 2D analysis. but i am getting floating error; invalid number. plz help me
Did you ever think about the reason why there's a different forum for every software? What the f... do you think should somebody answer without knowledge of the software used by you?
This is the forum for STAR-CCM+ forum, N O T gambit and fluent

Ask in the gambit and or fluent forum, maybe you will get an answer there. And if not, DO NOT ask here again, you won't get an answer here nearly for sure!
abdul099 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 09:45.