CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

help with Baffles...

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 26, 2010, 15:32
Default help with Baffles...
  #1
syd
New Member
 
Mattia
Join Date: Mar 2010
Posts: 7
Rep Power: 6
syd is on a distinguished road
Hi everyone!

I am simulating a sailboat, with a mainsail and a jib: I managed to create a mesh that satisfies me, but it's huge(8 millions of cells of volume mesh), so I'm trying to reduce it; one way I read about was "transforming" the sails in baffles interfaces.

Untill now, I imported the 2 sails in CCM as .IGES files, with a thickness of 0.4 mm: in this way, everything works, but the resulting mesh is huge, as I said before, because of the very small thickness.

So, I tried to import them as superficies, with no thickness (as .IGES files): the software allow me to import them, but it warns me that they "are not solid": in fact, as I try to perform a boolean union (between the hull+mast+boom and one sail) I get an error message "not closed and manifold region", referring to the sail.

My question is: how do I handle my boundaries:
-mainsail
-jib
-boat
-wind tunnel
if I want to turn my 2 sails in 2 baffles with no thickness?

thanks to everyone!!!
syd is offline   Reply With Quote

Old   April 26, 2010, 16:06
Default
  #2
Senior Member
 
Join Date: Mar 2009
Location: Austin, TX
Posts: 130
Rep Power: 8
kyle is on a distinguished road
You are not going to be able to mesh the sail as a baffle in Star-CCM+, at least not easily.

You can try meshing the same way that you originally tried, but disable proximity refinement in the mesher. This way it will not create tiny cells all over the sail.
kyle is offline   Reply With Quote

Old   April 27, 2010, 17:36
Default
  #3
Member
 
Vinicius Girardi
Join Date: Mar 2009
Location: Sao Paulo, Brazil
Posts: 80
Rep Power: 7
Vinicius is on a distinguished road
Before meshing, right click at the boundary that have your "only surface" sail and click in convert to interfaces. Keep both in the same region, and in the node called interfaces, change the interface type from Internal Interface to Baffle interface. This allows you to generate a mesh without no manifold edges.

Try to see where these non-manifold edges are in your model, in the surface repair mode. They will be the blues edges.

Always check your surface to see if it has non-manifold edges/vertices, free edges and self-intersections.
Vinicius is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SnappyHexMesh for internal Flow vishwa OpenFOAM Native Meshers: snappyHexMesh and Others 23 August 6, 2014 03:50
external flow with snappyHexMesh chelvistero OpenFOAM 11 January 15, 2010 19:43
Including baffles in automatic meshing(pro amm) Ankush Aggarwal CD-adapco 2 June 28, 2006 02:24
Loosing baffles while creating a volume mesh Susanne CD-adapco 0 May 9, 2006 02:52
Mesh problems for a stirred vessel with baffles! UY CFX 0 September 14, 2005 10:19


All times are GMT -4. The time now is 11:23.