CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   STAR-CCM+ (http://www.cfd-online.com/Forums/star-ccm/)
-   -   Meshing error (http://www.cfd-online.com/Forums/star-ccm/76924-meshing-error.html)

Mlynam June 8, 2010 12:29

Meshing error
 
I am getting an error when attempting to re-mesh my surface and create a volume mesh. The error reads:
orientFaces: Sidedness had an error
has anyone seen this error? I am running version 4.06.011 and using the polyhedral, prism layer, and surface remesher for the model. Any help would be appreciated.

ML

Vinicius June 8, 2010 16:01

Check if your imported surfaces doesnŽt have pierced faces or other errors. Maybe youŽll need to use the surface wrapper tool.

Mlynam June 8, 2010 17:20

I did inspect the original surface and I couldnt't find any pierced or strangley formed geometry. Also - surface wrapper is out of the question as I have multiple regions in the geometry. Thank you for your reply, do you have any other ideas?

ML

Vinicius June 8, 2010 18:06

You said you have multiple regions, are they already set or you will split by surface topology to create the interfaces?

Mlynam June 9, 2010 12:20

They are already set and the interfaces have been created.

ML

f-w June 9, 2010 13:07

The wrapper can be used on multiple regions if "per-region meshing" is checked in your mesh continua; you won't have a conformal mesh at the interfaces as a result, though.

Mlynam June 9, 2010 17:55

Ah! I have a mesh. Thank you for your help everyone!

ML

abdul099 July 6, 2010 09:47

Maybe you want to tell us what the cause for the problem has been? It could also help other users with a similar problem...

Best regards,

Mlynam July 8, 2010 13:16

abdul099,

I believe I was having the issue because I was applying a single mesh continuim to multiple regions. When I applied the "per-region meshing" option I no longer had the problem. Does that help?

ML

TrII4d November 29, 2011 16:47

@ Mlynam and abdul099

yes that was the reason. I had the same problem as u abdul099.
I activated "per-region meshing" and now star ccm+ mashed.

thank you so much!

greetz

Mgolse January 2, 2012 15:29

Per region meshing works but if I would like a conformal mesh at the interfaces this will not suffice.


All times are GMT -4. The time now is 20:24.