CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   STAR-CCM+ (http://www.cfd-online.com/Forums/star-ccm/)
-   -   Difficulty meshing a two region problem (http://www.cfd-online.com/Forums/star-ccm/79182-difficulty-meshing-two-region-problem.html)

james15 August 15, 2010 22:02

Difficulty meshing a two region problem
 
2 Attachment(s)
Hello,

I am have difficulty properly meshing a simple case containing a solid rectangular cooling channel with fluid flow through the center (heat transfer will occur from the outside of the cooling channel and into the working fluid). For some reason the surface mesh along the boundaries and symmetry plane are not creating a closed set of mesh surfaces - the result is that there are not only gaps with no nodes, but I cannot generate a volume mesh. I followed the meshing tutorials and the information did not help me in this case. The only thing that seems to help is increasing the number of points in gap (this improved things but nothing more). I also tried decreasing the mesh size in each of the specific regions on the non-global level.

I have some experience with Star-CCM+, but only with single region fluid flow (no heat transfer). I am trying to learn more about the software and how to create multiple regions and incorporate heat transfer.

I have attached screen shots which help to illustrate my problem.

Any help you can provide me with would be great - Thank you.

James

bengy August 16, 2010 05:58

hi,
welcome in my world i had the same problem:)
you have a typical non-conformal mesh. did you try use only one mesh continuum?

svenne August 16, 2010 09:29

Maybe one of the following hints might help.

- inspect your import mesh prior defining Interfaces. (Surface Repair Tool, NonManifold Edges checked). Boundary between solid and fluid should have blue edges on all perimeters. If not repair the geometry.

- redo your model with only one side of fluid solid interfaces. After importing the geometry, use the "convert to interface" option to fully create the interfaces necessary.

- define feature curves (boundary perimeter) prior surface meshing.

- enable / disable the "project to cad" feature

these are rather guesses, so no guarantee that they will improve anything ;)

karthickeyan August 17, 2010 00:50

Hello james

by creating features curve u can avoid this problem


to create features curve see help in star ccm+

james15 August 18, 2010 10:24

I have tried a few of the things mentioned with no luck:

-Disabling project to CAD did help seal up the outer region (not the ends), that is once i deleted the fluid region.
-I also tried having one interface, but that did not help either.
-I also am using one mesh continum

What i will try next is to play around with feature curves and see where that takes me.

Thanks for the help so far.

James

karthickeyan August 19, 2010 01:10

hi james try this too
 
reduce the mesh size by decreasing the base size in mesh


All times are GMT -4. The time now is 07:12.