CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

ChoosePixelFormat Failed

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 1, 2011, 18:55
Default ChoosePixelFormat Failed
  #1
New Member
 
Nicholas
Join Date: May 2009
Location: Seattle, USA
Posts: 18
Rep Power: 8
nickninevah is on a distinguished road
Hi All

This error started for me right after I upgraded to Star CMM+ 6.02. It happens whenever I have a scene that tries to save to a file. I have three scenes, set to write a picture at every timestep.

A the end of the time step, I received the error message "ChoosePixelFormat failed." Once I clicked OK, the client instance of Star CCM+ immediately shutdown with no other messages or warning. The server process was still running. I had to kill the server process, lose all my work, and start over again.

This has happened every single time that I try to save the scene file. If I turn off the file saving, everything works fine. I've talked to support about it, and they think it is a problem with my video card rendering. Has anyone else had this problem? Anyone know a solution?

System Specs
OS: Windows XP 64 bit Pro
Java: Version 1.6
Star CCM+: Version 6.02
Video Card: nVidia Quadro FX 1700
Card Driver: 6.14.11.9178
CPU: 2 Dual Core Intels
nickninevah is offline   Reply With Quote

Old   April 2, 2011, 13:25
Default
  #2
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 637
Rep Power: 12
abdul099 is on a distinguished road
Can't you just reconnect to the still running server?

Anyway, you might try to run the simulation in batch mode without a connected client. Does the error still occur?
abdul099 is offline   Reply With Quote

Old   April 4, 2011, 18:16
Default
  #3
New Member
 
Nicholas
Join Date: May 2009
Location: Seattle, USA
Posts: 18
Rep Power: 8
nickninevah is on a distinguished road
That's the weird part. I can't reconnect to the server. When I open a new client, the server doesn't show.

Good idea about the batch mode. I will give that a try.
nickninevah is offline   Reply With Quote

Old   April 5, 2011, 14:36
Default
  #4
Member
 
John
Join Date: Aug 2009
Posts: 93
Rep Power: 7
nomad is on a distinguished road
This was an issue in 4.06 and they knew about it. I was hoping they had fixed it in later versions.
nomad is offline   Reply With Quote

Old   April 5, 2011, 21:09
Default
  #5
New Member
 
Nicholas
Join Date: May 2009
Location: Seattle, USA
Posts: 18
Rep Power: 8
nickninevah is on a distinguished road
Really,

That sucks. Any ideas for a work around. I tried running in batch mode; no luck.

Next I was going to try running with the switch
-mesa
in the command line. I'm hoping that will help things.
nickninevah is offline   Reply With Quote

Old   April 6, 2011, 02:07
Default
  #6
Senior Member
 
sail's Avatar
 
Vieri Abolaffio
Join Date: Jul 2010
Location: Always on the move.
Posts: 308
Rep Power: 7
sail is on a distinguished road
try shutting off the hardware acceleration. if this doesn't work try setting up the software to save just one picture per timestep (silly, i know, but i've had problems and that trick sometimes works...)

edit: to turn off the hw acceleration, right click on the desktop, proprieties, advanced, should be somewhere in there...
sail is offline   Reply With Quote

Old   November 15, 2013, 01:31
Default
  #7
New Member
 
Eike
Join Date: Sep 2011
Posts: 18
Rep Power: 5
Eike is on a distinguished road
nickninevah, did that work for you?

I have the same problem with 8.02.008 ... Windows 7, btw.
Eike is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transient boundary conditions Jarrod Sinclair (Sinclair) OpenFOAM Running, Solving & CFD 133 May 6, 2015 06:21
ParaView/Parafoam error when making animation Disco_Caine OpenFOAM Paraview & paraFoam 6 September 28, 2010 09:54
OF 1.6 | Ubuntu 9.10 (64bit) | GLIBCXX_3.4.11 not found piprus OpenFOAM Installation 22 February 25, 2010 14:43
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31
user defined function cfduser CFX 0 April 29, 2006 10:58


All times are GMT -4. The time now is 06:21.