CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > STAR-CCM+

parallel session mpi problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 4, 2011, 16:01
Default parallel session mpi problem
  #1
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
Hello,
I'm running STAR CCM+ 4.04 on a win64 machine.
When I select a new parallel simulation the program says "Warning: no MPI distribution found."
I installed MPICH version which came with the software, it's mpich.nt.1.2.5.exe and registered it with my account.
The system has only one account, without password to enter.
Can someone please help me?

Thanks a lot
ecto is offline   Reply With Quote

Old   April 4, 2011, 18:58
Default
  #2
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
Nobody?
I think this is a common issue in win64
ecto is offline   Reply With Quote

Old   April 5, 2011, 04:48
Default
  #3
Senior Member
 
Join Date: Mar 2009
Posts: 203
Rep Power: 9
Maddin is on a distinguished road
I have no account created and it works. Try without account.
Did you started the server? Firewall allows the access?
Maddin is offline   Reply With Quote

Old   April 5, 2011, 05:48
Default
  #4
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
I have windows 7, and I have one account as administrator. I tried with and without password. Are you talking about the license server? If yes, this it's ok. I also tried with the windows firewall off , no changes. How can I understand if MPICH works correctly?
Now I installed the newer version of MPICH2 for windows 7 64bit, but no changes: "Warning: no MPI distribution found."
What do you think?
Thanks for the help
ecto is offline   Reply With Quote

Old   April 5, 2011, 05:48
Default
  #5
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
I have windows 7, and I have one account as administrator. I tried with and without password. Are you talking about the license server? If yes, this it's ok. I also tried with the windows firewall off , no changes. How can I understand if MPICH works correctly?
Now I installed the newer version of MPICH2 for windows 7 64bit, but no changes: "Warning: no MPI distribution found."
What do you think?
Thanks for the help
ecto is offline   Reply With Quote

Old   April 5, 2011, 05:59
Default
  #6
New Member
 
Join Date: Feb 2011
Posts: 7
Rep Power: 6
mmaukii is on a distinguished road
Had also mpi problems on different systems! What acutally worked on all of them as solution was to reinstall STAR-CCM!
mmaukii is offline   Reply With Quote

Old   April 5, 2011, 06:06
Default
  #7
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
I see... And I should install mpich before or after ccm? Have you got experience on windows 7 64bit?
ecto is offline   Reply With Quote

Old   April 5, 2011, 07:28
Default
  #8
New Member
 
Join Date: Feb 2011
Posts: 7
Rep Power: 6
mmaukii is on a distinguished road
if you install starccm with normal options it normaly installs mpich2 automatically (at least newer versions). For me i had exactly that problem on a win7 64 bit. Tried to install hpdmi and mpich by myself, nothing worked. But the good old reinstallation solved every thing.
mmaukii is offline   Reply With Quote

Old   April 5, 2011, 07:51
Default
  #9
Senior Member
 
Join Date: Mar 2009
Posts: 203
Rep Power: 9
Maddin is on a distinguished road
I understood you wrong - you also can work with accounts in MPI.
There I had problems with using an account.

When you have the config of the MPI open you can check that the server is running.
Maddin is offline   Reply With Quote

Old   April 6, 2011, 04:57
Default
  #10
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
I incredibly managed to make it work!
That's what I did:
download the latest mpich2 installer 64bit on desktop (it's "something .msi")

open the dos prompt with administrator priviliges and go onto the desktop, here use "msiexec /i something.msi" to launch installation of mpich2

install for "everybody"

it works!
ecto is offline   Reply With Quote

Old   April 6, 2011, 04:58
Default
  #11
New Member
 
Join Date: Nov 2010
Posts: 16
Rep Power: 6
ecto is on a distinguished road
And I didn't reinstall ccm+
ecto is offline   Reply With Quote

Old   April 6, 2011, 05:28
Default
  #12
New Member
 
Join Date: Feb 2011
Posts: 7
Rep Power: 6
mmaukii is on a distinguished road
nice. So i know also for the next time an easier way!
mmaukii is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in the CFX12.1 parallel computation BalanceChen ANSYS 2 July 7, 2011 10:26
Parallel UDF problem, hello world version pilou FLUENT 0 March 10, 2011 09:20
A Strange Problem in making Parallel (Ansys/CFX 12) a.sarami CFX 13 October 7, 2010 01:33
problem using property udfs in parallel mode EllenW FLUENT 0 June 23, 2009 17:18
MPI and parallel computation Wang Main CFD Forum 7 April 15, 2004 11:25


All times are GMT -4. The time now is 03:58.