CFD Online URL
[Sponsors]
Home > Forums > STAR-CCM+

Animation in Star-CCM+

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 29, 2011, 12:37
Default Animation in Star-CCM+
  #1
New Member
 
NourFlow's Avatar
 
Nour
Join Date: Jun 2011
Posts: 4
Rep Power: 5
NourFlow is on a distinguished road
Hi all,
I'm a beginner in Star-CCM+ and i need your help
i like to make an animation that shows a moving section plan representing a pressure for example.
i will tell you what i did and it didn't work:
i created a section plan, i created a scalar scene presenting the pressure with this section plan as a part!
For animation settings, i put sweep for animation mode, 10 for cycle time and auto rage to avoid putting start and end values.
it doesn't work
thanks!!
NourFlow is offline   Reply With Quote

Old   June 29, 2011, 16:13
Default
  #2
f-w
Senior Member
 
Join Date: Apr 2009
Posts: 129
Rep Power: 7
f-w is on a distinguished road
Works for me. The reason it doesn't for you might be because of auto range; or, you just don't see the difference due to the high frame rate (change it to 1fps under Scene > Attributes > Animation).
f-w is offline   Reply With Quote

Old   June 29, 2011, 18:35
Default
  #3
New Member
 
NourFlow's Avatar
 
Nour
Join Date: Jun 2011
Posts: 4
Rep Power: 5
NourFlow is on a distinguished road
Quote:
Originally Posted by f-w View Post
Works for me. The reason it doesn't for you might be because of auto range; or, you just don't see the difference due to the high frame rate (change it to 1fps under Scene > Attributes > Animation).
thanks for help! but it doesn't work for me !
i tried it ! and i will explain to problem
i'm simulating a kind of object in a wind tunnel (3 m of width)
my Axes system goes with one corner of the Box presenting the Tunnel.
i created a section plane at Y=0, i can see the pressure plot in different positions (different Y from 0 to 3 m). i like to create a simulation that shows me this plan in different positions by sweeping it in the Y direction.
1/ i created the scalar scene with the section plan Y=0 as a part (i can see the pressure scene)
2/ for simulation i put sweep (the only option available)
3/ cycle time: 30 seconds
end value : 3
start value: 0
auto range : disabled
repeat mode: repeat
4/ in atributes-- animation, i put 1fps
== using this setting, i must have 30 frames per second while my cycle time is 30 seconds but i can see only one frame.

i'm using Star-CCM+ V6 and i have a 9 millions cells mesh.

it may be an easy thing but it doesn't work for me!

thanks for help
NourFlow is offline   Reply With Quote

Old   June 29, 2011, 19:22
Default
  #4
f-w
Senior Member
 
Join Date: Apr 2009
Posts: 129
Rep Power: 7
f-w is on a distinguished road
The process you described is what I did.

Did you remember to play your animation? It won't play on it's own; you have to press the red play button in the animation toolbar.

Also, with 9M cells it might take some time to load each slice ... other than that, if you can see the slices manually, I can't think of anything else at this time.
f-w is offline   Reply With Quote

Old   June 29, 2011, 19:42
Default
  #5
New Member
 
NourFlow's Avatar
 
Nour
Join Date: Jun 2011
Posts: 4
Rep Power: 5
NourFlow is on a distinguished road
Quote:
Originally Posted by f-w View Post
The process you described is what I did.

Did you remember to play your animation? It won't play on it's own; you have to press the red play button in the animation toolbar.

Also, with 9M cells it might take some time to load each slice ... other than that, if you can see the slices manually, I can't think of anything else at this time.
Thanks for answer !
yes i did a preview and i tried also to save it but i get all the time only one frame.
i tried also to save the animation as a PNG frames in order to make an animation with an aother tool but i get two frames with the plot in the Y=0 plane and the other slices as a white pictures!!!
i really thank you for your help and i hope that you write me again if you remenber later something that can solve the problem.

with respect!
NourFlow is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using starToFoam clo OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 33 September 26, 2012 05:04
StarToFoam error Kart OpenFOAM Meshing & Mesh Conversion 1 February 4, 2010 05:38
how to make animation in star ccm *NM* raziftech CD-adapco 3 October 17, 2007 03:35
error in star ccm maurizio CD-adapco 3 October 16, 2007 06:17
Trimmed cell and embedded refinement mesh conversion issues michele OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 2 July 15, 2005 05:15


All times are GMT -4. The time now is 21:07.