CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   STAR-CCM+ (http://www.cfd-online.com/Forums/star-ccm/)
-   -   Automatic exhaust valve closing simulation (http://www.cfd-online.com/Forums/star-ccm/99703-automatic-exhaust-valve-closing-simulation.html)

hamzamotiwala April 10, 2012 02:42

Automatic exhaust valve closing simulation
 
Helo friends,

I am simulating the movement of exhaust valves. I am doing this using mesh morpher in v6.6(I dont have v7.2 installed on the cluster yet).

I define the valve as a solid region and the rest of the geometry as fluid. I set the morpher for solid to displacement and give no morphing to fluid region. I give in a table for the valve movement. I am testing it to move at every 5 seconds. so i divided the table into 1sec values. I change the value for only z coordinate for every 5 second by 1mm.

The problem is that till the first 5secs i.e. till the first displacement of 1mm everything is fine but afterwords it starts moving for every timestep by 1mm. I just dont get it.

The input table looks something like this:

t x y z
0 0 0 0
1 0 0 0
2 0 0 0
3 0 0 0
4 0 0 0
5 0 0 .001
6 0 0 .001
7 0 0 .001
8 0 0 .001
9 0 0 .001
10 0 0 .002

the another variation i tried was :

t x y z
0 0 0 0
1 0 0 0
2 0 0 0
3 0 0 0
4 0 0 0
5 0 0 .001
6 0 0 0
7 0 0 0
8 0 0 0
9 0 0 0
10 0 0 .001

this didnt work either. does anyone have any idea why it keeps moving by 1mm at every time step even when i define not to?

looking forward to some help.

thanks,
Hamza

hamzamotiwala April 10, 2012 08:10

Hello all,

An update to the above problem. There is something wrong with the settings.

Why does my simulation not take the valves into consideration. I mean why does it flow through the valves rather than around it.

I have defined them as wall.

any help would be great.

then I will get back to the moving mesh thing. ;)

thanks
Hamza

hamzamotiwala April 11, 2012 01:32

valves detected.

Can someone now help me with a moving valve simulation please.

Thanks,
Hamza

kri321shna April 11, 2012 03:17

create two different regions
 
hello,
please try with this.

1.create the region for valves (it will create interfaces, or u can do manually), then ur problem will get solve.
2. right click on region and click on "split by Non-Contiguous"

then u can work?

plz inform if this working or not.

hamzamotiwala April 11, 2012 07:30

Hello Krishna,

I didnt really understand how that would help me with the automation of the valves.

thanks,
Hamza

hamzamotiwala April 11, 2012 08:19

Hello once again everyone,

I got the valve to move in z direction using mesh morphing.

I need to move it 9mm in 9 steps.

After 5mm movement, I get an error saying that there are negative volume cells and the simulation stops.

How can I avoid this?

Is there any other way to simulate opening and closing valves in starccm+ ?

thanks,
Hamza

kri321shna April 11, 2012 23:01

thin layer
 
you can use thin layer concept, so that u can avoid negative volumes at valve close position.

janko-hrasko April 15, 2012 17:27

Hi,
what kind of motion do you use?

Currently I am working on motion of piston inside compressor and I have similar problems. I am using morphing in my problem and the solution for your first problem is I think selecting Total displacement in Physics values for your moving boundary.

So far I didnīt find out how to avoid negative volumes in my simulation. I canīt find any remeshing tool during timesteps, so the only way is to make good mesh or do you have any other proposal?

hamzamotiwala April 16, 2012 09:03

Hey,

Thanks for the advice. I will try that.

Although I was able to run the simulation by changing the thinner factor to 0.5. This way I avoided negative volumes but I think its only because by setting this factor low I chose to neglect a lot of cells in the region where morphing is carried out(atleast this is what I understood from it).

the mesh looks aweful. So I dont trust the results completely. (They do tend to tally to the Experimental results though)

I am still open to more suggestions and ideas.

Thanks,
Hamza

abdul099 April 28, 2012 06:49

To avoid negative volume cells, you should try to keep the displacement low for every time step, especially when you're compressing cells or shear them. Depending on the simulation, you also might put some boundaries to floating or in-plane (the latter one works only for planar boundaries).
But always keep in mind, you can't completely avoid negative volume cells. It often depends on the combination of the shape of the domain and the desired motion. E.g. you can't move one side of a very small gap for a very large displacement while the other side just sticks at it's position. In this case, you need to find an option how to move the "sticking" side or you need to remesh frequently.


All times are GMT -4. The time now is 03:29.