CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > SU2 Installation

libiomp5md.dll

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 23, 2013, 07:19
Default libiomp5md.dll
  #1
Member
 
Hossein
Join Date: Apr 2010
Posts: 62
Rep Power: 7
atoof is on a distinguished road
Send a message via Yahoo to atoof
I downloaded SU2 v2.0 64bit to install on windows 7 with 64bit operating system. After installing and running the program, I encounter an error which states liniomp5md.dll is missing and reinstall your program. The error does not disappear when I reinstall the program. How can I solve this problem
atoof is offline   Reply With Quote

Old   January 23, 2013, 17:24
Default
  #2
New Member
 
Abhilash J Markkassery
Join Date: Nov 2012
Location: Texas, United States
Posts: 14
Rep Power: 4
amarkkassery is on a distinguished road
Send a message via Skype™ to amarkkassery
atoof,

You're running the MPI (Parallel version) of SU^2, which needs MPICH2 installed and configured. Please download the Serial version and install it. See if that solves your error.
amarkkassery is offline   Reply With Quote

Old   January 24, 2013, 02:10
Default
  #3
New Member
 
Caner
Join Date: Jan 2010
Posts: 7
Rep Power: 7
Caner is on a distinguished road
I have encoutered same problem. I installed Windows 7 Serial Installer (32 bit). After installation, when I try to run the program this message comes up:

"the program cant start because libiomp5md.dll is missing from your computer.Try reinstall the program to fix this problem"

Thanks for your help in advance
Caner is offline   Reply With Quote

Old   January 24, 2013, 10:25
Default
  #4
New Member
 
Abhilash J Markkassery
Join Date: Nov 2012
Location: Texas, United States
Posts: 14
Rep Power: 4
amarkkassery is on a distinguished road
Send a message via Skype™ to amarkkassery
Caner,

I'm not exactly sure, why that would be. But just to see if it is indeed the exact problem, please go to http://www.mpich.org/downloads/ and download and install your version of Windows (x86/x64).

Let me know if that solves it. If it does, then there's something wrong with the Serial Binaries requiring MPI (It might have been packaged wrong ?)
amarkkassery is offline   Reply With Quote

Old   January 25, 2013, 02:36
Default
  #5
New Member
 
Caner
Join Date: Jan 2010
Posts: 7
Rep Power: 7
Caner is on a distinguished road
Dear Abhilash

Thanks for your reply

I downloaded and installed mpich from the link you sent but it doesnt solve the problem, the same message still comes up
Caner is offline   Reply With Quote

Old   February 28, 2013, 22:47
Default
  #6
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
The same problem, as posted before
Ahmed is offline   Reply With Quote

Old   March 1, 2013, 07:06
Default
  #7
New Member
 
Ron Burnett
Join Date: Feb 2013
Posts: 22
Rep Power: 4
rnburne is on a distinguished road
Had the same problem and the following "nickle-dime" procedure worked (serial version with XP 32bit).
--downloaded the file (5.0.2007.1022), copy/pasted into system32 directory
where most dll's are found
-- run regsvr32 C:\...........\libiomp5md.dll
--it loaded with an error message...."entry point was not found, file cannot
be registered"
Regardless, this solved everything. SU2 installs and runs OK.
rnburne is offline   Reply With Quote

Old   April 3, 2013, 15:08
Default
  #8
New Member
 
Join Date: Mar 2013
Posts: 1
Rep Power: 0
bgodfrey is on a distinguished road
Where do you get the file to download for this fix?
bgodfrey is offline   Reply With Quote

Old   April 3, 2013, 18:51
Default
  #9
New Member
 
Ron Burnett
Join Date: Feb 2013
Posts: 22
Rep Power: 4
rnburne is on a distinguished road
downloaded from www.topdll.com
rnburne is offline   Reply With Quote

Old   April 8, 2013, 05:45
Default
  #10
Member
 
Hossein
Join Date: Apr 2010
Posts: 62
Rep Power: 7
atoof is on a distinguished road
Send a message via Yahoo to atoof
Quote:
Originally Posted by rnburne View Post
Had the same problem and the following "nickle-dime" procedure worked (serial version with XP 32bit).
--downloaded the file (5.0.2007.1022), copy/pasted into system32 directory
where most dll's are found
-- run regsvr32 C:\...........\libiomp5md.dll
--it loaded with an error message...."entry point was not found, file cannot
be registered"
Regardless, this solved everything. SU2 installs and runs OK.
I have installed Serial Installer (32 bit) on XP and did above procedure. Previous error (the program cant start because libiomp5md.dll is missing from your computer.Try reinstall the program to fix this problem) removed but I encounter another message in cmd shell which says "Ther is no configuration file!!". What's the problem??

Hossein
atoof is offline   Reply With Quote

Old   April 8, 2013, 10:40
Default
  #11
New Member
 
Ron Burnett
Join Date: Feb 2013
Posts: 22
Rep Power: 4
rnburne is on a distinguished road
You haven't given us much to work with..... assuming you HAVE a configuration file present, the problem is most likely an improperly named/labeled file or a simple typo error. Also, very good operating instructions are available on Stanford's site.
rnburne is offline   Reply With Quote

Old   April 27, 2013, 00:59
Default SU2_CFD.exe - System Error
  #12
New Member
 
bimuz
Join Date: Apr 2013
Location: san francisco
Posts: 3
Rep Power: 4
bimuz is on a distinguished road
libiomp5md.dll is missing

Same issue.
Installation of Setup-Windows_x64-Serial.exe is successful.
However, I cannot run SU2_CFD.exe or any other *.exe.
bimuz is offline   Reply With Quote

Old   April 27, 2013, 01:31
Default No Configuration file!
  #13
New Member
 
bimuz
Join Date: Apr 2013
Location: san francisco
Posts: 3
Rep Power: 4
bimuz is on a distinguished road
Got error - There is no configuration file!!

in windows7 64bit
bimuz is offline   Reply With Quote

Old   April 28, 2013, 01:18
Default
  #14
New Member
 
cean wang
Join Date: Feb 2013
Posts: 24
Rep Power: 4
ceanwang is on a distinguished road
Quote:
Originally Posted by bimuz View Post
Got error - There is no configuration file!!

in windows7 64bit
Usage: su2_cfd my.cfg

you need to specify one cfg file. they must be in the same folder, also the mesh file.
ceanwang is offline   Reply With Quote

Old   April 28, 2013, 13:57
Default Successful
  #15
New Member
 
bimuz
Join Date: Apr 2013
Location: san francisco
Posts: 3
Rep Power: 4
bimuz is on a distinguished road
Thank you.
First simulation succeeded.
bimuz is offline   Reply With Quote

Old   June 7, 2013, 07:24
Default Does NOT work!
  #16
Member
 
Anonymous
Join Date: Jul 2009
Posts: 42
Rep Power: 8
gerritgroot is on a distinguished road
What's the solution for the missing libiomp5md.dll file?

I installed the serial version on a Win7 64bit machine and the above posts don't give any solution.
gerritgroot is offline   Reply With Quote

Old   July 13, 2013, 20:21
Default
  #17
New Member
 
Nicolas
Join Date: Jul 2013
Posts: 1
Rep Power: 0
ncamachol is on a distinguished road
Download the installer package corresponding to your architecture (x64 or x86). You must have administrator privileges to install. Run the installer and follow the installation wizard which will guide you through the options.
Install the Intel redistributable libraries, located in the Intel sub-directory of your installation, by running the .msi file. You will again need administrator privileges. After installation of the libraries you are ready to run the serial (single-threaded) SU2 programs.
[Optional: only required for parallel solutions] Download, install, and configure MPICH2 1.4.1p1 for Windows by following the instructions in the Windows Installation Guide, paying particular attention to the specific portions regarding Windows 7 setup. It is strongly recommended that users test Windows MPICH2 installations via the provided examples before running SU2 parallel solutions.

http://adl.stanford.edu/docs/display...s+Installation
ncamachol is offline   Reply With Quote

Old   October 13, 2013, 08:28
Default
  #18
Member
 
Hossein
Join Date: Apr 2010
Posts: 62
Rep Power: 7
atoof is on a distinguished road
Send a message via Yahoo to atoof
Quote:
Originally Posted by ncamachol View Post
Install the Intel redistributable libraries, located in the Intel sub-directory of your installation, by running the .msi file.
the error "There is no configuration file!!" again in windows7 64bit.
atoof is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 14:08.