CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > SU2 Installation

error while running SU2 in parallel

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 14, 2013, 10:59
Exclamation error while running SU2 in parallel
  #1
New Member
 
Join Date: Feb 2013
Posts: 12
Rep Power: 4
Abhii is on a distinguished road
Hi

I installed SU2 from sourcecode on the cluster but when I am trying to run it it generates following error file & doesn't generate any output. Could you guys please have a look at it & see if there is something that needs to be fixed at my end.

I used gcc compiler & mvapich2 for compiling my code. code was compiled with arnings but no errors.

Thanks a lot for ur help

Abhii
Attached Files
File Type: txt errorfile.txt (2.7 KB, 34 views)
Abhii is offline   Reply With Quote

Old   March 24, 2013, 00:19
Default
  #2
Super Moderator
 
Francisco Palacios
Join Date: Jan 2013
Location: Stanford, CA
Posts: 301
Rep Power: 5
fpalacios is on a distinguished road
Quote:
Originally Posted by Abhii View Post
Hi

I installed SU2 from sourcecode on the cluster but when I am trying to run it it generates following error file & doesn't generate any output. Could you guys please have a look at it & see if there is something that needs to be fixed at my end.

I used gcc compiler & mvapich2 for compiling my code. code was compiled with arnings but no errors.

Thanks a lot for ur help

Abhii
Have you created the environment variables $SU2_HOME, and $SU2_RUN ?

http://adl.stanford.edu/docs/display...on+from+Source

Best,
Francisco
fpalacios is offline   Reply With Quote

Old   March 24, 2013, 11:08
Default
  #3
New Member
 
Join Date: Feb 2013
Posts: 12
Rep Power: 4
Abhii is on a distinguished road
yes, I created relevant environment variables in my bashrc

Thanks
Abhii
Abhii is offline   Reply With Quote

Old   March 24, 2013, 12:32
Default
  #4
Super Moderator
 
Francisco Palacios
Join Date: Jan 2013
Location: Stanford, CA
Posts: 301
Rep Power: 5
fpalacios is on a distinguished road
It could be a Python issue, could you please run the code manually?
./SU2_CFD {name of the config file}
Does it work?

What's the version of Python and NumPy that you are using?

Cheers,
Francisco
fpalacios is offline   Reply With Quote

Old   May 29, 2013, 13:58
Default
  #5
New Member
 
Join Date: Feb 2013
Posts: 12
Rep Power: 4
Abhii is on a distinguished road
Thanks Francisco

I was on other projects for a while.... how ever I have reinstalled SU2& now I when I try to run it it flags following error message
Quote:
Traceback (most recent call last):
File "/sb/project/sks-412-aa/SU2v2.0/trunk/SU2Py/parallel_computation.py", line 161, in <module>
main()
File "/sb/project/sks-412-aa/SU2v2.0/trunk/SU2Py/parallel_computation.py", line 54, in main
options.output )
File "/sb/project/sks-412-aa/SU2v2.0/trunk/SU2Py/parallel_computation.py", line 83, in parallel_computation
solution_adj_filename = params_get['SOLUTION_ADJ_FILENAME']
KeyError: 'SOLUTION_ADJ_FILENAME'
I used ifort_icc/12.0.4 for compiling the code
& I am using following modules for running

openmpi/1.4.3-intel
python/2.6.7

I would really appreciate if you could let me know as to what is it that needs to be fixed. Thanks again for your help


Regards
Abhii

Last edited by Abhii; May 29, 2013 at 15:52.
Abhii is offline   Reply With Quote

Old   June 4, 2013, 23:19
Default
  #6
New Member
 
Join Date: Feb 2013
Posts: 12
Rep Power: 4
Abhii is on a distinguished road
comment deleted
Abhii is offline   Reply With Quote

Reply

Tags
parallel installation

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
running OpenFoam in parallel vishwa OpenFOAM 22 August 2, 2015 08:53
Problems running in parallel - missing controlDict Argen OpenFOAM Running, Solving & CFD 4 June 7, 2012 03:50
error while running in parallel using openmpi on local mc 6 processors suryawanshi_nitin OpenFOAM 5 May 21, 2012 14:13
Running mapFields with Parallel Source and Parallel Target RDanks OpenFOAM Mesh Utilities 2 June 6, 2011 07:56
Running in parallel crashed zhajingjing OpenFOAM 4 September 15, 2010 07:12


All times are GMT -4. The time now is 10:41.