CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   Tecplot (http://www.cfd-online.com/Forums/tecplot/)
-   -   Tecplot: Multi-Block Visualization (http://www.cfd-online.com/Forums/tecplot/13285-tecplot-multi-block-visualization.html)

Sue April 9, 2007 23:43

Tecplot: Multi-Block Visualization
 
I have a cubic domain with a large number of blocks (of different geometry). Each block, obviously, has its own (i,j,k). Problem is that when I do "animate" for I=1,IM, it does not show the plan scanning from inflow plane (I=1) to outflow plane (I=IM) of the whole domain. Instead, the I-planes sweeps I=1,IM in each block, which is useless (just imagine you have 100 blocks). Is there any way/option is TECPLOT 360 so that I can convert the individual (i,j,k) to a global (I,J,K) - maybe some sort of interpolation over the whole domain. I hope somebody can help me out as I really need to find a solution for this. Thanks. Sue

to April 10, 2007 01:30

Re: Tecplot: Multi-Block Visualization
 
Hi,

Just do a very simple macro. Regards

Sue April 10, 2007 02:10

Re: Tecplot: Multi-Block Visualization
 
Thanks, but could you give me a reference or link, I'm not a TECPLOT pro, so I need something to start with - an example on writing a macro in Tecplot would also be helpful.

Thanks a lot. Sue

Simon April 10, 2007 05:17

Re: Tecplot: Multi-Block Visualization
 
Sue,

I had a very similar problem, albeit in 2D, where I had a 23 block domain for which I wanted to animate the contour data.

I also tried writing a macro, but in the end I used the STRAND ID command in Tecplot 360 which was very straightforward.

I've enclosed a code snippet below from my output subroutine that gives an idea of how to do this. This may help ?

If you have a lot of data to animate, you may want to consider converting your data to Tecplot binary format, either in your code, or as I did, by running the Preplot batch command to automate the conversion. To do this all I did was to copy preplot.exe ( included with Tecplot360 ) to a folder containing my ascii files ( written as .dat ) and run the following in a dos window

for %f in (*.dat) do preplot %f

This will convert all .dat files to binary tho - so be careful.

Hope this helps,

S.

DO 2080 NB = 1,23 ! NB is the block index

WRITE (8000+NB,3020) IM(NB),JM(NB) ! IM and JM are the imax and jmax values for the domain

WRITE (8000+NB,*) "STRANDID=",NB,"," ,"SOLUTIONTIME=", N*TSTEP

DO 2080 J=1,JM(NB)

DO 2080 I=1,IM(NB)

WRITE (8000+NB,3030) xi(I,J,NB),yi(I,J,NB),U_OUT(I,J,NB),V_OUT(I,J,NB), VEL(I,J,NB),MACH_OUT(I,J,NB),P_OUT(I,J,NB),T_OUT(I ,J,NB),RO_OUT(I,J,NB),H_OUT(I,J,NB) 2080 END DO

3000 FORMAT (1X,'TITLE = "X", "Y" ,"U", "V","VEL", "MACH", "P", "T", "RO" ,"H" ') 3010 FORMAT (1X,'VARIABLES = "X", "Y" ,"U" ,"V" ,"VEL","MACH" ,"P", "T" ,"RO", "H" ') 3020 FORMAT (1X,'ZONE T = "1", I = ',I3,2X, 'J= ',I3,2X,'F=POINT') 3030 FORMAT (10(2X,F15.6))

Simon April 10, 2007 05:22

Re: Tecplot: Multi-Block Visualization
 
p.s if you still have problems, I can send you a code sample by email if you give me an email address. S.

Sue April 10, 2007 15:22

Re: Tecplot: Multi-Block Visualization
 
Thanks for the info. I am working on it. Meanwhile, I have another (related) question. In "Slice Detailes", I define all the values, and then when I go to "Animate" and click on "Play" bottom ( > ), it starts displaying the animation but I don't see the slices, all I see is the contour of the entire domain, it's just like nothing is happening. What am I missing here?

Also, is there any way to make a number of slices, say 20, between I=1 and I=IM, but EXTRACTED to ZONE, and automatically, not one by one?

Thanks.

Sue

Sue April 10, 2007 15:53

Re: Tecplot: Multi-Block Visualization
 
Sorry, when I said between I=1 and I=IM, I meant "global" I. To avoid from any confussion, let's say between x=0 and x=Xmax of the whole domain.

Thanks.

S.

> Thanks for the info. I am working on it. Meanwhile, I have another (related) question. In "Slice Detailes", I define all the values, and then when I go to "Animate" and click on "Play" bottom ( > ), it starts displaying the animation but I don't see the slices, all I see is the contour of the entire domain, it's just like nothing is happening. What am I missing here?

Also, is there any way to make a number of slices, say 20, between I=1 and I=IM, but EXTRACTED to ZONE, and automatically, not one by one?

Thanks.

Sue



All times are GMT -4. The time now is 09:50.